ZWave remote?

Hm, I didn’t see any changes witch shows me, that the device is included in the last build (201608130112)?

However, I updated the zwave-binding with this build and with the first start of openhab i also found the zwave-binding -> devices empty. Even after waiting 10 minutes. I restart openhab and after some minutes anything return to normal and the devices appears in the list again. Anything i working fine so far.

I exlude / include the devolo device again, but ist shows up as “devolo [ID:102, Type:100]”. So I think it is not listet in the database of this build. Or did I get the wrong build?

cu - Arndt

Just to clarify: With “I cannot see any devices”, I mean the Nodes in the configuration of the zwave binding.
Also, this line in the log doesn’t log like it’s working ok, does it?

2016-08-14 11:49:47.478 [ERROR] [b.z.i.protocol.ZWaveController] - NODE 1: Restore from config: Error deserialising XML file. : ParseError at [row,col]:[1,1]
Message: Premature end of file.

But I can confirm arndt’s fix. After another restart, the devices are back now for me, too. The remote also shows up as “devolo [ID:102, Type:100]” for me. Config parameters and association groups are still empty.
The build history shows that this commit was included yesterday:
https:// github. com/openhab/openhab/commit/0b439ef742bb92af43f0dd4df5bfb16039269b25
On closer look, that does not seem to be the remote.

This doesn’t mean the binding isn’t working. It means that the XML file saved for node 1 (normally your controller) has not been read correctly). This doesn’t matter.

For the log you showed earlier, it shows the binding is working normally - sorry if I didn’t state that clearly.

It looks like I’ve not added the device to the binding so please create an issue for this so I can track it - there are a lot of requests so it’s hard to track just with the forum - sorry.

Some remarks to the Devolo Remote Control:

  • out of-the-box the battry was weak, 2.4V or so. I found some information about the - device. So the device may having trouble to include correctly if the batery is weak. So check an replace battery if needed.

  • You may bring the device in config-mode pressing all 4 buttons for ~ 5sec. Then you can use:

    Button 1: include/exclude. It is important to place the device close (!) to the controller.
    Button 1 “double click”: include/exclude network wide. Use this, if you can’t place the device next to the controller.

    Button 2: send information frame. Since the device has to “wake up” for communication, this may do the job.

I add an issue as requested :slight_smile:

Thanks for clarifying on the buttons. There also seems to be a “long press button 1” version, which the support hotline told me. I think it worked for me, but I tried both, so I cannot be sure.
My device SEEMS to be included like yours, or do you have configuration parameters and groups? Where would I expect to see events when I press a button?

If the device is “fresh out of the box” or after reset it to factory defaults, then any button should start the inclusion. Maybe. Dunno :slight_smile:

No, groups and parameters are empty. I found that the - version of the remote control is per default in a mode where the buttons are assined to differend groups. To receive an event you have to assign the zwave-controller to that groups. Or you may change the configuration of the buttons to another behavior. Unfortunately we can not do this (comfortably) as long as the device is unkonwn by openhab.

Actually, pressing a button, i get a very short flash of the device-LED in red (should be green if ok say the manual). I think, this will tell us, that the device has no idea where to send the event to. And I couldn’t see any activity on the controller (because it is not included to any groups so far).

Yes, I also see that short flash. I have also seen a state of the device where a short press led to a long red blink. Might have been in the unpaired state.
I thought more about any sign in the logs of openHAB. Ok, so let’s hope it gets included soon, else I’ll send the device back to Amazon - which would be a pity, because from first tests the range seems to be really good.

Please can you provide the model number, and user manual. Is this MT2652?

Declaration of Conformity sheet says MT:2653.
In which form would you like the user manual? The manual is really terrible, though. It doesn’t even give the modelnumber. It basically just tells you to go to the Devolo Home Control Station and follow the instructions there.

Ideally I’d like a PDF file for the manual.

It’s ok - the 2653 is already in the database, so I’ll add it into the OH1 binding…

Ok, just for completeness, the documents can be found here:

That manual is straight from hell and so is the (German) one you find prominently on Google for the device. The latter even contradicts itself with the buttons. I found the information on
to be more complete and valid. Especially, it shows how to do a factory reset. I reset my controller stick due to a problem with another device and wasn’t able to include the remote afterwards. After the reset, a long button press on button 1 activated the include mode and the include went ok. Now I’m just waiting for the database update :slight_smile:

@chris: thanks for adding the device!

After I’ve installed the new zwave-binding I was unable to include/exclude the device. It does not show up, does not reset to factory defaults… So all this try-and-error needs a lot of energy, and the battery was down do 2.6V again. I’ve replaced it. Using a fresh battery, anything is good. The device shows up as a Devolo Keyfob, Groups and Config is presend - and now I get “no item bound for event…” from the node when pressing a button. So I just need to add some items :slight_smile:

I apparently had to press the Node Information Frame sequence 1 or 2 times before it actually showed a name and listed the events.
I now get

2016-08-15 07:30:49.925 [WARN ] [.z.internal.ZWaveActiveBinding] - NODE 5: No item bound for event, endpoint = 0, command class = CENTRAL_SCENE, value = {key=0, scene=1}, ignoring.
2016-08-15 07:30:51.750 [WARN ] [.z.internal.ZWaveActiveBinding] - NODE 5: No item bound for event, endpoint = 0, command class = CENTRAL_SCENE, value = {key=0, scene=2}, ignoring.
2016-08-15 07:30:53.634 [WARN ] [.z.internal.ZWaveActiveBinding] - NODE 5: No item bound for event, endpoint = 0, command class = CENTRAL_SCENE, value = {key=0, scene=5}, ignoring.
2016-08-15 07:30:54.979 [WARN ] [.z.internal.ZWaveActiveBinding] - NODE 5: No item bound for event, endpoint = 0, command class = CENTRAL_SCENE, value = {key=0, scene=4}, ignoring.

for key 1-4.

After changing both pair modes to “Separately”, scene numbers change to 2 3 4 as expected. Occasionally, I get scene numbers 7 and 8, but I cannot pin this down to anything like long press or double click.

I do not see an example for this. How do the items have to look?

Although I don’t have this remote, I’m pretty sure it works the same way like in this example:

To find out your scene number you need to switch to debug mode, press the appropriate button and then take a look into the openhab.log, it should show you the scene number …

This doesn’t sound like it’s anything at all to do with the binding. Also, when you change to a new binding, you don’t need to exclude and include the device - just change the binding.

That’s normal. The binding needs battery devices to wake up a few times so that it can query all the information it needs, and also to configure certain information.

@chris: No, that was not a problem of openhab or binding, it was caused by the empy battery. I just wand to make clear: if there is a strange behavior while including/excluding a device like this, check the battery :slight_smile:

@kmv: looking good so far.

If you change to “separately”, keys are assigned to scene 1…4. In “pair” - mode, the button-numbers and scene-numbers are not the same, but you also can choose “pair with double click”. Then you get additional scene numbers by double clicking a button. Such like 7 and 8… Using this setting you can “enhance” the 4-button remote to a 8 button :slight_smile: