Zwave Roller Shutter control

I need some advice for zwave control units for roller shutters.
I wish they were fully compatible with openhab, they had the 2 input for physical buttons and that you could choose the desired % opening and opening status.
Is there any model that has the ability to do a firmware update via openhab?

I’m not really sure I understand this. I believe that there are a lot of rollershutter controllers that work with openHAB. They all have different features.

No - most suppliers do not supply OTA firmware updates and until this changes there’s not a lot of point in supporting OTA upgrades in the binding.

1 Like

I had considered the following models:
-Fibaro FGR-223 but I have read in various posts having problems with the status of the shutter position, has it been solved?
-Zipato Micromodule Motor Controller is compatible?
-Aeotec nano shutter doesn’t seem to have the consumption detection so I don’t think it has the position in%.
-Widom Roller Shutter, any experience of use?
I would like advice on which device to choose according to your experience so that it is fully functional out of the box with normal configurations.
Thank you.

I think @sihui uses Fibaro

I have several FGR222 which work without any issues.


Is it possible to create a group for controlling (up/down/stop) all the zwave roller shutters present as items in openhab?
Some examples?

Sure, standard procedure in the docs:

Group:Rollershutter gRollershutterAll <rollershutter>
Group:Rollershutter gRollershutterLiving <rollershutter>  
Group:Rollershutter gRollershutterKitchen <rollershutter> 
Group:Rollershutter gRollershutterSouth <rollershutter> 
Group:Rollershutter gRollershutterWest <rollershutter> 

Rollershutter FibFGR222_Kitchen_East "Küche Ost [%d %%]" (gRollershutterAll, gRollershutterKitchen) { channel="zwave:device:uzb:node11:blinds_control", autoupdate="false" }
Rollershutter FibFGR222_Kitchen_South_L "Küche Süd L [%d %%]" (gRollershutterSouth, gRollershutterAll, gRollershutterKitchen)  { channel="zwave:device:uzb:node12:blinds_control", autoupdate="false" }
Rollershutter FibFGR222_Kitchen_South_R "Küche Süd R [%d %%]" (gRollershutterSouth, gRollershutterAll, gRollershutterKitchen) { channel="zwave:device:uzb:node13:blinds_control", autoupdate="false" }
Rollershutter FibFGR222_Living_South "WoZi Süd [%d %%]"  (gRollershutterSouth, gRollershutterAll, gRollershutterLiving) { channel="zwave:device:uzb:node32:blinds_control", autoupdate="false" }
Rollershutter FibFGR222_Living_West_L "WoZi West L [%d %%]" (gRollershutterWest, gRollershutterAll, gRollershutterLiving) { channel="zwave:device:uzb:node33:blinds_control", autoupdate="false" }
Rollershutter FibFGR222_Living_West_R "WoZi West R [%d %%]" (gRollershutterWest, gRollershutterAll, gRollershutterLiving) { channel="zwave:device:uzb:node34:blinds_control", autoupdate="false" }

Switch item=gRollershutterAll label="Grp EG" mappings=[UP="Auf", STOP="X", DOWN="Zu"]
Switch item=gRollershutterLiving label="Grp WZ" mappings=[UP="Auf", STOP="X", DOWN="Zu"]
Switch item=gRollershutterKitchen label="Grp Küche" mappings=[UP="Auf", STOP="X", DOWN="Zu"] 
Switch item=gRollershutterSouth label="Grp Süd" mappings=[UP="Auf", STOP="X", DOWN="Zu"] 
Switch item=gRollershutterWest label="Grp West" mappings=[UP="Auf", STOP="X", DOWN="Zu"]

I tried to create the group of all the shutters and without doing the mappings function I see the arrows and the X.
In the single definitions for the shutters in the configuration file .sitempaps, I wrote Default, but if I do it with the group I don’t works, putting switch as indicated by you works, what’s the difference?

Trying the Group function, I see that the controls for the 6 shutters are slow from each other and many times they don’t work or I see that the roller shutter unit goes offline and I have to switch it off and on again, this happened to me even when I tried the association groups.
Is it possible that the zwave network is full with 6 devices?
Can I make some changes such as polling? Thanks.

I have no idea what you are talking about, sorry. My example works, if you are adapting that to your system it should work too. If you are changing something it may not work and you need to read the docs.

Then you have a problem, please provide debug logs showing this.

No, people are using zwave with around 150 devices on one controller without problems.

Lots of questions!

First, you mention that some roller shutter modules are reported as OFFLINE. That could mean several things. What is the distance from the Z-Wave controller to the roller shutter modules? Is there reinforced concrete or metal shielding in the path? Did you recently reset and reconfigure one of your Z-Wave roller shutter modules?

To my knowledge, Z-Wave by design doesn’t implement status reporting as a measure of bandwidth optimisation. You can however easily add polling yourself by periodically send the REFRESH command to the Z-Wave roller shutter item.

Keep in mind though that, due to the ‘conservative’ messaging in Z-Wave, you won’t be notified when a remote operated a blind, Unless you poll the status from time to time.

Sorry, I don’t get that. I don’t have to poll (manually or by rule) any devices to get the actual status of my rollershutters when operated outside of openHAB if the associations groups are set correctly.

1 Like

The roller shutter modules are close to the aeotec USB stick, the farthest will be 15 meters and in the middle there are the others and I have no metal or other shields.
Now they are configured without the groups of associations and if I use the physical keys they always work, only a couple of times have the modules been blocked and I had to turn them off and turn them on again.
If I use the modules with OpenHab they work individually but yesterday trying the groups to manage with a command all together, they start to move, then some are blocked or don’t move and go in offline, even if I turn off the raspberry they get stuck and I have to switch off and on again.
Yes, for this problem I have excluded 2 or 3 times one of the modules to make tests.

The default polling for each setting of each device is set: Polling Period: 1 day and Command Poll Period: 1500.
If I can do more tests, later I could do it.

Which association groups besides 1: Lifeline are needed for reporting the position at all times without polling?

The ones dedicated to the controller. The naming is determined by the user who adds that association group to the database. Mostly it is “Group 1”, “Group 3” (for a lot of Fibaro devices), “Reporting” or “Controller”.

To my knowledge, the association groups are defined by the Z-Wave devices. It’s not something I can define myself (it’s a device / controller property).

The FGR-223 (Firmware v5.1) has 3 association groups defined:

  • 1: Lifeline (1 node can be assigned - is set to 1: Controller)
  • 2: Roller Shutter (up to 5 nodes can be assigned - left blank)
  • 3: Slats (up to 5 nodes can be assigned - left blank)

Correct. But still you have to define it in the database and give it a name.
Your are talking about zwave plus devices: the binding will set the association group of plus devices to the controller automatically.
But there are still devices out there where you have to set the association group to the controller manually.

Before Chris changed the code of the zwave binding to have the association groups set automatically we had five or more posts in this forum every day with “My item status does not update, what am I doing wrong” :grinning:


If I tried to start from a new installation and using openhabian instead of installing from Apt would it be advised to also reset the zwave stick?
For the default polling values ​​shown above, do I need to change them?

There should be no need to reset the stick. The Z-Wave network is stored on the stick. You should just need to add the controller & set the port. Discovering devices again should find all your Z-Wave devices.
If you are going to re-use Items from your old installation, be sure to give your stick the same ThjingId as the old one. The device ThingIds are based off the stick.

1 Like

I started from a new clean installation, installing the stable version of openhabian and searching in the zwave network for my roller shutter widom devices now tells me unknown device.

Before use zwave bindings I reset the zwave usb.

In the compatibility page of the documentation I find the device:

In fact I used it even before moving on to the milestone but now I want to use the stable versione.
Why now I don’t have compatibility?

Sitemap -

Because the default widget for a Group is to display the group members with a click.
If you want non-default e.g. a Switch widget, you have to say so in the sitemap.

Because you’ve downgraded zwave binding version. There has I think been quite a bit of work with rollershutters in this binding since 2.4