Zwave thing can not be added - duplicate channel error

Hello!

I’ve have 2 Zwave switched. One is a dimmer switch the other one is a binary switch (On/off)

They have been set, assigned and working but for some improvements i’ve had to swap the zwave modules.
Put the dimmer to the place of normal switch, and put the normal switch instead of the dimmer.

To rediscover the things in OH3, I’ve deleted the things and have tried to add them again with the proper name and grouping etc.

The problem is I was able to add the dimmer but I’m not able to add the switch to the system because it does show that the scene number is duplicated.

I’ve checked and there is no node12 in the system at the things section… Also have checked my items files (since i’m useing VSCode do define items and groups etc) but no problem there. The things and items are deleted for node12 so it should be able to add.

The error message is this when I’m trying to add it to the system with “auto detect”

2022-06-13 15:29:16.827 [ERROR] [ore.internal.discovery.InboxResource] - Thing zwave:device:0372d50f:node12 unable to be approved: Duplicate channels zwave:device:0372d50f:node12:scene_number

What am I missing?!
Can I check somehow what are the used channels except if I open the items and check the channel for all items?

Why? Simply moving them from one physical location to another doesn’t remove them from the Zwave mesh network. By default over night a network heal would run and their new physical location would be accounted for.

I’ve never seen an error like this so I don’t have a whole lot to offer. I’d stop openHAB and look in $OH_USERDATA/zwave for node12.xml. If it exists delete it.

Then I’d grep through the files in $OH_USERDATA/jsondb and see if node12 is in any of those files. If it’s one of the Things files (Thing or Links) I’d maybe try to manually remove that entry. Be very careful doing this as a typo can mess up the whole file. Also make certain that node 12 refers to the Zwave Thing.

That should purge all reference to that node. Then rerun the discovery and acceptance of the Thing.

After the phisical swap, they were doing automation incorrectly, although I’ve replaced the node numbers in the .items file. That is why I’ve though that starting from “zero” could solve things without major debugging.
I’ve already tried to update OH3 with all components, and the restart :slight_smile:
Thanks for the hint, I’ll check those files!

Incorrectly how?

That’s completely unrelated to the error.

The door sensor was triggering the “zwave switch” to turn on the light. (node12). After I’ve edited the items file it was turning the “garage lights” on. (node26).

This was before the “can not add duplicate channel… error”

I’ve tried to edit the files and restarted OH but the problem still persists. :frowning: maybe I need to extend the zwave log level

I can’t help more except to say that if you don’t have rules in play here you’ve set up some zwave association groups. And something there is probably causing problems.

There may be a problem in the Z-Wave database - possibly an incorrect definition for your device.

Please identify your device.

Hello!

The device is an MCO MH-S220 Micro Switch

EU Version

OpenSmartHouse Z-Wave Device Database This is the device in the zwave database

There are two entries in the database, which logically result in two hits for devices with version > 3.2:

@chris Please have a look at this.

If this is really the problem, the database should catch this in the future. If there are more duplicates of this kind (two ore more database entries for devices with the same ‘Reference’ and ‘All versions’ and subset(s) of versions), they should be fixed.

I’ll take a look, but I don’t think the two entries will cause a problem since the system will find one or the other as they will definately have different thing IDs.

The more likely problem is that one of these two entries has the same channel defined more than once (since the error is duplicate channel). I think if the same thing was defined twice, then binding will not start at all.

The newer device had the scene channel defined twice - I’ve now fixed this.

1 Like

It is strange that this thing is not yet added to the system and when I try to add it then it gives me an error.
Maybe there is some “stuck” data left in the system, since this was already added, then removed and now it can not be added again.
The problem is I do not know where to check if this channel is already “stucked” somewhere or assigned somewhere.
Searching the whole openhab/userdata/ and sys/ folders for node12 only give hits for /zwave and /jsondb folders. Even deleting the node12 network file from /zwave and, editing the discovery file in jsondb folder does not give me any success.

This is not relevant - the device is part of the network, so the binding will still communicate with it.

Yes, because there is the error in the database I mentioned earlier.

You will need to use an updated binding once I update it in a few days.

I see!
Thanks everyone for helping me (possible others too) and for your great work!