ZWave Wrong identification of manufacturer / model of Door / Window sensor

Tags: #<Tag:0x00007fc8faae05e0> #<Tag:0x00007fc8faae0220> #<Tag:0x00007fc8faae0018>

First make sure you properly uninstalled the stable binding.
Then perform a bundle:start XXX where XXX is the number from your installed, but not active snapshot binding.

You may need to also install the serial transport dependency:

Add your controller as Thing and then set the correct port in the properties of that Thing.

Thank you very much.
I did as you told and indeed it is active now.
btw, I started learing using the karaf console and it is great. I’m extending my openhab knowledge all the time.

There is (hopefully) one problem.
I added the z-wave controller to my ‘Things’’, but when configuring it, the “serial port” field is missing - so I can’t set it to /dev/ttyAMA0.

Thanks again,
Meir.

This is how this Z-Wave controller config looks:
image

The “port” field is missing

Normally, this is what you will see if the binding is not running - is the controller online? If not, what is the state? Are you sure the binding is running (I know you said it is, but, just checking… :wink: )?

You are right
I did bundle:start 186 (my zwave id) and went to Paper UI, Clicked Add thing and saw the Z-Wave Contrtoller Thing.

But now I ran again the following command and it is “Installed” and not “Active”

bundle:list | grep ZWave

186 │ Installed │ 80 │ 2.4.0.201809291432 │ ZWave Binding

I nran also the thins list:
smarthome:things list

.
.
.
zwave:serial_zstick:ed57d759 (Type=Thing, Status=UNINITIALIZED, Label=Razberry Board 2016 Z-Wave Controller, Bridge=null)
.
.
.

Normally a bundle won’t start if it’s missing dependencies. I think the only dependency that is likely to be missing is the serial driver.

Try typing feature:install openhab-transport-serial in karaf and see if it starts.

Something wiered:

I did the followings:

  • feature:install openhab-transport-serial
  • bundle:start 186
  • bundle:list | grep ZWave (186 │ Active │ 80 │ 2.4.0.201809291432 │ ZWave Binding)

but few hour later it went back to installed state

and gain it “complained” on the missing “gnu.io

Clear the cache

and install the serial transport again (has to be performed after each clearing of tmp and cache)

This is what is installed by the serial feature, so I guess this is being removed somehow.

  • I stopped the OH service (sudo systemctl stop openhab2.service)

  • I cleaned the cache (both cache and tmp sub directories)

  • I ran OH service (sudo systemctl stop openhab2.service)

  • I ran the console (sudo openhab-cli)

  • I imported the transport serial (feature:install openhab-transport-serial)

  • I started the ZWave bundle (bundle:start 189)

  • I checked that it is active (bundle:list | grep ZWave ===> 189 │ Active │ 80 │ 2.4.0.201809291432 │ ZWave Binding)

  • I configure the port:
    image

  • I got “Server Internal Error” message:

  • looking at the openhab.log is see this error:
    2018-09-30 12:23:30.432 [ERROR] [st.core.internal.thing.ThingResource] - Exception during HTTP PUT request for update config at ‘things/zwave:serial_zstick:ed57d759/config’
    java.lang.IllegalStateException: Thing with UID zwave:serial_zstick:ed57d759 has no handler attached.
    at org.eclipse.smarthome.core.thing.internal.ThingRegistryImpl.updateConfiguration(ThingRegistryImpl.java:94) [108:org.eclipse.smarthome.core.thing:0.10.0.oh230]
    at org.eclipse.smarthome.io.rest.core.internal.thing.ThingResource.updateConfiguration(ThingResource.java:425) [118:org.eclipse.smarthome.io.rest.core:0.10.0.oh230]
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:?]

Never seen that error, are you sure you have the correct port?

Check via dmesg | grep tty

did
sudo dmesg | grep tty

got
[ 0.000000] Kernel command line: 8250.nr_uarts=1 bcm2708_fb.fbwidth=1824 bcm2708_fb.fbheight=984 bcm2708_fb.fbdepth=16 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3f000000 vc_mem.mem_size=0x3f600000 dwc_otg.lpm_enable=0 console=tty1 root=PARTUUID=e9283127-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
[ 0.000809] console [tty1] enabled
[ 0.894026] 3f201000.serial: ttyAMA0 at MMIO 0x3f201000 (irq = 87, base_baud = 0) is a PL011 rev2
[ 2.628378] systemd[1]: Created slice system-getty.slice.

Looks good, no more ideas.
Edit: Does your openhab user belong to tty group?

Yes, I added it to tty and dialout groups

When the OH 2.4.0 release is expected.
If it is less than a month from now I’ll wait for it.
Or, may be I’ll move the snapshot releases?

I’m not 100% sure as it’s not been discussed yet in the maintainers discussions, but over the past couple of years, there have been 2 releases per year - one in December, and one around June. So, I would guess December…

You don’t necessarily need to move to the snapshot if you don’t like the idea of this - you can also use the milestone builds which are updated periodically (about every month) and M4 was released very recently. I’m not sure if you need a very recent version of the binding or not (ie if we’ve made any database updates that you need in the past week or so) - if not, M4 might be a good option for you.

Thanks,
I’ll wait for M4.

M4 is already available - it was released a week or so back.

Thanks.