1.7.1 to 1.8 upgrade not happening?

I do sudo apt-get update and then sudo apt-get upgrade but it does not find anything to upgrade.
And deb http://dl.bintray.com/openhab/apt-repo stable main is addaed to the sources.list and looks as it is fetched when updating. Any hint on what is happening ?

pi@rpi-openhab ~ $ sudo apt-get update
Get:1 http://dl.bintray.com stable Release.gpg [821 B]
Hit http://raspberrypi.collabora.com wheezy Release.gpg
Hit http://archive.raspberrypi.org wheezy Release.gpg
Hit http://mirrordirector.raspbian.org wheezy Release.gpg
Hit http://raspberrypi.collabora.com wheezy Release
Hit http://mirrordirector.raspbian.org wheezy Release
Get:2 http://dl.bintray.com stable Release [3,695 B]
Hit http://repo.mosquitto.org wheezy Release.gpg
Hit http://archive.raspberrypi.org wheezy Release
Hit http://repo.mosquitto.org wheezy Release
Hit http://raspberrypi.collabora.com wheezy/rpi armhf Packages
Hit http://mirrordirector.raspbian.org wheezy/main armhf Packages
Get:3 http://dl.bintray.com stable/main armhf Packages [20.5 kB]
Hit http://archive.raspberrypi.org wheezy/main armhf Packages
Hit http://mirrordirector.raspbian.org wheezy/contrib armhf Packages
Hit http://repo.mosquitto.org wheezy/main armhf Packages
Hit http://mirrordirector.raspbian.org wheezy/non-free armhf Packages
Hit http://mirrordirector.raspbian.org wheezy/rpi armhf Packages
Ign http://raspberrypi.collabora.com wheezy/rpi Translation-en_GB
Ign http://raspberrypi.collabora.com wheezy/rpi Translation-en
Ign http://dl.bintray.com stable/main Translation-en_GB
Ign http://repo.mosquitto.org wheezy/main Translation-en_GB
Ign http://archive.raspberrypi.org wheezy/main Translation-en_GB
Ign http://dl.bintray.com stable/main Translation-en
Ign http://repo.mosquitto.org wheezy/main Translation-en
Ign http://archive.raspberrypi.org wheezy/main Translation-en
Ign http://mirrordirector.raspbian.org wheezy/contrib Translation-en_GB
Ign http://mirrordirector.raspbian.org wheezy/contrib Translation-en
Ign http://mirrordirector.raspbian.org wheezy/main Translation-en_GB
Ign http://mirrordirector.raspbian.org wheezy/main Translation-en
Ign http://mirrordirector.raspbian.org wheezy/non-free Translation-en_GB
Ign http://mirrordirector.raspbian.org wheezy/non-free Translation-en
Ign http://mirrordirector.raspbian.org wheezy/rpi Translation-en_GB
Ign http://mirrordirector.raspbian.org wheezy/rpi Translation-en
Fetched 25.0 kB in 11s (2,199 B/s)
Reading package lists... Done
pi@rpi-openhab ~ $ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
pi@rpi-openhab ~ $

You did “sudo apt-get update”, but not “sudo apt-get upgrade”, I got the same results you did… I got mine upgraded, but I cannot get the web interface to load my sitemaps… I get the background to the web interface, but no items from my sitemap.

Look at my terminal sniplet I DID sudo apt-get upgrade after update. Just nothing happens.


In your terminal snippet, I didn’t see a sudo apt-get upgrade… sorry…

@xsherlock I’ve just tested the upgrade with my Pi and it worked. May be you just tried to upgrade to early.
Please try it again.

I am having the same problem. I also checked my sources.list file. Curiously, a few days ago, I was having the signature problem, and so I waited until others reported it working (I’m talking about this discussion).

Which distro are you using?

I’m not sure I know what you’re asking. Sorry. Noob here. I was running OH 1.7.1. I may have just messed it up as I tried sudo apt-get install openhab-runtime. That may have worked as I now can’t see any pages that had multiple dimmer sliders in the UI. But at startup, it still says openHAB runtime has been started (v1.7.1).

Sorry, I meant “which linux distro”.
Can you check the output of
sudo dpkg -l|grep openhab

My fault. I’m using a raspberry pi 2. I’m not sure how to tell exactly which distro I have. Dpkg says 1.8.0.

Update: I ran sudo dpkg -l|grep debian and got multiple results. sudo dpkg -l|grep raspian returns nothing. Not sure if this is helpful.

Sorry for being unclear again.
sudo dpkg -l|grep openhab
queries the openhab version.

cat /etc/issue
should print information about the linux distro.

Could you post the output of these two commands?

I appreciate your patience. Here are the results:

ii openhab-runtime 1.8.0 all openHAB Distribution

Raspbian GNU/Linux 8 \n \l

Ok, your running openHAB 1.8.0.
From where did you pick this information?

i’m running the RPI2. and surprisingly the second line does not return any optput, but openhab 1.7.1 is definitely running on my setup.

pi@rpi-openhab ~ $ cat /etc/issue
Raspbian GNU/Linux 7 \n \l

pi@rpi-openhab ~ $ sudo dpkg -l|grep openhab
pi@rpi-openhab ~ $

This is very stock RPI2 and to install the open hab I followed this guide

And the update upgrade still does not upgrade my instalation.

From the text that flies by after I start OpenHAB via sudo /opt/openhab/start.sh

2016-01-13 17:59:55.272 [INFO ] [.o.core.internal.CoreActivator] - openHAB runtime has been started (v1.7.1).

That’s what I followed several months ago. I am beginning to think I should start over and follow the official instructions.

Strongly recommended! :smile:

1 Like

I’ve backed up my configurations directory. Are there any other files or directories I should backup before erasing the SD card and starting over? I haven’t done much. Two z-wave lights and some hue lights.

Any file you’ve changed, but they are usually in the configurations directory. You might want to save your Z-Wave database, but it will be rebuilt if you don’t.

While I’m writing new posts came in but I send my reply anyway.

I think it’s pretty clear now. You both mixed things up. You did a manual installation and tried to upgrade it using the apt installation, which isn’t possible. @xsherlock only has the manual installation because he only used the apt-get upgrade command. @Domino has two installations because he used the apt-get install command to try the upgrade.

If you want to stay with your manual installation you have to manually upgrade it.

If you want to go with the apt installation it is described here apt installation instructions. If you want to keep your configuration move the items, rules,… files from /opt/openhab/configurations to /etc/openhab/configurations/… directories.