A single distro from now on!

This post was flagged by the community and is temporarily hidden.

Martin,
I also use the 1.9 version of the astro binding. When I look at the PaperUI I see both the 1.9 and 2.0 versions. Do you use the offline version. I saw above if you want the offline distro. you need to do the following commands:

sudo apt-get install openhab2-addons
sudo apt-get install openhab2-addons-legacy

Hi

I downloaded the snapshot, unpacked it and started openhab und a Windows 7 64bit professional system.
In the console everything loojed fine, got the openhab logo an so on.
Then i tried localhost:8080 an got the following line.

Error 404 - Not Found.

No context on this server matched or handled this request.
Contexts known to this server are:
/8199 —> org.mortbay.jetty.webapp.WebAppContext@1db05b2{/8199,file:/C:/Program%20Files%20(x86)/WEKA/Energieaudits%20in%20kleinen%20und%20mittleren%20Unternehmen/webapp/}

This also happend some time ago with the offline distro and demo package.

Maybe some of you have an idea what I´m doing wron.

Thx

Hi @Daniel_OH , You can’t place it in a location that has spaces. Such as “Program Files” for example. Try moving it away and seeing if that works better.

This post was flagged by the community and is temporarily hidden.

I did a clean install wiping my userdata folder. Now it is working.

Is the new .deb package expected to work on Raspbian Jessie Lite as a starting point on a Pi2B? I still can’t find any reason why the runtime loads up Karaf and doesn’t go further (no logs, no listening ports except the Karaf shutdown and Java remote debugging port). If I either start the openhab2 service or do this by hand

pi@habpi2:/usr/share/openhab2 $ sudo -u openhab ./start_debug.sh
Launching the openHAB runtime...
Listening for transport dt_socket at address: 5005

no further progress is made in starting up.

does this have anything to do with this?: https://github.com/openhab/openhab-distro/pull/356#issuecomment-268740854

did you completely overwrite the /userdata/etc/ with your “old” files? - if yes, this could be the problem…

Yep, that’s the same configuration I used to test. I’m honestly baffled by why it’s not working for you. Is anything else running java?

Solved, but not sure what was wrong exactly, by removing JDK8 and installing it again, with steps like this:

sudo apt-get purge oracle-java8-jdk
sudo apt-get purge oracle-java8-installer
sudo apt-get install oracle-java8-installer

Somehow ended up with an apparently working java environment, but had this effect. Thanks again for your help.

1 Like

Strange indeed! But, glad you got it sorted!

1 Like

Hello

Yesterdy I tried the new single distro, and because I was curios, I chose the simple package.
It woud be no problem, to download the distro agein and start from the beginning, but I was wondering if there is an easyier way to choose an other package? How can I get back to the initial setup an choose the standard package?

THX

I’m sure there is a setting somewhere down in the userdata folder. But you can manually set the package by changing the package parameter in your services/addons.cfg folder. The comments in that file indicate valid values.

Are you saying that this distro should use or relies on systemd ?

Hi, I didn’t try it but I think you can edit your userdata/etc/org.openhab.addons.cfg file and set the “package” setting to “standard”. At least it’s the setting in my org.openhab.addons.cfg:

package = standard
ui = basic,paper,habmin
...

Nope, but in his case it was. If you’re using sysVinit (init.d), then can use that.

Sorry, maybe my fault - but with paper ui i cant download anny persistence addon and i cant any addon folder to manually place the addons.

Hi

i tried it as you sugessted. It didn´t change anything, so i decided to reinstall it.
For mi this was the easyiest way.

thx

Actually, the package selection does nothing else than creating the file userdata/etc/org.openhab.addons.cfg. So if you delete this file and set a different package in conf/services/addons.cfg it will create a new file with the addons specified of that package. But there really isn’t a need to switch package, because you can simply change the installed addons yourself at any time and for your personal needs.

1 Like

This information would actually nicely fit at the end of this documentation article, wouldn’t you agree?

http://docs.openhab.org/configuration/packages.html