Add Z-wave Controller to Synology NAS Install - Serial Error: Port /dev/ttyACM0 does not exist

  • Platform information:
    • Hardware: Synology NAS DS916+ / Aeotec Z-Stick Gen5
    • OS: DSM 6.2.2-24922
    • Java Runtime Environment: Java8 1.8.0_241
    • openHAB version:
  • Issue of the topic:
    I’ve installed OpenHAB to my Synology NAS which seams to work fine.
    As a next step I’m trying to add a Z-wave controller (Aeotec Z-Stick Gen5) to the setup.
    Adding the binding worked fine but configuring the Serial Port doesn’t work.
    I’ve used port /dev/ttyACM0 but receive the following error: Serial Error: Port /dev/ttyACM0 does not exist

Following some information I found on this community this probably has to do with insufficient rights for the openHAB user. I’m not a Linux expert but tried the following:

  • Via SSH logged in as admin on the NAS (ls -l /dev/ttyACM0) I receive the following info on which I assume is the serial port for my Z-wave controller USB stick:
    crw------- 1 root root 166, 0 Apr 14 19:32 /dev/ttyACM0

  • I have difficulties in changing the access rights for my openHAB user for this port following the instructions I found on
    Can somebody help on this?

You likely have a group permissions issue. Only users in the root group have access to that device. Is your openhab user in that group?

I had a similar issue, i resolved it with : sudo chmod 777 /dev/ttyACM0
I bookmarked this link as reference: [SOLVED] Synology Zigbee Binding and CC2531 Stick - "failed to open the dongle"

That opens up the security to any rogue program running on the NAS.

1 Like

And as said in the original posting, it’s only a test. The correct way to solve this problem is to use a udev rule to change ownership and permition.

Take a look at

Yesterday I’ve rebooted my NAS before making any further configuration. Strangely enough my controller came online. But when checking the access rights on the port I still get this:

crwxrwxrwx 1 root root 166, 0 Apr 17 08:21 /dev/ttyACM0

When removing the controller and pluging it back in, it goes in an offline state and I have to reboot the NAS again.

I look into the udev rule now.

Here’s a straight forward and easy solution that worked for me.

Go here:

Click on your Synology device and download “UsbSerialDrivers DSM 6.2 v6-7”.

These are the drivers that come with the Domoticz package. When you ditch Domoticz (because you just could not take anymore of it) you will apparently also loose the serial port configuration. You can get it back by just installing this package.

Perform a manual install in package manager of this package. Ignore the confusing rap which will not show you any encouraging results anyway would you be so couragous to follow up on them (there is no need to SSH into anything).

After installation, reboot your Synology.

Go back into OpenHAB to your ZWave stick configuration and find /dev/ttyACM0 is now provided as an option in the dropdown list. Choose it, save.

Give it a minute. OpenHAB will automatically start searching for ZWave devices and report what it found.