Amazon Echo Control Error "Web socket close 1005" - Still happening on 3.2.0

322 │ Active │  80 │ 3.2.9                 │ org.smarthomej.binding.amazonechocontrol

My recommendation would be to clear the cache and tmp directories as the next steps.

I’m assuming you put the other commons jar in the addons also?

Best, Jay

Thank you! Solved the issue for me.

More discussion here

I rebuild the container and now it seems to work. fingers crossed

btw: great work and thanks

Thanks for posting the updated binding, Jay! And thanks, Mark, for the link to the other thread. I ended up installing the new binding by adding the json third-party addon file in the settings, and using the UI to install it like any other binding (after first removing the one that ships with 3.2, of course.)

Everything is working smoothly now. No more websocket errors.

Are the updates in this binding set to be added to the next official release?

Looks like this might solve two problems in one go (web socket 1005 and delayed response to commands). However, I can’t log in. I get: Login to '' failed: Request failed.

My account is registered with but I’m not convinced that is the problem because it recognises me enough to ask for my OTP, it just fails after that. If I disable 2FA, it fails right after the password screen.

Why is the smarthome/j version not merged into the main openhab? Why keeping a separate repo/version?

There are different views on technical and administrative/organizational aspects.

1 Like

Same thing here, however, I’m registered with

I’ve got mine working. Reinstall the version that can log in, get logged in and then install the latest - it remembers that you are logged on.

3.2.10 also fixed the login.

Great. I was waiting over the weekend so used the workaround with 3.2.9.

Where can I get this build (3.2.10)?

If you’re on openHAB 3.2.0 or later, you can add “” in the “JSON 3rd Party Addon Service” section in the settings page of the UI.
Once that is saved, go to the bindings page and you’ll see a new section with the 3rd Party Addons. You’re looking for the SmartHome/J variant of the Amazon Echo Control Binding.
Be sure to uninstall the regular one before you install this one!

1 Like

Nice. I was able to install it but can’t sign in to amazon. I got this error

HTTP ERROR 500 java.lang.NullPointerException
URI:	/amazonechocontrol/adef560844/ap/signin
MESSAGE:	java.lang.NullPointerException
SERVLET:	org.ops4j.pax.web.service.spi.model.ServletModel-47
CAUSED BY:	java.lang.NullPointerException
Caused by:
	at org.smarthomej.binding.amazonechocontrol.internal.smarthome.HandlerColorController.getStateDescription(
	at org.smarthomej.binding.amazonechocontrol.internal.handler.SmartHomeDeviceHandler.setDeviceAndUpdateThingState(
	at org.smarthomej.binding.amazonechocontrol.internal.handler.AccountHandler.lambda$19(
	at java.base/java.util.concurrent.CopyOnWriteArrayList.forEach(
	at java.base/java.util.concurrent.CopyOnWriteArraySet.forEach(
	at org.smarthomej.binding.amazonechocontrol.internal.handler.AccountHandler.updateSmartHomeDeviceList(
	at org.smarthomej.binding.amazonechocontrol.internal.handler.AccountHandler.setConnection(
	at org.smarthomej.binding.amazonechocontrol.internal.AccountServlet.handleProxyRequest(
	at org.smarthomej.binding.amazonechocontrol.internal.AccountServlet.doVerb(
	at org.smarthomej.binding.amazonechocontrol.internal.AccountServlet.doPost(
	at javax.servlet.http.HttpServlet.service(
	at javax.servlet.http.HttpServlet.service(
	at org.eclipse.jetty.servlet.ServletHolder.handle(
	at org.eclipse.jetty.servlet.ServletHandler.doHandle(
	at org.ops4j.pax.web.service.jetty.internal.HttpServiceServletHandler.doHandle(
	at org.eclipse.jetty.server.handler.ScopedHandler.handle(
	at org.eclipse.jetty.server.handler.HandlerWrapper.handle(
	at org.eclipse.jetty.server.handler.ScopedHandler.nextHandle(
	at org.eclipse.jetty.server.session.SessionHandler.doHandle(
	at org.eclipse.jetty.server.handler.ScopedHandler.nextHandle(
	at org.eclipse.jetty.server.handler.ContextHandler.doHandle(
	at org.ops4j.pax.web.service.jetty.internal.HttpServiceContext.doHandle(
	at org.eclipse.jetty.server.handler.ScopedHandler.nextScope(
	at org.eclipse.jetty.servlet.ServletHandler.doScope(
	at org.eclipse.jetty.server.session.SessionHandler.doScope(
	at org.eclipse.jetty.server.handler.ScopedHandler.nextScope(
	at org.eclipse.jetty.server.handler.ContextHandler.doScope(
	at org.eclipse.jetty.server.handler.ScopedHandler.handle(
	at org.ops4j.pax.web.service.jetty.internal.JettyServerHandlerCollection.handle(
	at org.eclipse.jetty.server.handler.HandlerWrapper.handle(
	at org.eclipse.jetty.server.Server.handle(
	at org.eclipse.jetty.server.HttpChannel.lambda$handle$1(
	at org.eclipse.jetty.server.HttpChannel.dispatch(
	at org.eclipse.jetty.server.HttpChannel.handle(
	at org.eclipse.jetty.server.HttpConnection.onFillable(
	at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.runTask(
	at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.doProduce(
	at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.tryProduce(
	at org.eclipse.jetty.util.thread.ReservedThreadExecutor$
	at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(
	at org.eclipse.jetty.util.thread.QueuedThreadPool$
	at java.base/
Powered by Jetty:// 9.4.43.v20210629

Maybe I need Samrthome/J Commons? If so, I can’t get it via openhab third party addons.

It’s automatically installed. That is a very strange error. Can you please restart openHAB and check that you only have one binding installed? On the karaf console: list -s | grep -i amazonechocontrol should only list one bundle.

Thank you! I was not aware this even existed.

I’m curious what @J-N-K improved on these? I do have 3 bindings that bounce offline/online (HUE, Onkyo & HP Printer), wonder if HTTP binding below would fix that?

  • Mail
  • HTTP

Best, Jay

No, each binding is responsible on its own for thing status.

3,2,10 is the only one installed. I did a restart and still have the same error. I use OTP on