Amazon Echo Control Error "Web socket close 1005" - Still happening on 3.2.0

The old thread for this error ends with everybody seeming to say that the error has gone away, and the thread is locked. From what I can tell, the updated binding included with OH 3.1 and up is supposed to have fixed the problem. Unfortunately, that hasn’t worked for me.

I’m on 3.2.0, and I’ve removed the binding, cleared the cache, re-installed the binding… I’ve tried snapshot JARs that were posted in the old thread… no matter what I do, I still get the Web socket 1005 error every minute.

Am I missing a step? Do I need to remove my amazon “account” thing and re-add it? Is there some other log-out-and-back-in step that I’ve somehow missed?

1 Like

also on latest ci build:

310 │ Active │  80 │    │ openHAB Add-ons :: Bundles :: Amazon Echo Control Binding

log says:

11:14:34.604 [INFO ] [ocontrol.internal.WebSocketConnection] - Web Socket close 1005. Reason: null

opened bug: [amazonechocontrol] openhab 3.2.0 Web Socket close 1005. Reason: null · Issue #11822 · openhab/openhab-addons (

Same problem here, with 3.2 stable

2021-12-22 09:07:11.489 [INFO ] [control.internal.WebSocketConnection] - Web Socket close 1005. Reason: null

I’m on openHABian main branch, and received an update today. After the update, I am no longer getting the web socket error! Interestingly, the splash screen when I log into SSH still says “openHAB 3.2.0 - Release Build”.

EDIT: Never mind. It’s back. Not sure what happened, there, but it was gone for a little while. Then, I had to temporarily disable my “amazon account” thing, and when I re-enabled it, the web socket error returned.

Hi all,

Struggeling with the same error logs - openhabian OH3.2.0.
Are there any updates?


look here: [amazonechocontrol] Error: Web Socket close 1005. Reason: null · Issue #11810 · openhab/openhab-addons · GitHub

Here’s a version of the binding that works.

You have to uninstall the old one you have and drop these 2 items into your AddOn’s. A recycle of OH most likely will be needed also.

This version also works with the new Alexa air sensors just released.

Please don’t forget to remove the .txt from each of the files before doing this.

org.smarthomej.binding.amazonechocontrol-3.2.9-SNAPSHOT.jar.txt (475.7 KB)

org.smarthomej.commons-3.2.9-SNAPSHOT.jar.txt (66.4 KB)

Best, Jay

1 Like

with this version I get following error:

[ocontrol.internal.handler.EchoHandler] - Failed to get player queue

EDIT: seems to be resolved.

no … I get this Error again and again

At the karaf console, what is shown with this command?

list -s | grep amazon

Best, Jay

322 │ Active │  80 │ 3.2.9                 │ org.smarthomej.binding.amazonechocontrol

My recommendation would be to clear the cache and tmp directories as the next steps.

I’m assuming you put the other commons jar in the addons also?

Best, Jay

Thank you! Solved the issue for me.

More discussion here

I rebuild the container and now it seems to work. fingers crossed

btw: great work and thanks

Thanks for posting the updated binding, Jay! And thanks, Mark, for the link to the other thread. I ended up installing the new binding by adding the json third-party addon file in the settings, and using the UI to install it like any other binding (after first removing the one that ships with 3.2, of course.)

Everything is working smoothly now. No more websocket errors.

Are the updates in this binding set to be added to the next official release?

Looks like this might solve two problems in one go (web socket 1005 and delayed response to commands). However, I can’t log in. I get: Login to '' failed: Request failed.

My account is registered with but I’m not convinced that is the problem because it recognises me enough to ask for my OTP, it just fails after that. If I disable 2FA, it fails right after the password screen.

Why is the smarthome/j version not merged into the main openhab? Why keeping a separate repo/version?

There are different views on technical and administrative/organizational aspects.

1 Like

Same thing here, however, I’m registered with