[BTicino/OpenWebNet] New openHAB2 binding ready for testing

bticino
openhab2
openwebnet
Tags: #<Tag:0x00007fd310e6e980> #<Tag:0x00007fd310e6dcd8> #<Tag:0x00007fd310e6db98>

(Mark) #21

Hi, I am a total noob to OpenHab2 and the BTicino binding. So I am sorry if I am asking a very stupid question but maybe it will encourage others to give it a try.

I have MH202 gateway and have installed OpenHab2 on a Raspberry Pi3b using the OpenHab2 image. At first I had some trouble getting the binding visible in the Inbox but managed it in the end. I will describe that problem and the fix at the end of this post for the next noob.

I have the binding installed and followed instructions to set up the binding but after selecting ‘add manually’ I see nothing and nowhere to add the IP address, password etc for the gateway

Log shows this:
018-05-05 11:34:25.440 [INFO ] [ery.OpenWebNetBridgeDiscoveryService] - ==OWN:BridgeDiscovery== ------ startScan() - SEARCHING for bridges…

2018-05-05 11:34:25.452 [WARN ] [ery.OpenWebNetBridgeDiscoveryService] - ==OWN:BridgeDiscovery== onConnectionError() - CONNECTION ERROR: errorCode = NO_SERIAL_PORTS_ERROR

Is it stupid me or is something wrong?

OK… for my initial noob problem.

After starting the Pi with the image and leaving for while to do its thing all seemed good. I copied the binding jar file to the suggested folder using WinSCP but nothing showed in the OpenHab Inbox. I thought maybe it was a permission problem and changed the jar permissions to 4777. Still nothing. Next I tried connecting and copying the binding jar to the Addons folder by Samba share. That worked and now the binding shows in my Openhab Inbox but I cant yet find the place to add the gateway details. See above.

Edit: Started to work now :slight_smile: I thought maybe it was a browser issue so I switched from Chrome to Edge. In Edge I could know see what I needed. Went back to Chrome. Still nothing. Hit refresh and now that works too. Or maybe it was just leaving it for while I mowed the lawn :slight_smile:


(Massimo) #22

Thanks @m4rk for testing the binding, and congratulations with your first efforts with openHAB!
So, were you able to connect and discover your devices with your MH202 gateway?
Are you able to control them?
Feedback from BUS is still buggy, but it will be corrected soon…
Bye
Massi


(Mark) #23

Hi, Cool you replied…thanks

Not only did the binding find a lot of devices, 90, but I got my first rule working :slight_smile: My office light now turns On when my phone is connected to the LAN and Off when it disconnects. I am really pleased with that because I had no idea about the syntax for the rule file and thought it would require a lot of trial and error frustration. Its not so user friendly having to edit files that way but I guess that will improve in time.


(Mark) #24

I have a problem now. The switch state isn’t being tracked. Switches toggle on and off correctly from the control panel but do not update when the physical switch state is changed. I tried removing all things including the gateway and then added them back but still not updating.


(Massimo) #25

hi @m4rk,
it’s’ a known bug now, it happens to others as well.
Keep an eye on this thread, a new version that corrects the bug is coming up…
bye
Massi


(Arnaud) #26

Hello Massi,

It’s possible to integrate a CEN+ commands ? WHO=25

The source code is here : https://www.dropbox.com/sh/fm6tb4o1fdllaqk/AAAFN9h1Zn4JNcpDtVoQgnBba?dl=0
Julesbike is autor for the biding integrate the WHO=25
Link for the github : https://github.com/openhab/openhab1-addons/issues/4609 5

Best regards

Arnaud


(Mark) #27

Some progress with my testing of this binding with Alexa on an Echo but I need a bit of help.

  • Alexa can now announce when a light is switched off or on. What she says is defined by me.
  • I can now voice command Alexa to turn a light on or off and Alexa will say OK and then tell me what she did using the announcement I set up.

The problem I have is that the name of the light is ‘switch’ to Alexa . I set everything up using PaperUI and gave the light item the name ‘Office light’ in PaperUI but Alexa sees it as called ‘switch’. The name Alexa has appears to be the channel name from the binding. So, if I add more items they could all be the same name!!! I took a look in Habmin to see if I could change it but I can not.

How do I change the name so Alexa sees it as ‘Office light’ ? Stumped for now.

Maybe I should post this somewhere else but not sure really. Help is appreciated :slight_smile:

edit … I made a more detailed post on my problem here:

Thx Mark.

another edit… problem fixed
Update…Fixed it myself after an evening of reading useless information and then an inspired guess… The trick was to select expose item in OpenHab cloud service and select item. Remove devices from Alexa and rediscover.


(Massimo) #29

@tagada: I will put them in the list of TODOs.

Hi @m4rk, Good you solved, but I would suggest to discuss other integrations (Alexa, Google Home, rules, etc.) in other community threads to keep this one concentrated on the BTicino Binding issues… Let me know if now the state is being tracked!


(Mark) #30

Installed as instructed. Beta 5 is shown in binding name

  • Blinds: Now see Blinds and Zigbee blinds. Control work as expected. Configured in MyHomeSuite as function type Automation actuator. Openhab shows as BUS Automation.
  • Lights: Dimmers and lights are mixed up. Some are seen as dimmers when they are not(F411 Light actuators) and some seen as switches when they are dimmable. Even so, Open control on/off works for them.
  • Temperature probes: No sign of them
  • Status: Seems to working now for some. Switches that are switches are working but items labelled as switches that actually dimmable spots are not updating their status.

Dimmers:
F429 SCS/DALI gateway … binding thinks they are switches
F417U2 … binding thinks they are switches
F418U2 universal dimmer … binding thinks its a switch

Switches:
F411U/4 … binding thinks they are dimmers

Probes:
HC/HS/HD4692 probes with regulation

I also noticed some where addresses have a leading 0 and others do not
eg 0810 or 810

I will check if I can see a pattern to this.

edit… Gateway disappeared after Pi reboot. Had restart discover from scratch etc


(Massimo) #31

Thanks for testing.

Dimmers are seen as switches if they are not dimmed when discovery is activated (see instructions in the README).

I am very surprised that switches are seen as dimmers… I will need you log in Private Msg to understand why (see my message).

Temp probes are not supported in this version (see README).

Where addresses can vary according to area definition, but 810 should not be a valid WHERE address for lightning (0810 is a valid one instead). Again you should send me the log file to see where this 810 comes from.

Bye
Massimo


(Arnaud) #32

Hi Massimo,

I will test the binding and I will redirect you if it works.

Best regards

Arnaud


(Mark) #33

Tagada, Set dimmers to 50% before discovery. I found they get discovered both as switches and dimmers if they are off at the time. Setting to 50% fixed it.


(Tony) #34

Hi @m4rk you did a really big step in only 1 month! Amazing!
Thank @massi for all your effort! I am going to install it as well this evening I hope!
I am still behind but I will do my best to support you guys!


(Mark) #35

Thank you Tony for the encouragement here and elsewhere. Massimo too.

It wasn’t so long ago I didn’t know what a Raspberry Pi was and now I have about 6 of them doing different jobs. They are so useful. Then along came thoughts on what to do to get my BTicino stuff to the next level and possibly working with non-BTicino stuff. I had a spare Pi and Openhab looked like a good bet. A few weeks later, after a bit of success with Openhab, I then thought Alexa could be a useful addition. Now I have voice alerts, voice commands to and from my BTicino BUS and Alexa is amusing for now. But there’s more to do and explore as these things develop.

I don’t know Linux or any other language. I have long forgotten Fortran 77 the only programming I ever did. With help I have picked up bits of useful code, commands and software tools as I go. So, if I can dive in and get a result in a reasonable time without much knowledge then anyone not afraid to learn something new can too.

I recognise that friendly support, tips and examples are key factors to encourage people to take the first few tentative steps. A friendly, supportive community is important for that. Later, newcomers have become experts and contribute as well. It’s one reason why I started my rather chatty threads on these topics over at the AVF site. People can see the journey and follow.

See link if anyone wants to join in: www.avforums.com home-automation-bticino-openwebnet-scs-bus

ps It did help that it rained a lot on my holiday :slight_smile:


(Arnaud) #36

Hello All,
It’s strange, I’m used a Zigbee Automation Actuator Legrand 067263.
When i’m send a command :
UP => The actuator DOWN it’s NOK
DOWN : The actuator UP it’s NOK
STOP => STOP It’s OK

Arnaud


(Massimo) #37

Hi @tagada. Then please check that the connection of your device with the electric wire of the roller shutter is correct.
In fact if an UP command is sent in OH2 to a Automation thing, it is translated by the binding to a *2*1*WHERE## OWN command which contains the WHAT=1, which according to the specifications must be used for sending UP a shutter on the BUS/ZigBee side (UP means opening it).
I do not have shutters to test myself, but other users have tested the binding with shutter commands and it worked fine.
Did you ever tested your device with other apps or systems?
Bye,
MASSIMO


(Mark) #38

I tested with both my wireless and wired blinds. They work as expected.


(Roberto) #39

OK with 2.2

On 2.3 and OpenHabian 1.4.1 you need to add “modbus binding” to install gnu.io also :slightly_smiling_face:

On OpenHab 2.3:

karaf bundle:list

227 │ Installed │ 80 │ 2.3.0.b5 │ OpenWebNet Binding (beta5)

but I’m not able to find it in the webpages (Paper-UI); on log i find:

2018-05-29 21:59:37.825 [WARN ] [org.apache.felix.fileinstall ] - Error while starting bundle: file:/THE_PATH/openhab-2.3.0/addons/org.openhab.binding.openwebnet-2.3.0-b5.jar
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.openwebnet [227]
_ Unresolved requirement: Import-Package: gnu.io_

On OpenHabian 1.4.1:

2018-05-30 00:07:03.550 [WARN ] [org.apache.felix.fileinstall ] - Error while starting bundle: file:/usr/share/openhab2/addons/org.openhab.binding.openwebnet-2.3.0-b5.jar
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.openwebnet [224]
Unresolved requirement: Import-Package: gnu.io


(Arnaud) #40

Hello All,
I’m deleted the automation actuators Legrand 067263
My first shutter actuator is recognize on GENERIC Device (WHERE=765215901#9)
OpenWebNet Generic Device
My second shutter actuator is recognise GENERIC Device (WHERE=765217301#9)
OpenWebNet Generic Device
So I added the actuators manually.
Orders “up” and “down” are always reversed

Some time ago I used this binding and it worked well
Link for this binding : Upgrade BTICINO (OpenWebNet) binding to OH2 (plus new Zigbee GW support)

Best regards
Arnaud


(Massimo) #41

Hi Arnaud (@tagada),

  • for the discovery as GENERIC I need to check the device code your shutters returns, maybe is a new one and I can add it
  • for the inverted UP/DOWN : this is very strange as the OpenWebNet documentation is quite clear and for others it works well.

To sort both things out I would need your log.
Please proceed this way:

  1. set log level to DEBUG:
    • from Karaf console (more info here):
      • log:set DEBUG org.openhab.binding.openwebnet
      • log:set DEBUG org.openwebnet
  2. delete the automation actuators
  3. stop openhab
  4. start openhab
  5. start a new discovery
  6. add manually one of the 2 shutter actuators
  7. on PaperUI press the down arrow “v” to close your shutter

and then send the openhab.log file, better if you use a personal message (PM).

bye
Massimo