[BTicino/OpenWebNet] New openHAB2 binding ready for testing

bticino
openhab2
openwebnet
Tags: #<Tag:0x00007fd316995368> #<Tag:0x00007fd3169951d8> #<Tag:0x00007fd316995048>

(Roberto) #42

Ciao Massimo,

it seems almost OK with this beta but I’ve found those in the log:

2018-05-30 07:58:47.034 [INFO ] [et.handler.OpenWebNetLightingHandler] - ==OWN:LightingHandler== updateLightOnOffState() Ignoring unsupported WHAT for thing openwebnet:bus_on_off_switch:4005f1b5:88h4h03. Frame=<°1°39°88#4#03##>
updateLightOnOffState() Ignoring unsupported WHAT for thing openwebnet:bus_on_off_switch:4005f1b5:88h4h03. Frame=<°1°34°88#4#03##>

If you remember we just saw it and I realize today what’s this device… It is a device by Bticino, exactly this:

AM5658 Green Switch: integrated control with movement sensor, using a combination of passive infrared rays and ultrasounds, and brightness sensor. Manual switching ON of the light using the front pushbutton, and automatic switching off based on brightness level and movement. Switch off delay and brightness sensor threshold adjustable using the the one-two-way remote control (BMSO4003 and BMSO4001), physical or virtual configuration. 2 modules

Every time it is triggered “on” by movement it turns on some lights it sends on bus Frame=<°1°34°88#4#03##> , when timer expires (and turns off lights) it sends Frame=<°1°39°88#4#03##>

Are you interested in manage this?

PS: note I changed “star” in " ° "

R


(Massimo) #43

Hi @Rob-VF

  • the dependency to gnu.io is already included in the binding, nothing changed on that side in the binding; so probably something is broken in dependency management in the new OH v2.3.0 just released. I will investigate more… thanks for pointing it out!

  • the WHO generated by the device is in fact documented. I do not have that device. If you plan to use it in OH2, then please file an issue here: https://github.com/mvalla/openhab-openwebnet so that it is tracked and maybe also others could contribute to it.

bye
Massimo


(Enrico) #44

I can confirm Rob-VF described behaviour, after the update the binding is not showing anymore.
But using the “modbus workaround” everything seems working again (no need to reconfigure anything)

Thanks,
Enrico


(Ruben) #45

hello everyone!
i’ve tried to install Modbus Binding (binding-modbus1 - 1.12.0) from PaperUI, then i’ve logged by ssh directly from raspberry using (ssh -p 8101 openhab@localhost), then executed the command “feature:install openhab-transport-serial”, installed Bticino binding, but i still cannot see in bindings the bticino binding as installed, and also i cannot see in homekit my blinds…how can i solve it?
please explain as you could explain to a child :slight_smile: thanks a lot


(Enrico) #46

This is what I did:
1 Copy and paste the binding file into the addons folder
2 install modbus from addons bindings in paper ui
3 restart openhab
4 in inbox start a new manual discovery: you should see the openwebnet binding and be able to add your gateway

Bye


(Ruben) #47

Grazie Enrico!

Just one little question…can you link me the binding file to be moved to addons folder?

Thanks a lot!

Ruben Fuser


(Enrico) #48

first post of this thread:
https://github.com/mvalla/openhab-openwebnet/releases/download/v2.3.0-b5/org.openhab.binding.openwebnet-2.3.0-b5.jar


(Ruben) #49

ok i can see the binding in PaperUI…but from Homekit i still cannot see blinds.
is it possible to download the previous version of “Bticino Binding” ? where can i find it?

thanks


(Massimo) #50

Hi @rubenfuser,
did you configure the gateway manually?
did you start a discovery afterwards to discover devices?
Please first of all follow instructions as detailed in the binding README.

Previous beta4 (b4) version of the binding can be found here, but it does not support shutters/blinds.

bye
Massimo


(Ruben) #51

for the moment i’m testing configuration files without connecting directly to my Bticino LCD panel…
what i’m doing is, install openhab, install bticino binding from add-ons in paperui, install homekit plugin, add bticino.items and check from my iphone if homekit can see all peripherals added in bticino.items.
i can see all lights, but not blinds.
Yesterday morning worked perfectly, but after lunch (around 14 pm italy time) i’ve reinstalled everything clean, and it started to not show only blinds. but i’m sure with the same config file, in the morning worked perfectly…i’m becoming crazy :’(


(Massimo) #52

Can you look at PaperUI/Configuration>Bindings ? I suspect you have installed the official BTicino1 binding. This thread is about the under development OpenWebNet(BTicino) binding which cannot be installed via paperUI (yet) as it is not yet part of the official release…

In relation to HomeKit configuration, I suggest you look for other thread in the community/guides for proper configuration.

Bye
Massimo


(Ruben) #53

oh yes sorry, i thought this page was for BTicino Binding (binding-bticino1 - 1.12.0)


(Mark) #54

For blind control it seems Alexa only responds to 0% or 100%. She says the devices cant do ‘stop’. Is this an issue of the BUS binding or Alexa? Stop works from the control panel. Also, Alexa doesn’t seem to able to do open, close, up, down either. I posted the same question on the Echo control thread as I am not sure where the issue is.

2nd small issue… The discovery refused to find one of my lights. After a few tries I manually added and it works. It’s a dimmer and was on during the search. @massi it’s address 9.2 if you want to check the logs. Lights with addresses either side were found.

M


(Rob) #55

Hi Massimo,

first many thanks for your work! I was watching this thread for a couple of weeks and now managed to install openHAB and your BTicino/OWN binding on my Raspi.
After adding the SCS gateway manually it shows up under Configuration->Things and the status is “online”. A manual discovery in inbox however doesn’t give any results (i’ve only blinds) … :disappointed:

Logfile says:
==OWN:BridgeDiscovery== onConnectionError() - CONNECTION ERROR: errorCode = NO_SERIAL_PORTS_ERROR

Maybe it’s the type of my gateway, which is not supported (basic gateway F455)?

thanks,
Rob


(Massimo) #56

Hi @rowaki,
If the gateway gets connected it is strange that it does not discover anyone of your blinds.
(The error you report here is not for the SCS/BUS but for the ZigBee side so it’s normal it does not find it).

What I suggest is you set the log level to DEBUG (see instructions above in the thread), delete the Gateway configuration and configure it again, then after gw is back online start a new discovery from Inbox.
Then send me the log openhab.log (use Personal Message, attach it changing the extension to .pdf as .log extensions cannot be loaded)
bye
M


(Massimo) #57

Ok @rowaki, found the problem: it will be solved in the next update. thanks. massi


(Mark) #58

I found the answer to my original problem and a work around with Alexa and blind control. I post here becasue Its related to the use of the BUS and maybe of interest to the BTicino BUS users.

My problem: Stop command didn’t work and to control blinds and I could only use 0 or 100% for open,close with Alexa. Worse still is that I couldn’t send another command until the actuator timed out 2mins later. I wasn’t sure where the issue was Alexa or binding. Maybe its feature and not a bu of both :slight_smile:

Solution:

  • Create dummy/virtual items in Openhab, one each for: Blind Open, Blind close, Blind stop.
  • Create an Alexa routines in the Alexa phone app that responds to the voice commands to control the above dummy items eg.Routine blind Down is initiated by voice command ‘Blind down’. And switches on Blind down dummy item in openhab.
  • Create an openhab rules file with rules that check for the switch On of the dummy switch and translates this to Up, Down, Stop commands for my roller shutter.

eg For my Stop I did it like this (after finding some hints by another poster)

rule "Dining room blind stop"
when
	Item VirtDiningRoomBlindStop changed to ON
then
	sendCommand(DiningRoomBlind_RollerShutter, STOP)
	Thread::sleep(2000)
	sendCommand(VirtDiningRoomBlindStop, OFF)
	logInfo("Shutters","Alexa command: Dining room blind STOP via virtual Item")
end

M


(Mark) #59

@massi,

I see these errors in the log

[INFO ] [et.handler.OpenWebNetLightingHandler] - ==OWN:LightingHandler== updateLightOnOffState() Ignoring unsupported WHAT for thing openwebnet:bus_on_off_switch:aaa770d6:1006. Frame=<11000#1*1006##>

2018-06-09 10:00:41.264 [WARN ] [.handler.OpenWebNetAutomationHandler] - ==OWN:AutomationHandler== updateAutomationState() FRAME <21000#2*55##> NOT SUPPORTED for thing openwebnet:bus_automation:aaa770d6:55, ignoring it.

You know about these right?

The 2nd error maybe addressed in version x.y in the the future :wink:


(stefan) #60

hello massimo,

i´m very happy about your binding because now the bus monitoring doesn´t stop any more :slight_smile:

i did a clean install openhabian with openhab 2.3.0-1, onewire-binding, and your bticino-binding. first it did not work, but when i installed the modbus-binding everything was fine.

the integration of who=4 (temperature control) would be a very nice thing for next step.

thank you very much for this binding, great work!

best regards, stefan


(Gennaro Di Marzo) #61

Hello to all
I would need to create a pulsed command with 0.5 ms to operate the sliding gate.
the address of the daughter A: 9 PL: 10
can you do something ???

Thank you