[BTicino/OpenWebNet] New openHAB2 binding ready for testing

bticino
openhab2
openwebnet
Tags: #<Tag:0x00007fd30e554630> #<Tag:0x00007fd30e554400> #<Tag:0x00007fd30e55bf98>

(Massimo) #62

the binding can send/receive openwebnet commands to an IP gateway. If your gateway has a command to generate impulse activation of switches, please report the openwebnet command here and I will try to understand how to support it from openHAB


(Corrado Dal Canton) #63

Hi Massimo
just tried to install yr binding.
The system linked to bticino gateway (f454) but is says it is Homeserver1; I have Homeserver1 also but with another ip address.
The discovering tool worked perfectly with dimm lights also.
I will do some trials late in the evening so
BTW do you plan to integrate WHO=18? Energy monitor together with OH2 rules would be great, for exmple use some loads only if solar production enough for them and so on.
If you need some tests I am available
Anyway my compliments for yr work
Corrado
Corrado


(Mark) #64

I have two that require a pulse also.

  • F411/4 Configured as…Function type: Light actuator, Modality: Master pulse, Load type:Lock
  • F411U2 Configured as…Function type: Light actuator, Modality: Master pulse, Load type:Actuator

Both work from the MyHome phone app with settings: Mode Lock.with timing:0.5s

Mark


(RebZone) #65

Hi Massi,
great work so far :slight_smile:

I’m trying to make my roller shutters work with a bticino mh200n gateway.
I was able to auto discovery everything, ad even in the sitemap (or the control page) I’m able to manually control every single roller shutter.

The only thing I can’t manage is the opening %. I’ve tried with time manual setting, and even with auto calibration, but It doesn’t seem to work…are there any known issues with this?

…especially with auto calibration: how is it supposed to work? what’s the procedure? …I read the tip “Use AUTO (default) to calibrate the shutter automatically (UP->DOWN->Position%) the first time a Position command (%) is sent.” but I cannot understand if I have to manage it manually or if is supposed to make a full auto calibration. Could you please give some more detailed instructions on this?

Thanks :slight_smile:


(Massimo) #66

Hi Corrado, this could be put in the roadmap.
Please file an issue here requesting for it, so that it keeps tracked and maybe also other developers can contribute to it!

Bye
M


(Massimo) #67

It works like this:

  • AUTO: if you put AUTO in the settings, the first time you send from openHAB a position% command an automatic calibration will be started: the shutter will first go all UP, then all DOWN then to the requested position% . After calibration AUTO will be changed in the settings to the actual shutter run time that has been calibrated

  • MANUAL: otherwise, if you want you can also put a number value (in milliseconds) for the shutter run time: you calculate how many seconds it takes for you shutter, multiply by 1000 and then put the value in the settings.

after you have done one of the 2 options above (auto or manual calibration) you should be able to use the position% command.

If position% still does not work, please activate DEBUG mode (see above in the thread for how to do that) and send me the DEBUG log to be analysed as Personal Message.

Bye
Massi


(RebZone) #68

AUTO: if you put AUTO in the settings, the first time you send from openHAB a position% command an automatic calibration will be started: the shutter will first go all UP, then all DOWN then to the requested position% . After calibration AUTO will be changed in the settings to the actual shutter run time that has been calibrated

…maybe I’m missing something, or something is not working well…
I tried exactly that procedure, but when I first set a % position the roller shutter just opens completely, but it doesn’t close…nor any value is stored in the settings.

This evening I’ll give another try enabling the debug log and eventually give you some feedback.

Just a question: how do you set the position%? Could you please make an example?


(Massimo) #69

What is your physical device model? How is the physical device configured? Did you set a shutter run time using the BTicino MyHome configurator?

To send a position% command from openHAB in PaperUI select the shutter item: there you have Up/Stop/Down buttons and a text box where you can insert percentage number , like 50 for 50%.

If calibration does not work as described, set log leve to debug, remove the Thing/item, discover it again and set a position% to start a new calibration.
Then send me the log as PM.
Bye
M


(RebZone) #70

I made some debug by myself and find out the problem is hardware related…My actuators have a stop timer set to 30/60 seconds, so the auto calibration doesn’t work (better: it works, but it gets a wrong time since the roller shutter waits the actuator to stop). Given that, the binding seems to work perfectly :+1: …now I have to find out how to calibrate the actuators :neutral_face:


(Mark) #71

I set ALL my stop timers on the actuators to two minutes.Its plenty of time for the blinds to move to position. I also found that a short time out can cause issues with the reliability of BUS scenarios actions eg if a scenario is trying tilt the blinds around the same time the stop time out occurs. My blinds will stop anyway when they reach the end position so I am not sure why its needed really.


(Massimo) #72

This is exactly the same problem another user had. If there is limited timer in the actuator, then the BTicino BUS will not send a STOP command after the shutter has reached a full UP position.
My suggestionis to look more to your actuator documentation and see if there is a better way to configure the actuator calibration.

Remember that the binding here for openHAB can only read what is happening on the bus> so if no STOP event is sent out on the BUS when the shutter reaches the UP positon, then there is no way for AUTO calibration to work.

Massi


(RebZone) #73

Massi, I have a litte improvement to suggest (I don’t know if it’s possible, but I try…).

Looking at the debug logs, I’ve noticed this behaviour:

  1. I send a 100% command (all close)
  2. the roller shutter closes completely (but since my actuator has a 60 seconds stop timer, no STOP event is sent out on the BUS for the next 60 seconds)
  3. some seconds (let’s say 5 seconds) after it finished closing I give a 70% command

The roller shutter doesn’t get the command since the binding reads the roller shutter is still moving (this is written in the logs), so I have to wait 60 seconds before sending another % command (using manual commands still works, but I’m thinking about scenarios).

Here is my suggestion: in this scenario (given % command while another % command is running) would it be possibile to send an intermediate STOP command when a new % command is received, and then execute that new command? In this way we could bypass the actuator temporization.

If I didn’t explain it well, these could be the steps:

  1. user sets 100% (or manual close)
  2. send command DOWN to rs
  3. user sets xx%
  4. send command STOP to rs
  5. send command UP to rs

Anyway this is not intended at all to resolve the auto calibration problem, but it could be a little improvement. :slight_smile:


(Massimo) #74

I think it can be done: to accept xx% command if another one was already sent.

But… why would you need to first send a 100% command and then just before 60sec are passed, another xx% command???

M


(Enrico) #75

I had the same issue as @rebzone, solved changing in my home suite the timer to the effective value needed to roll up or down completely the rollershutter (e.g. in my case 36 seconds).

Anyway what rebzone is proposing might be useful when you issue a command by mistake (or you change your mind).
E.g. the other day I issued a 0% command via Google Home to all rollershutter instead of a single one, but I wasn’t able to change/stop it until few seconds after the completion of the task (awakening everybody…:sweat_smile:)

bye


(RebZone) #76

This is exactly what I meant when posting the request :slight_smile:


(Massimo) #77

@enrico.mcc and @rebzone, would mind creating a new issue here with this request?


This way you can track it and it will become part of the TODO list for next versions.
bye
Massi


(RebZone) #78

Done! Thanks for your support :slight_smile:


(Enrico) #79

I added the one about who = 18

bye


(Rosario De Gaetano) #80

Hy Massino
after binding openhab whith bus gateway all is recognized but the roller shutter dont have seen in google assistant.
Do you have a solution.
The switchs and dimmers is recognized by google.
I use the version v2.3.0-b5.
At this moment i have espose the roller shutters at iftt whith openhab cloud.
Thanks


(Wolfgang Ott) #81

Hello everybody,
i am new in this topic. It’s my first try to get my Gateway F455 working with Openhab. So far i managed to install Openhab on my raspberry pi. Also i installed the OpenWebnet Binding. Everything looks ok in the Hab Paper UI. When i try to add a thing manually i click on the Binding and i see an empty page.
Can someone tell me, what i am doing wrong?
Thanks ind advance