[BTicino/OpenWebNet] New openHAB2 binding ready for testing

bticino
openhab2
openwebnet
Tags: #<Tag:0x00007fd30e5e2480> #<Tag:0x00007fd30e5e2340> #<Tag:0x00007fd30e5e2200>

(Wolfgang Ott) #82

Sorry!!! Everything works now. I had to restart my raspberry pi.


(Wolfgang Ott) #83

Now i am stuck with another thing: Hope that someone can halp me.
I try to configure a thing (in my case i just want to switch on and off a light)
image
What do i need to fill in into the configuration parameters. What is the correct syntax for the F455 Gateway?
for example: if want to turn on A=1 and PL=3
Where do i get the Where?
Thanx


(Mark) #84

MyHomeSuite BUS scanner will find BUS items or if you never use MyHomeSuite but they are physically configured then the numbers are stated on the configurators in the actuator.


(Wolfgang Ott) #85

I can see the A and the PL in the MyHomeSuite. What i don’t know is the “Where” Value. In the example above it is the 11??


(Mark) #86


(Wolfgang Ott) #87

Thanks. Now i got it. I was thinking to complicated.


(Wolfgang Ott) #88

I still need help. I can’t manage to get the “thing” working. As far as i understand this i have to write 13 as the OpenWebNet Device Address for A=1 and PL=3? Doing so i get the Status “UNKNOWN” for my light switch.


What can i do to get this working. I think i am am very close to the finish line but i see no light ;-)))


(Mark) #89

Try switching the light on and off from the wall Switch to see if it comes on line


(stefan) #90

hello wolfgang,
mark told you to try device adress “94” for a=9 and pl=4
in my installation i have defined different areas with f422 hardware (groundfloor, 1stfloor, outside,…) if i want do set an actor in groundfloor for example i have to write device adress “94#4#01” an actor in 1stfloor would be “94#4#02”
perhaps you have differnet local-buses, too?
best regards, stefan


(Massimo) #91

Hi Wolfgang,

  • did you configure the gateway manually?
  • did you start a discovery afterwards to discover devices?

I suggest you follow instructions as detailed in the binding README

In particular the section about “Devices”.

Massimo


(Wolfgang Ott) #92

Hello everyone,
what i exactly did is installing the Raspberry PI, then i manually configured the OpenHab. Afterwards i copied the jar file from above into the /usr/share/openhab2/addons/ folder an ran the script “feature:install openhab-transport-serial” in Karaf console. Then i added in PaperUI the thins stuff (Bus Gateway and BUS Switch). THis should work now. After turning them on manually the Light switch is online and the Gateway is online too.
Then i added a sitemap file and a things file in the etc/opehab2 folderstructure. The Light now does show up in the Basic UI but it dont turn on or off. Is there a things file missing in my structure or is it enought to have it configured in the PaperUI? Mabe i a missing this? Can someone please explain how to get the bold numbers from below from the example file. I think that could be my problem. At the moment i don’t have a things file.

Bridge openwebnet:bus_gateway:somename [ host=“192.168.1.1”, passwd="*****" ] {
bus_on_off_switch myswitch [ where=“64#4#01” ]
bus_dimmer mydimmer [ where=“24” ]
bus_automation myshutter [ where=“53”, shutterRun=“12000”]
}


(Massimo) #93

Hi @bobu,
I think you should provide us more precise info if you want us to help you.
First you say you have a .things file, then later in the same message you say you do not have a .things file.

As indicated in the README (and in the openHAB docs for beginners…), starting from a clean situation what you need to do is:

  1. copy the jar file in your /addons folder
  2. run the command feature:install openhab-transport-serial in Karaf console
  3. from PaperUI add manually the BUS Gateway, with all the needed config parameters set correctly (Host, Port and Password)
  4. after the gateway is added and Online, run a device discovery from Inbox to find all your devices automatically
  5. if the last step works well, you should not bother about setting any .things files and you should now see in the Inbox all the devices in your BTicino system (the ones that are supported: switches, dimmers, automation)
  6. from Inbox you can add them
  7. if Simple Mode is configured (Configuration>System>ItemLinking Simple Mode=ON) after adding from Inbox you should see your devices Items in the “Control” view, similar to the second picture in this thread.

The .things or .items files are only needed if you want more complex configurations.

Let us know if it works following these instructions !

Bye,
Massi


(Wolfgang Ott) #94

Hi massi,
i did exactly wat you recomended. The Bus Gateway is ONLINE. But when i press scan in the Inbox and select the Gateway nothing happens. The only way to get lights visible in the UI is to add them manually under Configuration/Things. Then i have to turn the switch physically on my wall and after a few minutes the new thing gets online. But there is no way to generate (=scan) them nor do the lamps react on any action set in the UI.
Is it possible that my F455 Gateway does not suppert OpenWebNet even though it is shown as ONLINE in the Config section?
ABout my last post: What i wrote yesterday was my try to config everything in the etc/openhab2 structure. Obviusly i mixed two file types. But as far as i understand your last post, there is no need to set any config in these files.

I will now try to start from scratch and build a complete new image.
My installing problem was that i could not use the ready made OpenHab image. I hat to install the raspberry system and then add manually the openhab. Maybe a complete restart will make it work.

But before: Could you please answer my question concerning the F455 so i will know, that my Gateway is OK for OpenHab binding. After this i will start again and send you a feedback about the result.

Thanx in advance for your help


(Mark) #95

That reminds me… @massi did you work out why just one of my lights never gets discovered and I have to add it manually?


(Massimo) #96

I just noticed now that you have the F455. It is supported but you have to wait a new release that I am working on that fixes an issue with this gateway. I will send you a fix via PM that should solve temporarily the problem.

Massi


(Arnaud) #97

This link may be interresting :
https://github.com/sxpert/myhomepy

Arnaud


(RebZone) #98

Hi again Massi,
do you have reports about roller shutters % position issues when used in rules?
I’ve noticed that if I give a manual command (even through the control page) with a specific % position, it works perfectly almost all the times, but if I make a rule (scenario) to move many roller shutters at once, it almost screws up everything.
I mean something like this:

  1. I have a rs in position 70. If the rule calls a rs.sendcommand(70), it opens a little bit more
  2. I have all rs position 100. I call a rule (n. 1) to open to 0. Then I call a rule (n. 2) to move everything to 70: everything stops near a 50% position. But if I switch from position 100 to rule n. 2, everything moves correctly to 70. -> I mean: the same rule causes different rs positions based on starting position.

I even tried to insert a sleep(1000) command between commands in rules, but it doesn’t solve the problem.

Any suggestion?


(Mark) #99

The way I move blinds to set positions is to first send the blinds to known start position eg fully closed. Then send them up, then send a stop after the time needed to get to position I want. This way no matter where they are when I send the command they always get to the correct position. It also makes it easier for fine blade control. I do this in my scenario controller not in openhab but I guess its working in a similar way with a start point at 100%, fully closed position.

If I’m correct then if the start point is changed then the time (%) will have to change too. That could be calculated if the open to close time is known (calibration), the motor drive speed is the same for up and down, and no one has manually moved them somewhere else outside of openhab.

So, without positional information to be consistent and accurate you must first drive to the start point before moving to %position. As your 70% test showed.

or put it another way… the %position is really just the time it takes to get there from a known start point, in this case the chosen start point is fully closed 100%.

Maybe your blinds have positional information in which case just ignore me :wink:

Sorry for chipping in… :grinning:

Massi, thats why Cen support would be good as I could just execute the relevant scenario instead of having to recreate them all again in openhab.


(RebZone) #100

This is exaclty what I was doing before Massi created this new binding (which is really interesting). Since controlling just 1 rs everything works fine, I was just wondering why multiple commands create strange behaviours.
It would be great to set a % position that actually works in scenarios, since I could just send 1 command (even in homekit) instead of DOWN/UP/WAIT/STOP commands.


(Massimo) #101

Roller shutter position% commands are based on position estimate which is base on timing .
Positional information from shutters is not supported by the binding (if anyone has this type of devices, contact me so I can support this more precise feedback from devices)

Said that, sending multiple positions commands to several shutters at once should be supported, and actually I tested it in my simulated environment.
Since it does not work: @rebzone could you set log level to DEBUG, then:

  1. Set 3/4 shutters that are part of a scenario to 100%
  2. start a openHAB scenario that activates those 3/4 shutters using positions%

If everything messes up as you described, send me the log (openhab.log)

Bye
Massi