[BTicino/OpenWebNet] New openHAB2 binding ready for testing

bticino
openhab2
openwebnet
Tags: #<Tag:0x00007fd322245048> #<Tag:0x00007fd322244e68> #<Tag:0x00007fd322244d00>

(grappler baki) #102

Hi Massimo,

Thanks a lot for all the work.
Just got an Amazon Echo dot and I would like to send command using voice.

I started to install OpenHab2 2.3.0 on a ubuntu linux.
I have the bticino F454 with firmware 2.0.5. No password is required on the gateway from host on the same subnet.

I followed the readme file to install the addons but the binding cannot connect to my F454
==OWN== BridgeHandler creating new gatewayBus with config properties: 192.168.6.42:20000, 140681
2018-07-01 18:55:41.074 [DEBUG] [g.openwebnet.bus.MyHomeJavaConnector] - ##gw-openwebnet-connector## Created MyHomeJavaConnector 192.168.6.42:20000 pwd=140681
2018-07-01 18:55:41.077 [DEBUG] [bnet.handler.OpenWebNetBridgeHandler] - ==OWN== BridgeHandler Trying to connect gateway…
2018-07-01 18:55:41.078 [ERROR] [org.openwebnet.AbstractOpenGateway ] - ERROR IN Java $MODULE$: connection cannot be established
2018-07-01 18:56:01.079 [INFO ] [bnet.handler.OpenWebNetBridgeHandler] - ==OWN== BridgeHandler still unknown. Setting device=openwebnet:bus_gateway:3f676829 to OFFLINE

I have tested the openwbnet client

The debug mode does not give me more details.
I tried a telnet from the linux VM but I have not issue to connect to the host.
telnet 192.168.6.42 20000
Trying 192.168.6.42…
Connected to 192.168.6.42.
Escape character is ‘^]’.

Did I miss something ?

Thanks.
Baki.


(Massimo) #103

Hallo,
I just released the beta6 version of the binding.

Everyone is encouraged to upgrade to this version.

This is a bug-fix release: these are the issues solved in the release:

  • [FIX] some library connectivity issues
  • updated to openHAB 2.4.0 dev branch. The bundle should work with both 2.2 and 2.3 versions of openHAB.
  • [FIX #7] added support for inverted UP/DOWN automation commands for older USB ZigBee dongles
  • [BUG] some switches were wrongly discovered as dimmers (now use only commands for device discovery)
  • [FIX] added support for SCS/ZIGBEE_SHUTTER_SWITCH (515/513) device types
  • [FIX] added support for F455 gateways using *99*0## command session

v2.4.0-b6: https://github.com/mvalla/openhab-openwebnet/releases/download/v2.4.0-b6/org.openhab.binding.openwebnet-2.4.0-b6.jar

How to upgrade from previous release

The previous version of the binding must be uninstalled using Karaf console (is not enough to update the binding jar file).

  1. go to Karaf console
  2. bundle:list to list all bundles and note the bundle id for OpenWebNet Binding
  3. bundle:uninstall to remove previous version of the binding
  4. copy the new version to /addons/ folder
  5. delete the old version jar file
  6. the new version of the binding should now be installed (check from PaperUI > Configuration > Bindings the binding name)

Bye
MASSI


(Massimo) #104

Hi @baki
Upgrade the JAR to this just released version:

v2.4.0-b6: https://github.com/mvalla/openhab-openwebnet/releases/download/v2.4.0-b6/org.openhab.binding.openwebnet-2.4.0-b6.jar

and you should be fine!

Let me know!

Massi


(grappler baki) #105

Hi Massimo,

Yes, it is working now ! Many thanks.


(Massimo) #106

Ok good!
I suggest you remove the oldest “OpenWebNet BUS” thing to avoid confusion. They are connected to the same gateway IP of course.
M


(Wolfgang Ott) #107

F455 Gateway now works perfect for me. Still having problems with rollershutters but no time at the moment to lokk at it. Command “Set xxx to 100%” works perfect for going down but “Set xxx to 0%” does not effect the rollershutter. The echo says “OK” but nothing happens. Any suggestions?


(Massimo) #108

If you go in PaperUI > control tab, can you set your rollershutter to 0% from there?
If yes, then the problem should be in the integration between Alexa and openHAB , not with the binding…
M


(Wolfgang Ott) #109

Hi Massi,
you are right. In PaperUI it works. This is an Alexa Problem. Thank you for your reply and your help.


(Patrick) #110

I thinking about testing this Binding.
Is there possibility to set different runtimes for each shutter?
LG Patrick


(Massimo) #111

Yes, each shutter device has its own runtime parameter that can be set.
Massi


(Patrick) #112

Thank u for the info :slight_smile:
I will test it at the weekiend :slight_smile:


(Patrick) #113

I got an error, when i start the binding
I followed the tutorial at the beginning of this threat

openhab> bundle:start org.openhab.binding.openwebnet
Error executing command: Error executing command on bundles:
        Error starting bundle 209: Could not resolve module: org.openhab.binding.openwebnet [209]
  Unresolved requirement: Import-Package: org.eclipse.jdt.annotation; resolution:="optional"
  Unresolved requirement: Import-Package: org.jupnp.model.meta


(Massimo) #114

you do not need to activate the binding unless you are upgrading it. It should be enough to put the JAR in the addons folder and activate manually some feature dependencies:

  1. go to Karaf console
  2. Type:
    feature:install openhab-transport-serial
  3. and if you are using openHAB 2.4.0-SNAPSHOT also type:
    feature:install esh-io-transport-upnp

at this point the binding should now be installed: check in PaperUI > Configuration > Bindings .

In case you still have problems set log level to DEBUG (see how in the thread) and send me a PM with the openhab.log along with your configuration (whcih BTicino gateway, IP address…)

Bye
massi


(Ivan) #115

Dear @massi,
I’m using your great great binding with MyHome Server1 .

OpenHab2 thing is this

OpenWebNet BUS Gateway - openwebnet:bus_gateway:29b22252

and “Shutter run” is set to AUTO

My item config for this shutter is the following:

Rollershutter GF_Studio_Shutter “Avvolgibile finestra [%d %%]” (GF_Studio, gShutter) [ “Rollershutter” ] {channel=“openwebnet:bus_automation:29b22252:33:shutter”}

But I don’t see the textbox to set the percent% and use it.

My home was configured through MyHomeUp, also on the BTicino MyHomeUp app I do not have a way to set the percentage.

Have you any hint?

Many thanks!
Ivan

P.S.
I would like to give you support / help on your project, if you need it let me know.


(Massimo) #116

Can you post a picture of your Coltrol tab in PaperUI? Your config looks ok so you should see the text box for position of the item seen form PaperUI …

Help in testing is always welcome.
Do you have thermostats in your BTicino system?

Massi


(Ivan) #117

Thanks Massi.
Yes, I have thermostats in my BTcino system (five of them in various rooms).
Yesterday I changed the config of my Rollingshutter changing AUTO in 18000ms in “Shutter run”, now I’m able to see the percentage but I’m not still able to see a textbox and move them by percentage.
I’m using F411/U2 actuators.

sshot1

Many thanks

I enclose the “Thing config” sshot in this answe and also the Control sshot in the next (as a new user I can post only 1 image for each message)


(Ivan) #118

sshot2


(Ivan) #119

One more thing.

Creating a rule where I set:

GF_Studio_Shutter.sendCommand(10)

the shutter does not move.

Using the same but without the percentage:

GF_Studio_Shutter.sendCommand(DOWN)

it works. On the log side:

==> /var/log/openhab2/openhab.log <==

2018-07-08 08:52:26.943 [WARN ] [.handler.OpenWebNetAutomationHandler] - ==OWN:AutomationHandler== updateAutomationState() FRAME <21000#0*33##> NOT SUPPORTED for thing openwebnet:bus_automation:29b22252:33, ignoring it.

2018-07-08 08:52:26.994 [WARN ] [.handler.OpenWebNetAutomationHandler] - ==OWN:AutomationHandler== updateAutomationState() FRAME <21000#2*33##> NOT SUPPORTED for thing openwebnet:bus_automation:29b22252:33, ignoring it.

2018-07-08 08:52:32.812 [WARN ] [.handler.OpenWebNetAutomationHandler] - ==OWN:AutomationHandler== updateAutomationState() FRAME <21000#0*33##> NOT SUPPORTED for thing openwebnet:bus_automation:29b22252:33, ignoring it.

2018-07-08 08:52:39.377 [WARN ] [me.core.internal.events.EventHandler] - Dispatching event to subscriber ‘org.eclipse.smarthome.io.monitor.internal.EventLogger@16c309d’ takes more than 5000ms.

I don’t know if this helps.
Ivan

PS.
Rolling shutter motors produced by Elero (Nice), a German brand but produced in Italy (I think).


(Patrick) #120

Hi,
I have also tested this. When i make some rules with UP/Stop and Down it works perfectly. When i send a command 30% the shutter drives to 100% :slight_smile:.

12:17:25.542 [INFO ] [smarthome.event.ItemCommandEvent     ] - Item 'RolloWohnziLi' received command 30
12:17:25.581 [INFO ] [smarthome.event.RuleStatusInfoEvent  ] - ee930ef0-baf4-4d41-a57d-19349311862c updated: IDLE
12:17:25.624 [INFO ] [smarthome.event.ItemStateChangedEvent] - RolloWohnziLi changed from 0 to 30
12:17:25.669 [INFO ] [smarthome.event.ItemStateChangedEvent] - RolloWohnziLi changed from 30 to 1
12:17:33.759 [INFO ] [smarthome.event.ItemStateChangedEvent] - RolloWohnziLi changed from 1 to 40
12:17:49.184 [INFO ] [smarthome.event.ItemStateChangedEvent] - RolloWohnziLi changed from 40 to 100

The new binding in combination with expermential rule binding works great :smiley:

many thanks to the coders


(Massimo) #121

In the README it is explained that for Position% to work a calibration must first be completed going all down (100%), then all up (0%), then to position (x%).
It looks like your calibration did non work.

Try first to set manually the shutterRun (see README) and if it works with manual calibration, try to set back to AUTO and do an auto calibration (see README) and then tell me if it works.

Bye
Massi