[BTicino/OpenWebNet] New openHAB2 binding ready for testing

bticino
openhab2
openwebnet
Tags: #<Tag:0x00007fd30f221f20> #<Tag:0x00007fd30f221de0> #<Tag:0x00007fd30f221ca0>

(Patrick) #123

The Positionig with % works now only my MH202 connection is a bit unstable and i love this binding :). great job


(Mark) #124

Hi Patrick,

I saw , before the post was deleted, that you had some instability issues with MH202. I also have MH202 and found that the binding can cause the MH202 to reboot. It occurs every time I scan for devices with PaperUI. I know it does this becasue I have a MH202 scenario that only runs at MH202 restart (checked box in top right for Scenario config in MyHomeSuite). I wondered if your instability issues are the same and if you see the same issue.

I have also had repeated restarts for no apparent reason and restarts when Openhab is restarted. These are not consistent and at the moment they are not happening but the restart on actuator, switch scan always occurs.

I haven’t tried using the blind calibration feature but might give it a try tonight, if its raining and I can’t dig the big trench at the back of my house that I have been working on :slight_smile:


(Patrick) #125

Hi,
the calibration of the shutter works :slight_smile:.
Good to hear that i’m not alone, it seems that the connection stop every time when i send a few commandos in a short time.
testing is every day at the evning possible :slight_smile:

bg


(Mark) #126

I have been helping Massi test preview versions before the beta release. So, I have to bear that in mind when we discuss or it will get confusing.


(Hannes) #127

I also have the problem, that my MH202 restarts at irregular intervals, but - in my case - this is not related to the OpenHab binding (it runs over my webserver “F454”).


(RebZone) #128

I really appreciate your efforts making this a GREAT binding, but since % positioning is difficult to achieve (obviously dued to hardware limitations), would it be possible to implement a time based positioning which could be used in control page and invoked in rules?
I mean a sort of timed-UP or timed-DOWN command.
Example:
UP for 5 seconds then STOP
or
DOWN for 10 seconds then STOP

IMHO this could achieve a really big semplification in scenarios (morning scenario = UP for 5 seconds all shutters then STOP).

…or maybe this is just a useless proposal…so ignore it :slight_smile:

…and just a question: is anyone experiencing lag in response when sending multiple UP/DOWN/STOP commands?


(Massimo) #129

@m4rk @k0nti please try to describe what happens to your MH202 with clear details in a new issue here
it is helpful to describe a sequence of actions that always leads to the MH202 restart and attach the DEBUG-level openHAB log that shows the actions and the restart (binding looses connectivity so the restart is detecteed in the log by that…)
bye
massi


(Massimo) #130

it may be related. I am starting to suspect that the MH202 “suffers” of too many messages at once on the BUS caused by the binding and interaction of the binding with F454 in your case.
Does your MH202 restart at irregular intervals even if the binding is not active and connected to the F454 ?
massi


(Patrick) #131

Hi Massi,
i will upload some logs in the evening. i can reproduce it all 5 minutes.
bg Patrick


(Massimo) #132

it is exactly done like that!
If you set shutterRun=10000 (10secs) and then send all UP (0%), and then send a command 30% the binding sends a DOWN command, waits for 30%*10000ms=3sec and then it sends a STOP command.

Yes in fact when position% is used in rules and many position% commands are all sent at once to several rollershutters, thigs are reporeted “to mess up”.
If many users experience this I suggest we keep track of this and file a new issue.

Massi


(Arnaud) #133

Hi Massi,

I have a thermostats and no controlled zone.

Arnaud


(Mark) #134

I ran a discovery last night but there were no new items to discovery. No MH202 restart this time. I will try it again after removing my items.


(Patrick) #135

When i don’t send a command to it it also keep stable online.
But when i send a group command with 4 shutter i get mainly evertime a disconnect .


(Massimo) #136

Hi, I may have identified the problem: the MH202 probably suffers to receive multiple connections at a time, right now the binding opens a new connection for every command sent… which is wrong.

I am trying to finalize the Thermo WHO=4 support in the binding (I am testing it with some help from you) and afterwards I will try to correct this multiple commands problem. In any case there is an issue for that on the GitHub so things get tracked…

Bye
Massi


(Mark) #137

OK. maybe I wait before removing all my items and setting off a discovery.Or if its useful I will do it ?


(Patrick) #138

Hi,

I have one Thermostat in my bticino network and testing is no problem.
I have the possibility to test mostly every evening :slight_smile:

bg patrick


(stefan) #139

Hi to all,
i have a h3550 tithermo with 12 x hd4693 themp probes and 4 x f430/4 heating actors installed and would be glad to thest who=4 :slight_smile:
best regards, stefan


(Michael) #140

Hi to all,

I am new to OpenHAB, but seems very promising. I tried to connect into my BTicino F455 Basic Gateway, but I seem to get a java error (null pointer exception) in the openhab.log.

What can/should I provide to get some help or explanation on what might be going on? OpenHAB is running on a RaspB 3B+. Connections to e.g. MiLight Controller and Samsung TV are working fine…

Many thanks,
Michael


(Michael) #141

OK… made quite some progress. I rebooted the RaspB, removed the “thing” definition for my Gateway F455. After that, I re-added it again, and this time saw it nicely coming online. Also the Vendor and type where now correctly filled in.

Items on my bus now also got detected! I quickly tested with 1 single switch, and it is working!

Fantastic work all, keep it up!
-Michael