[BTicino/OpenWebNet] New openHAB2 binding ready for testing

bticino
openhab2
openwebnet
Tags: #<Tag:0x00007fe066118e30> #<Tag:0x00007fe066118c50> #<Tag:0x00007fe066118ae8>

(Massimo) #394

Thanks for that! I will need more details, will write you in PM.

The dev environment for developing/testing OH2 bindings is based on Eclipse: you can try yourself if you can set up the dev environment correctly, see manual here (but no time to give you support in dev env setup here, sorry!)

bye
M


(mix) #397

As requested in the installation instructions, I’m sending the logs of the automatic and manual discovery of my F454 WebServer, using the latest build beta9-1.
Hope they might be useful for further developments…
Not any problem to report or ask information for… (at least, not yet !).

Thank you.

PNP - AUTO

2019-01-06 19:55:42.684 [DEBUG] [ery.OpenWebNetBridgeDiscoveryService] - ==OWN:BridgeDiscovery== getSupportedThingTypes()
2019-01-06 19:55:42.686 [DEBUG] [ery.OpenWebNetBridgeDiscoveryService] - ==OWN:BridgeDiscovery== getSupportedThingTypes()
2019-01-06 19:55:42.687 [INFO ] [ery.OpenWebNetBridgeDiscoveryService] - ==OWN:BridgeDiscovery== ------ startScan() - SEARCHING for bridges...
2019-01-06 19:55:42.688 [DEBUG] [ery.OpenWebNetBridgeDiscoveryService] - ==OWN:BridgeDiscovery:Dongle== ... trying to connect dongle ...
2019-01-06 19:55:42.689 [DEBUG] [org.openwebnet.OpenGatewayZigBee    ] - ##gw-openwebnet## Finding serial ports...
2019-01-06 19:55:42.719 [DEBUG] [org.openwebnet.OpenGatewayZigBee    ] - ##gw-openwebnet## ... found serial port /dev/ttyS1
2019-01-06 19:55:42.720 [DEBUG] [org.openwebnet.OpenGatewayZigBee    ] - ##gw-openwebnet## ... found serial port /dev/ttyS0
2019-01-06 19:55:42.721 [DEBUG] [org.openwebnet.OpenGatewayZigBee    ] - ##gw-openwebnet## ... trying to connect USB dongle on serial port /dev/ttyS1 ...
2019-01-06 19:55:42.728 [INFO ] [org.openwebnet.OpenGatewayZigBee    ] - SERIAL SENDING   >>>>>>>>>>>>>>>>>>>>>>>> *13*60*##
2019-01-06 19:55:42.728 [INFO ] [org.openwebnet.OpenGatewayZigBee$a  ] - ##gw-openwebnet-ReceiveThread##  USB *RECEIVING* on port: /dev/ttyS1
2019-01-06 19:55:44.742 [DEBUG] [org.openwebnet.OpenGatewayZigBee$a  ] - ##gw-openwebnet-ReceiveThread## STOPPED receive thread on port: /dev/ttyS1
2019-01-06 19:55:44.826 [DEBUG] [org.openwebnet.OpenGatewayZigBee    ] - ##gw-openwebnet## no response received from port: /dev/ttyS1
2019-01-06 19:55:44.827 [DEBUG] [org.openwebnet.OpenGatewayZigBee    ] - ##gw-openwebnet## ... trying to connect USB dongle on serial port /dev/ttyS0 ...
2019-01-06 19:55:44.834 [INFO ] [org.openwebnet.OpenGatewayZigBee    ] - SERIAL SENDING   >>>>>>>>>>>>>>>>>>>>>>>> *13*60*##
2019-01-06 19:55:44.834 [INFO ] [org.openwebnet.OpenGatewayZigBee$a  ] - ##gw-openwebnet-ReceiveThread##  USB *RECEIVING* on port: /dev/ttyS0
2019-01-06 19:55:46.846 [DEBUG] [org.openwebnet.OpenGatewayZigBee$a  ] - ##gw-openwebnet-ReceiveThread## STOPPED receive thread on port: /dev/ttyS0
2019-01-06 19:55:46.931 [DEBUG] [org.openwebnet.OpenGatewayZigBee    ] - ##gw-openwebnet## no response received from port: /dev/ttyS0
2019-01-06 19:55:46.932 [DEBUG] [org.openwebnet.OpenGatewayZigBee    ] - ##gw-openwebnet## --NO USB ZigBee dongle FOUND--
2019-01-06 19:55:46.933 [INFO ] [ery.OpenWebNetBridgeDiscoveryService] - ==OWN:BridgeDiscovery== no serial ports found
2019-01-06 19:55:46.933 [INFO ] [overy.BusGatewayDiscoveryParticipant] - ================================================
[...]
2019-01-06 19:55:46.942 [INFO ] [overy.BusGatewayDiscoveryParticipant] - ================================================
2019-01-06 19:55:46.944 [INFO ] [overy.BusGatewayDiscoveryParticipant] - ==OWN:UPnP== DISCOVERED DEVICE: (RemoteDevice) Identity: (RemoteDeviceIdentity) UDN: uuid:00df5b9b-13c4-0815-371f-97d8007fe960, Descriptor: http://192.168.10.103:32469/DeviceDescription.xml, Root: true
2019-01-06 19:55:46.944 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =FRIENDLY NAME: Plex Media Server: MediaNAS
2019-01-06 19:55:46.945 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =BASE URL     : null
2019-01-06 19:55:46.946 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =SERIAL #     : null
2019-01-06 19:55:46.946 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =UPC          : null
2019-01-06 19:55:46.947 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =ID.DESC URL  : http://192.168.10.103:32469/DeviceDescription.xml
2019-01-06 19:55:46.948 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =ID.MAX AGE   : 1800
2019-01-06 19:55:46.948 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =MANUFACTURER : Plex, Inc.
2019-01-06 19:55:46.949 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =MODEL        : Plex Media Server | Plex Media Server | 1.14.1.5488
2019-01-06 19:55:46.949 [INFO ] [overy.BusGatewayDiscoveryParticipant] - ================================================
2019-01-06 19:55:46.950 [INFO ] [overy.BusGatewayDiscoveryParticipant] - ==OWN:UPnP== DISCOVERED DEVICE: (RemoteDevice) Identity: (RemoteDeviceIdentity) UDN: uuid:4d696e69-444c-164e-9d41-245ebe0125ff, Descriptor: http://192.168.10.103:8200/rootDesc.xml, Root: true
2019-01-06 19:55:46.951 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =FRIENDLY NAME: MediaNAS
2019-01-06 19:55:46.952 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =BASE URL     : null
2019-01-06 19:55:46.953 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =SERIAL #     : 12345678
2019-01-06 19:55:46.954 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =UPC          : null
2019-01-06 19:55:46.955 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =ID.DESC URL  : http://192.168.10.103:8200/rootDesc.xml
2019-01-06 19:55:46.956 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =ID.MAX AGE   : 1810
2019-01-06 19:55:46.956 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =MANUFACTURER : Microsoft
2019-01-06 19:55:46.957 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =MODEL        : Windows Media Player Sharing | QNAPDLNA on TurboNAS | 3.0
2019-01-06 19:55:46.958 [INFO ] [overy.BusGatewayDiscoveryParticipant] - ================================================
[...]
2019-01-06 19:55:46.994 [INFO ] [overy.BusGatewayDiscoveryParticipant] - ================================================
2019-01-06 19:55:46.995 [INFO ] [overy.BusGatewayDiscoveryParticipant] - ==OWN:UPnP== DISCOVERED DEVICE: (RemoteDevice) Identity: (RemoteDeviceIdentity) UDN: uuid:667897a8-b1ae-49b5-8a43-1be49da722c3, Descriptor: http://192.168.10.103:8080/upnpd/42502c4157.xml, Root: true
2019-01-06 19:55:46.996 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =FRIENDLY NAME: MediaNAS
2019-01-06 19:55:46.997 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =BASE URL     : null
2019-01-06 19:55:46.997 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =SERIAL #     : Q167B05289
2019-01-06 19:55:46.998 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =UPC          : null
2019-01-06 19:55:46.999 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =ID.DESC URL  : http://192.168.10.103:8080/upnpd/42502c4157.xml
2019-01-06 19:55:47.000 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =ID.MAX AGE   : 1800
2019-01-06 19:55:47.001 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =MANUFACTURER : QNAP Systems, Inc.
2019-01-06 19:55:47.002 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =MODEL        : TS-451A | null | 4.3.6
2019-01-06 19:55:47.003 [INFO ] [overy.BusGatewayDiscoveryParticipant] - ================================================
[...]
2019-01-06 19:55:47.018 [INFO ] [overy.BusGatewayDiscoveryParticipant] - ================================================
2019-01-06 19:55:47.019 [INFO ] [overy.BusGatewayDiscoveryParticipant] - ==OWN:UPnP== DISCOVERED DEVICE: (RemoteDevice) Identity: (RemoteDeviceIdentity) UDN: uuid:pnp-webserver-2_0-00:03:50:A4:63:26, Descriptor: http://192.168.10.35:49152/, Root: true
2019-01-06 19:55:47.020 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =FRIENDLY NAME: Webserver F454AV Mix
2019-01-06 19:55:47.021 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =BASE URL     : null
2019-01-06 19:55:47.021 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =SERIAL #     : 00:03:50:A4:63:26
2019-01-06 19:55:47.022 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =UPC          : null
2019-01-06 19:55:47.022 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =ID.DESC URL  : http://192.168.10.35:49152/
2019-01-06 19:55:47.023 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =ID.MAX AGE   : 500
2019-01-06 19:55:47.024 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =MANUFACTURER : BTicino S.p.A.
2019-01-06 19:55:47.024 [INFO ] [overy.BusGatewayDiscoveryParticipant] - =MODEL        : F454 | Web Server AV | 2.0
2019-01-06 19:55:47.025 [DEBUG] [ery.OpenWebNetBridgeDiscoveryService] - ==OWN:BridgeDiscovery== getSupportedThingTypes()
2019-01-06 19:55:47.326 [INFO ] [overy.BusGatewayDiscoveryParticipant] - ================================================
[...]

MANUAL

2019-01-06 19:57:24.080 [DEBUG] [et.internal.OpenWebNetHandlerFactory] - ==OWN:HandlerFactory== createHandler()
2019-01-06 19:57:24.085 [DEBUG] [et.internal.OpenWebNetHandlerFactory] - ==OWN:HandlerFactory== creating NEW BRIDGE Handler
2019-01-06 19:57:24.088 [DEBUG] [et.internal.OpenWebNetHandlerFactory] - ==OWN:HandlerFactory== registerDiscoveryService()
2019-01-06 19:57:24.103 [DEBUG] [ery.OpenWebNetDeviceDiscoveryService] - ==OWN:DeviceDiscovery== constructor for bridge: openwebnet:bus_gateway:a0901fbe
2019-01-06 19:57:24.106 [DEBUG] [ery.OpenWebNetDeviceDiscoveryService] - ==OWN:DeviceDiscovery== activate()
2019-01-06 19:57:24.109 [DEBUG] [org.openhab.binding.openwebnet      ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.config.discovery.DiscoveryService}={service.id=574, service.bundleid=234, service.scope=singleton} - org.openhab.binding.openwebnet
2019-01-06 19:57:24.129 [DEBUG] [org.openhab.binding.openwebnet      ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.config.core.status.ConfigStatusProvider}={service.id=575, service.bundleid=234, service.scope=singleton} - org.openhab.binding.openwebnet
2019-01-06 19:57:24.178 [DEBUG] [bnet.handler.OpenWebNetBridgeHandler] - ==OWN== BridgeHandler.initialize() 
2019-01-06 19:57:24.180 [DEBUG] [bnet.handler.OpenWebNetBridgeHandler] - ==OWN== type = openwebnet:bus_gateway
2019-01-06 19:57:24.182 [DEBUG] [bnet.handler.OpenWebNetBridgeHandler] - ==OWN== Creating new BUS gateway with config properties: 192.168.10.35:20000, pwd=******34
2019-01-06 19:57:24.196 [DEBUG] [g.openwebnet.bus.MyHomeJavaConnector] - ##gw-openwebnet-connector## Created MyHomeJavaConnector 192.168.10.35:20000
2019-01-06 19:57:24.214 [DEBUG] [bnet.handler.OpenWebNetBridgeHandler] - ==OWN== Trying to connect gateway...
2019-01-06 19:57:24.216 [INFO ] [org.openwebnet.OpenGatewayBus       ] - ##gw-openwebnet-BUS## Trying to connect BUS (192.168.10.35:20000)...
2019-01-06 19:57:24.219 [DEBUG] [g.openwebnet.bus.MyHomeSocketFactory] - ##gw-openwebnet-socket## Trying openMonitorSession socket....  (192.168.10.35:20000)
2019-01-06 19:57:24.247 [DEBUG] [org.openwebnet.bus.MyHomeConnection ] - ##gw-openwebnet-conn## ... starting HANDSHAKE ... 
2019-01-06 19:57:24.248 [DEBUG] [org.openwebnet.bus.MyHomeConnection ] - MON RECEIVED   <<<<<<====== *#*1##
2019-01-06 19:57:24.249 [DEBUG] [org.openwebnet.bus.MyHomeConnection ] - MON SENDING    ======>>>>>> *99*1##
2019-01-06 19:57:24.251 [DEBUG] [org.openwebnet.bus.MyHomeConnection ] - MON RECEIVED   <<<<<<====== *#769995515##
2019-01-06 19:57:24.252 [DEBUG] [org.openwebnet.bus.MyHomeConnection ] - MON SENDING    ======>>>>>> *#4294733820##
2019-01-06 19:57:24.255 [DEBUG] [org.openwebnet.bus.MyHomeConnection ] - MON RECEIVED   <<<<<<====== *#*1##
2019-01-06 19:57:24.255 [DEBUG] [org.openwebnet.bus.MyHomeConnection ] - ##gw-openwebnet-conn## starting MON keepalive timer
2019-01-06 19:57:24.261 [DEBUG] [g.openwebnet.bus.MyHomeSocketFactory] - ##gw-openwebnet-socket## ... connected monitor session 192.168.10.35:20000
2019-01-06 19:57:24.268 [INFO ] [org.openwebnet.OpenGatewayBus       ] - ##gw-openwebnet-BUS## CONNECTED BUS MONITORING to: 192.168.10.35:20000
2019-01-06 19:57:24.269 [DEBUG] [org.openwebnet.OpenGatewayBus$a     ] - ##gw-openwebnet-BusReceiveThread## STARTING receive thread
2019-01-06 19:57:24.280 [DEBUG] [g.openwebnet.bus.MyHomeJavaConnector] - ##gw-openwebnet-connector## Opening a NEW COMMAND SESSION...
2019-01-06 19:57:24.283 [INFO ] [g.openwebnet.bus.MyHomeSocketFactory] - ##gw-openwebnet-socket## Trying openCommandSession() socket....  (192.168.10.35:20000)
2019-01-06 19:57:24.300 [DEBUG] [org.openwebnet.bus.MyHomeConnection ] - ##gw-openwebnet-conn## ... starting HANDSHAKE ... 
2019-01-06 19:57:24.301 [DEBUG] [org.openwebnet.bus.MyHomeConnection ] - COM RECEIVED   <<<<<<====== *#*1##
2019-01-06 19:57:24.301 [DEBUG] [org.openwebnet.bus.MyHomeConnection ] - COM SENDING    ======>>>>>> *99*0##
2019-01-06 19:57:24.304 [DEBUG] [org.openwebnet.bus.MyHomeConnection ] - COM RECEIVED   <<<<<<====== *#751376495##
2019-01-06 19:57:24.305 [DEBUG] [org.openwebnet.bus.MyHomeConnection ] - COM SENDING    ======>>>>>> *#4175298555##
2019-01-06 19:57:24.308 [DEBUG] [org.openwebnet.bus.MyHomeConnection ] - COM RECEIVED   <<<<<<====== *#*1##
2019-01-06 19:57:24.309 [INFO ] [g.openwebnet.bus.MyHomeSocketFactory] - ##gw-openwebnet-socket## ... CONNECTED command session 192.168.10.35:20000
2019-01-06 19:57:24.310 [INFO ] [g.openwebnet.bus.MyHomeJavaConnector] - COM SENDING   ============>>>>>>>>>>>> *#13**15##
2019-01-06 19:57:24.345 [INFO ] [org.openwebnet.OpenGatewayBus$a     ] - MON RECEIVED  <<<<<<<<<<< *#13**15*200##
2019-01-06 19:57:24.349 [INFO ] [g.openwebnet.bus.MyHomeSocketFactory] - COM RECEIVED  <<<<<<<<<<<<============ *#13**15*200##
2019-01-06 19:57:24.355 [DEBUG] [org.openwebnet.OpenGatewayBus       ] - ##gw-openwebnet-BUS## server MODEL=MyHOMEServer1 / MH202 / F455
2019-01-06 19:57:24.368 [DEBUG] [bnet.handler.OpenWebNetBridgeHandler] - ==OWN==  GatewayManagement WHAT = null
2019-01-06 19:57:24.389 [INFO ] [g.openwebnet.bus.MyHomeSocketFactory] - COM RECEIVED  <<<<<<<<<<<<============ *#*1##
2019-01-06 19:57:24.693 [INFO ] [bnet.handler.OpenWebNetBridgeHandler] - ==OWN== ------------------- CONNECTED to BUS gateway - 192.168.10.35:20000
2019-01-06 19:57:27.444 [INFO ] [org.openwebnet.OpenGatewayBus$a     ] - MON RECEIVED  <<<<<<<<<<< *#4*19*0*0094##
2019-01-06 19:57:27.446 [DEBUG] [bnet.handler.OpenWebNetBridgeHandler] - ==OWN==  ownId=19 has NO THING associated, ignoring it
2019-01-06 19:57:53.414 [INFO ] [org.openwebnet.OpenGatewayBus$a     ] - MON RECEIVED  <<<<<<<<<<< *#4*19*0*0094##
2019-01-06 19:57:53.415 [DEBUG] [bnet.handler.OpenWebNetBridgeHandler] - ==OWN==  ownId=19 has NO THING associated, ignoring it

(Enrico) #398

Since installing the 9.1 binding version the item “where 51” doesn’t work properly anymore: in Things is shown as OFFLINE - COMMUNICATION_ERROR
I found in the log an error that might be related to that:

2019-01-06 23:09:39.915 [INFO ] [g.openwebnet.bus.MyHomeJavaConnector] - COM SENDING   ============>>>>>>>>>>>> *2*2*51##
2019-01-06 23:09:40.007 [INFO ] [org.openwebnet.OpenGatewayBus$a     ] - MON RECEIVED  <<<<<<<<<<< *2*1000#0*51##
2019-01-06 23:09:40.008 [DEBUG] [penwebnet.message.OpenMessageFactory] - ##openwebnet## COMMAND TRANSLATION, WHAT=STOP
2019-01-06 23:09:40.010 [WARN ] [bnet.handler.OpenWebNetEnergyHandler] - ==OWN:EnergyHandler== handleMessage() Ignoring unsupported command for thing openwebnet:bus_energy_central_unit:ef0da2a6:51. Frame=<*2*1000#0*51##>
2019-01-06 23:09:40.023 [INFO ] [org.openwebnet.OpenGatewayBus$a     ] - MON RECEIVED  <<<<<<<<<<< *2*0*51##
2019-01-06 23:09:40.025 [WARN ] [bnet.handler.OpenWebNetEnergyHandler] - ==OWN:EnergyHandler== handleMessage() Ignoring unsupported command for thing openwebnet:bus_energy_central_unit:ef0da2a6:51. Frame=<*2*0*51##>
2019-01-06 23:09:40.059 [INFO ] [org.openwebnet.OpenGatewayBus$a     ] - MON RECEIVED  <<<<<<<<<<< *2*1000#2*51##
2019-01-06 23:09:40.059 [INFO ] [g.openwebnet.bus.MyHomeSocketFactory] - COM RECEIVED  <<<<<<<<<<<<============ *#*1##
2019-01-06 23:09:40.061 [DEBUG] [penwebnet.message.OpenMessageFactory] - ##openwebnet## COMMAND TRANSLATION, WHAT=DOWN
2019-01-06 23:09:40.062 [WARN ] [bnet.handler.OpenWebNetEnergyHandler] - ==OWN:EnergyHandler== handleMessage() Ignoring unsupported command for thing openwebnet:bus_energy_central_unit:ef0da2a6:51. Frame=<*2*1000#2*51##>
2019-01-06 23:09:40.089 [INFO ] [org.openwebnet.OpenGatewayBus$a     ] - MON RECEIVED  <<<<<<<<<<< *2*2*51##
2019-01-06 23:09:40.091 [WARN ] [bnet.handler.OpenWebNetEnergyHandler] - ==OWN:EnergyHandler== handleMessage() Ignoring unsupported command for thing openwebnet:bus_energy_central_unit:ef0da2a6:51. Frame=<*2*2*51##>
2019-01-06 23:09:41.575 [INFO ] [org.openwebnet.OpenGatewayBus$a     ] - MON RECEIVED  <<<<<<<<<<< *#18*51*113*293##
2019-01-06 23:09:41.579 [DEBUG] [bnet.handler.OpenWebNetEnergyHandler] - ==OWN:EnergyHandler== updateActivePower() for thing: openwebnet:bus_energy_central_unit:ef0da2a6:51
2019-01-06 23:09:42.567 [INFO ] [org.openwebnet.OpenGatewayBus$a     ] - MON RECEIVED  <<<<<<<<<<< *#18*51*113*359##
2019-01-06 23:09:42.570 [DEBUG] [bnet.handler.OpenWebNetEnergyHandler] - ==OWN:EnergyHandler== updateActivePower() for thing: openwebnet:bus_energy_central_unit:ef0da2a6:51
2019-01-06 23:09:43.563 [INFO ] [org.openwebnet.OpenGatewayBus$a     ] - MON RECEIVED  <<<<<<<<<<< *#18*51*113*427##
2019-01-06 23:09:43.566 [DEBUG] [bnet.handler.OpenWebNetEnergyHandler] - ==OWN:EnergyHandler== updateActivePower() for thing: openwebnet:bus_energy_central_unit:ef0da2a6:51
2019-01-06 23:09:44.561 [INFO ] [org.openwebnet.OpenGatewayBus$a     ] - MON RECEIVED  <<<<<<<<<<< *#18*51*113*493##
2019-01-06 23:09:44.564 [DEBUG] [bnet.handler.OpenWebNetEnergyHandler] - ==OWN:EnergyHandler== updateActivePower() for thing: openwebnet:bus_energy_central_unit:ef0da2a6:51
2019-01-06 23:10:05.520 [INFO ] [org.openwebnet.OpenGatewayBus$a     ] - MON RECEIVED  <<<<<<<<<<< *#18*51*113*510##
2019-01-06 23:10:05.524 [DEBUG] [bnet.handler.OpenWebNetEnergyHandler] - ==OWN:EnergyHandler== updateActivePower() for thing: openwebnet:bus_energy_central_unit:ef0da2a6:51
2019-01-06 23:10:09.335 [DEBUG] [org.openwebnet.bus.MyHomeConnection ] - ##gw-openwebnet-conn## sending MON keepalive ACK
2019-01-06 23:10:09.339 [DEBUG] [org.openwebnet.bus.MyHomeConnection ] - MON SENDING    ======>>>>>> *#*1##
2019-01-06 23:10:16.498 [INFO ] [org.openwebnet.OpenGatewayBus$a     ] - MON RECEIVED  <<<<<<<<<<< *#18*51*113*454##
2019-01-06 23:10:16.500 [DEBUG] [bnet.handler.OpenWebNetEnergyHandler] - ==OWN:EnergyHandler== updateActivePower() for thing: openwebnet:bus_energy_central_unit:ef0da2a6:51
2019-01-06 23:10:17.496 [INFO ] [org.openwebnet.OpenGatewayBus$a     ] - MON RECEIVED  <<<<<<<<<<< *#18*51*113*386##
2019-01-06 23:10:17.519 [DEBUG] [bnet.handler.OpenWebNetEnergyHandler] - ==OWN:EnergyHandler== updateActivePower() for thing: openwebnet:bus_energy_central_unit:ef0da2a6:51
2019-01-06 23:10:18.494 [INFO ] [org.openwebnet.OpenGatewayBus$a     ] - MON RECEIVED  <<<<<<<<<<< *#18*51*113*319##
2019-01-06 23:10:18.497 [DEBUG] [bnet.handler.OpenWebNetEnergyHandler] - ==OWN:EnergyHandler== updateActivePower() for thing: openwebnet:bus_energy_central_unit:ef0da2a6:51
2019-01-06 23:10:19.492 [INFO ] [org.openwebnet.OpenGatewayBus$a     ] - MON RECEIVED  <<<<<<<<<<< *#18*51*113*251##
2019-01-06 23:10:19.495 [DEBUG] [bnet.handler.OpenWebNetEnergyHandler] - ==OWN:EnergyHandler== updateActivePower() for thing: openwebnet:bus_energy_central_unit:ef0da2a6:51
2019-01-06 23:10:22.012 [INFO ] [org.openwebnet.OpenGatewayBus$a     ] - MON RECEIVED  <<<<<<<<<<< *2*0*51##
2019-01-06 23:10:22.015 [WARN ] [bnet.handler.OpenWebNetEnergyHandler] - ==OWN:EnergyHandler== handleMessage() Ignoring unsupported command for thing openwebnet:bus_energy_central_unit:ef0da2a6:51. Frame=<*2*0*51##>
2019-01-06 23:10:26.841 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-modbus1'


(Michele) #399

Hello,
do you use the configuration via .items file?
If yes, publish the file
If not, have you tried to delete things and redo the search?


(Enrico) #400

Hi, I use paper UI
After removing thing and item the discovery does not find it anymore (it finds other things but not the where=51)
So I added it manually an I am able to move the rollershutter but the % doesn’t show.
And still have log issues:

2019-01-07 17:21:35.931 [WARN ] [.handler.OpenWebNetAutomationHandler] - ==OWN:AutomationHandler== updateAutomationState() FRAME <*2*1000#0*51##> NOT SUPPORTED for thing openwebnet:bus_automation:15be17ca, ignoring it.
2019-01-07 17:21:35.938 [DEBUG] [.handler.OpenWebNetAutomationHandler] - ==OWN:AutomationHandler== # 51 # [[[ internalState=0 positionEst=0 - calibrating=-1 shutterRun=36000 ]]]
2019-01-07 17:21:35.965 [INFO ] [g.openwebnet.bus.MyHomeSocketFactory] - COM RECEIVED  <<<<<<<<<<<<============ *#*1##
2019-01-07 17:21:35.973 [INFO ] [org.openwebnet.OpenGatewayBus$a     ] - MON RECEIVED  <<<<<<<<<<< *2*1000#2*51##
2019-01-07 17:21:35.975 [DEBUG] [penwebnet.message.OpenMessageFactory] - ##openwebnet## COMMAND TRANSLATION, WHAT=DOWN
2019-01-07 17:21:35.992 [INFO ] [org.openwebnet.OpenGatewayBus$a     ] - MON RECEIVED  <<<<<<<<<<< *2*2*51##
2019-01-07 17:21:35.991 [WARN ] [.handler.OpenWebNetAutomationHandler] - ==OWN:AutomationHandler== updateAutomationState() FRAME <*2*1000#2*51##> NOT SUPPORTED for thing openwebnet:bus_automation:15be17ca, ignoring it.

:thinking:
Anyway thanks for the suggestion!


(Michele) #401

The first log gave problems on the energy bus, while the second is right on bus automation


(Michele) #402

The best thing is to configure via .items and .things files because you have many more options especially to manage .sitemaps


(Massimo) #403

thanks @mix! This is helpful, gateway discovery will be added in next releases.
Bye
M


(Massimo) #404

@enrico.mcc, @gozilla01 there is a bug in beta9-1 where devices with same WHERE (51) are confused and messages from BUS are sent to the wrong device:

2019-01-06 23:10:22.015 [WARN ] [bnet.handler.OpenWebNetEnergyHandler] - ==OWN:EnergyHandler== handleMessage() Ignoring unsupported command for thing openwebnet:bus_energy_central_unit:ef0da2a6:51. Frame=<*2*0*51##>

this is a Automation message delivered to a Energy thing.
It will be fixed in beta9-2, see #42.

M


(Enrico) #405

Thanks massi! :top:


(Mark) #406

Hi, Just got a new problem and I am starting to investigate.

Sitemap now generates an out of memory error.


Problem accessing /basicui/app. Reason:

Server Error

### Caused by:

java.lang.OutOfMemoryError: Java heap space

Log file also has eros relating to memory issues

Around the same time I noticed my Thermostats were suddenly not showing any values in the sitemap. Everything else in the site map was fine.

On researching the memory error I saw that it can be caused by some bindings not releasing memory. I am wondering if the two issues are related. Has anyone else seen a similar problem. I already tried deleting the cache, restarting etc but no luck in fixing it.

Now non of my BUS items are showing in the log. So it seems something hs gone wrong with the binding. Next I will try uninstall this binding and reinstall.


(Mark) #407

Completetly died at one point but I recovered it somewhat after doing update from openhab config panel. But now I am back to the original situation with no thermostat temperature values or anything else for the binding. My other non BUS items and things are working well.

log file shows this

Error while starting bundle: file:/usr/share/openhab2/addons/org.openhab.binding.openwebnet-2.4.0-b9.jar

org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.openwebnet [236]

I tried bundle uninstall and installing the latest version.

Log shows this

Error while starting bundle: file:/usr/share/openhab2/addons/org.openhab.binding.openwebnet-2.4.0-b9-1.jar
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.openwebnet [237]

(Michele) #408

Which OH version 2.4.0 Stable?
Have you tried to send the two commands with Haraf console?


(Mark) #409

openHAB 2.4.0-1 (Release Build)

If you mean Karaf bundle:list and bundle: uninstall, then yes, after I updated openhab. Before updating from config even Karaf didn’t work. Now just openwebnet binding doesn’t install.


(Michele) #410

I meant these two commands

feature:install openhab-transport-serial
feature:install esh-io-transport-upnp

(Mark) #411

I tried that

Error executing command: No matching features for esh-io-transport-upnp/0.0.0

Also after restoring openhab-cli backup I see this… Nothing is installing!!!

2019-01-10 19:53:42.595 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-package-standard': No matching features for openhab-package-standard/0.0.0

2019-01-10 19:53:42.761 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-http1, openhab-persistence-mapdb, openhab-binding-exec, openhab-ui-homebuilder, openhab-misc-openhabcloud, openhab-misc-restdocs, openhab-transformation-javascript, openhab-persistence-influxdb, openhab-ui-habpanel, openhab-transformation-regex, openhab-binding-mqtt1, openhab-persistence-rrd4j, openhab-ui-basic, openhab-transformation-map, openhab-binding-ntp, openhab-action-mail, openhab-binding-astro, openhab-binding-expire1, openhab-ui-paper, openhab-transformation-scale': Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=system; type=karaf.feature; version="[4.1.5,4.1.5]"; filter:="(&amp;(osgi.identity=system)(type=karaf.feature)(version&gt;=4.1.5)(version&lt;=4.1.5))"

Odd thing is that sitemap is working again

I am stuck now.


(Michele) #412

I know so much that you have to install everything from scratch.


(Mark) #413

Its the first time I needed to use the cli backup. I worked OK but didn’t fix the problem. Nor did updating openhab

Start afresh…Something for the weekend LOL


(Mark) #414

sorry to divert the thread but I thought it was a binding issue. I got rid of the final issue, the error in the log, after clearing the cache. Thanks for the support.


(Michele) #415

Great that you have solved