Can not install openHAB

openhabian
Tags: #<Tag:0x00007f01437b2b90>

(4integration) #1

Hi,
Today I have spent suite some time on doing a fresh install of openHAB on Raspberry Pi 3.
I have done this several times before but today i won’t work.
First I tried a number of times with openhabian.

Flashing the SD
Booting and waiting (at longest 90 min)
Going to http://:8080 and no response
Checking status of the service

[13:17:17] openhabian@openHABianPi:~$ sudo systemctl status openhab2.service
openhab2.service - openHAB 2 - empowering the smart home
   Loaded: loaded (/usr/lib/systemd/system/openhab2.service; enabled; vendor preset: enabled)
   Active: activating (auto-restart) (Result: exit-code) since Fri 2019-01-11 13:17:21 CET; 751ms ago
     Docs: https://www.openhab.org/docs/
           https://community.openhab.org
  Process: 940 ExecStop=/usr/share/openhab2/runtime/bin/karaf stop (code=exited, status=1/FAILURE)
  Process: 924 ExecStart=/usr/share/openhab2/runtime/bin/karaf $OPENHAB_STARTMODE (code=exited, status=1/FAILURE)
 Main PID: 924 (code=exited, status=1/FAILURE)

Jan 11 13:17:21 openHABianPi systemd[1]: openhab2.service: Failed with result 'exit-code'.

Got that several times so got tired.

Trying with basic raspbian-lite installation (all updated) and the openHAB package installation as described at https://www.openhab.org/download/

and the same thing here :frowning:

pi@openhabpi:~ $ sudo /bin/systemctl status openhab2.service
openhab2.service - openHAB 2 - empowering the smart home
   Loaded: loaded (/usr/lib/systemd/system/openhab2.service; disabled; vendor preset: enabled)
   Active: activating (auto-restart) (Result: exit-code) since Fri 2019-01-11 14:45:19 CET; 2s ago
     Docs: https://www.openhab.org/docs/
           https://community.openhab.org
  Process: 741 ExecStop=/usr/share/openhab2/runtime/bin/karaf stop (code=exited, status=1/FAILURE)
  Process: 725 ExecStart=/usr/share/openhab2/runtime/bin/karaf $OPENHAB_STARTMODE (code=exited, status=1/FAILURE)
 Main PID: 725 (code=exited, status=1/FAILURE)

Jan 11 14:45:19 openhabpi systemd[1]: openhab2.service: Unit entered failed state.
Jan 11 14:45:19 openhabpi systemd[1]: openhab2.service: Failed with result 'exit-code'.

What shall I do?


Openhabian Fail not working
(CM6.5 H102) #2

Join the party here.:disappointed_relieved:

And see this issue on github


(CM6.5 H102) #3

@4integration The issue on github was just closed so try editing the underscores as described below.:crossed_fingers:

“There seems to be a typo in /opt/jopenhabian/functions/java-jre.sh. The script tries to open /opt/openhabian/includes/azul-zulu-license.md but there is no such file. The file-name is azul_zulu_license.md with underscores instead of dashes! Maybe that is the problem?”


(Emiel) #4

I have a RPI 3B + did fresh install and every things looks fine share are up and running. But at the end of the install script it tries to start openHAB 2 and its loops in starting and stopping openHAB 2.

I also have the same result on a SSH console :
[20:43:12] openhabian@openHABianPi:/opt/openhabian/functions$ sudo systemctl status openhab2.service
[sudo] password for openhabian:
● openhab2.service - openHAB 2 - empowering the smart home
Loaded: loaded (/usr/lib/systemd/system/openhab2.service; enabled; vendor preset: enabled)
Active: activating (auto-restart) (Result: exit-code) since Fri 2019-01-11 20:44:03 CET; 832ms ago
Docs: https://www.openhab.org/docs/
https://community.openhab.org
Process: 11566 ExecStop=/usr/share/openhab2/runtime/bin/karaf stop (code=exited, status=1/FAILURE)
Process: 11550 ExecStart=/usr/share/openhab2/runtime/bin/karaf $OPENHAB_STARTMODE (code=exited, status=1/FAILURE)
Main PID: 11550 (code=exited, status=1/FAILURE)

Jan 11 20:44:03 openHABianPi systemd[1]: openhab2.service: Unit entered failed state.
Jan 11 20:44:03 openHABianPi systemd[1]: openhab2.service: Failed with result ‘exit-code’.

I am a first time user, any help to fix this?


(4integration) #5

@mick1610 I tried to flash a new SD card this morning and seems to work fine .
See here Openhabian Fail not working


(Emiel) #6

Hey all,
I got it working last night 23:00u. I saw on this site that in a Github about the openhabian some one had the same problem. The advice was to installl java again. And I noticed that after running:
sudo java -version
I got a error that this command was not known.
So I installed Java by:
sudo apt-get install default-jre
Tried to start openhab 2 did not work.
Then I went to the config of Openhabian: by: sudo openhabian-config
And installed the latest openhab Snapshot en restarted openhab 2. And it worked.


(4integration) #7

@mick1610
I will try doing the same (using snapshot) since currently the “stable” 2.4.0 doesn’t seem to be stable in my system.

When you access PaperUI and Add-ons - what tabs do you see there?
I only have Bindings, Misc and Voice and missing Actions, Persistence, UI,…etc

EDIT: The same goes with 2.5.0 snapshot after upgrade


(CM6.5 H102) #8

@4integration after upgrading to 2.5 do a reboot and clean cache to see if everything comes back.

sudo systemctl stop openhab2

sudo openhab-cli clean-cache

sudo reboot


(4integration) #9

Thanks @H102 but didn’t help.
From being a happy openHAB user for many years …since 2.4.0 my experience/happiness have be drastically reduced. openHAB at 2.4 should be more stable than this…

EDIT: I don’t mean this have anything with the 2.5 snapshot version since it happened with 2.4 stable also and as I have written in Cannot access actions or legacy bindings in PaperUI it happens on:

  • Fresh install of openhabian
  • Fresh package install on Raspbian
  • ZIp package on Windows

(Emiel) #10

I have all the tabs, Actiosn, Bindings, Misc, Persistance, Transformations, User interfaces, and Voice.


(4integration) #11

I have got that also. I have selected “Simple” since I just wanted a minimal setup and control it my self.

As it seems “Simple - Purely UI” only gives you a subset of the UI in PaperUI (a bug to me) but standard gives “Action” tabs etc


(CM6.5 H102) #12

I’ve never tried installing simple due to this line in the addons.cfg “you need to expect MANY constraints in functionality!”.:neutral_face:

I’m not a fan of constraints.:laughing:


(Geoff) #13

I too am a first time openhab user.
Bought a Pi3b to solve my Vera/Lutron/Nuheat/Google woes, but am stuck trying to get it to work.
I’ve used etcher to burn to card, popped it into the Pi, attached ethernet, turned on.
Waited hours even, unable to access it’s interface.
As a first time user, can you explain how you got it working, or point me to.where you found out how?


(CM6.5 H102) #14

@Geoff1 have you tried accessing the interface using the IP address (Example 10.0.1.12:8080) and a different browser?

If still no luck then connect a HDMI cable and monitor to the RPI and let us know what on the screen. Or you can access via ssh with something like Putty with the default user and password as openhabian:openhabian

Note: If you haven’t tried a fresh image and install within the last few hours then I would start there as some issues have been solved earlier with installation.


(Emiel) #15

Strangely enough I did an new fresh install with 2.4.0 Openhabian and did use the same image from 3 days ago when it all did not work and now I had no problem at all. So I think something has changed. I think that the Zulu Java install has changed. Now I have Java and a working Openhab and used the demo set up afterwards which is also working. So I did not change an thing and now its working…


(CM6.5 H102) #16

Correct, how Java gets downloaded was fixed. The image just points to what needs to be downloaded so what image used is not a big deal.


(Geoff) #17

Well, I figured never hurts to start fresh, again. Today, downloaded image, flashed SD card, popped it into my Pi, connected to ethernet, powered up and now it works!
Always a relief when it suddenly works, always a concern as nothing done differently…