ConnectedCar Binding myAudi, Volkswagen, VW ID, Skoda, Enyaq, Seat, Ford, WeCharge

Hmm… The last update just before the token error was at 19:04 (matching the 15 minute intervals). This went well, but then 4 minutes later I got the token error mentioned before. It then tried once more with a LOOOT of loggings (including what seems to be updates on most points), and then ends up with the following being the last activity. general_LastUpdate stays at 19:04. Nothing more happens.

2022-11-23 19:19:24.982 [DEBUG] [nectedcar.internal.api.ApiHttpClient] - : HTTP POST https://tokenrefreshservice.apps.emea.vwapps.io/exchangeAuthCode

2022-11-23 19:19:25.228 [DEBUG] [nectedcar.internal.api.ApiHttpClient] - : HTTP 200 Response: {“access_token”:“eyJra…<lots_of_chars>…e4yAZ0M”,“token_type”:“bearer”,“expires_in”:3599}

2022-11-23 19:19:25.232 [DEBUG] [ctedcar.internal.api.IdentityManager] - Skoda-E: accessToken was created, valid for 2880sec

2022-11-23 19:19:25.234 [DEBUG] [nectedcar.internal.api.ApiHttpClient] - : HTTP GET https://api.connect.skoda-auto.cz/api/v1/position/vehicles/TMBJB9NY9NF009138/parking-position

2022-11-23 19:19:25.274 [DEBUG] [nectedcar.internal.api.ApiHttpClient] - : HTTP 403 Response:

2022-11-23 19:19:25.277 [DEBUG] [ng.connectedcar.internal.api.ApiBase] - : API call getValues_position/vehicles.parking-position failed: class org.openhab.binding.connectedcar.internal.api.ApiSecurityException Forbidden GET https://api.connect.skoda-auto.cz/api/v1/position/vehicles//parking-position (HTTP 403 Forbidden)

2022-11-23 19:19:25.278 [DEBUG] [ectedcar.internal.api.ApiBaseService] - Service status is not available!

In case anyone is interested, I created a dashboard for my Audi A6: Openhab connected car dashboard · GitHub
I’ve also attached a sample config for the link with item names / channels.

It looks overall like this:

Hi All,

I have tried to get this working with my Ford vehicle. I couldnt get any of the bindings to work with the account credentials and have updated my password a couple of times. I am currently using binding 3.3.0.

The output is:

COMMUNICATION_ERROR

Initialization failed: java.lang.IllegalStateException: Expected BEGIN_OBJECT but was STRING at line 1 column 151 path $.error ( Unable to parse ‘{“error_description”:“CSIAQ0172E The grant type [password] is not supported. Supported grant types are [authorization_code, refresh_token].”,“error”:“unsupported_grant_type”}’)

It looks like the ford portion isnt working?

Thanks
rahimlee54