Custom openHAB Cloud instance IFTTT connectivity

Hello, I have setup up my openHAB Cloud instance on my server. Everything is working fine expect IFTTT, I have followed this guide

The issue I have is when I try to run an authentication test from the IFTTT Developer Platform

I have entered an user that is connected to an openHAB2 installation, and is showing ONLINE.
Any ideas? Haven’t seen anything in the forums

I was in the same situation like you after followed the same guide.
My mistake was I didn’t filled out the IFTTT API URL in the General section of the API tab. We must set our Custom Openhab URL and this is not covered in the guide.
Now, the Auth test pass all green, I hope this is the same mistake for you.

Best regards.

I still get an error, but it’s different.

I think I have your culprit : The request URL you’re setup is in http and your server redirect http to https then the body response is “Moved” in this case.
Try to set your URL with https ?

thanks, that helped

Happy to read that :wink:

another question, did you get openhab2 applets working with your custom server?
i want to be able to send a command

Just tested and yes it works with my custom server.
Did you setup Triggers and action like described in this post ? :

And you must not use the official openhab2 applets, but your custom one you’ve created.

yup, i have just followed the guide, i tried running the endpoint test, they failed,

All is green from my side except triggers/itemstate.
Did you setup a correct test account in Auth menu ? (but I’m not sure it’s used)
What is the content of the first error block ? user/info

Auth failed … are you sure that the Auth test pass correctly now ?
My last thought is maybe a problem with your “iftttChannelKey” or “iftttTestToken” ?

yup fixed it, still doesn’t show any items, they are exposed in the paper ui

it shows loading on the ifttt which item section

I’ve faced to the same situation, stuck in loading state in item selection.
I’ve managed to get it work again by unlink my account in the setting of My applet > Services > My custom service and relink it again.

it helped, thanks a lot


I may ask a silly question, Can I setup everything on openhabian ran on Raspberry pi 3?