Distributing bindings through the IoT Marketplace


(Scott Radner) #21

Using apt on Ubuntu with SNAPSHOT builds and I am not seeing the new IoT Marketplace. Looking at cloudbees it appears builds have been unsuccessful since #826. The logs tend to all have the same pattern:

14:52:16.241 | Uploading archive online-repo-2.1.0-SNAPSHOT.zip
15:30:08.779 | Build timed out (after 60 minutes). Marking the build as aborted.
15:30:08.791 | Build was aborted

Not sure if this helps isolate a problem, but trying to be helpful.

Thanks for all the great work on this project. Cheers.


(Karel Goderis) #22

@Kai Kai, is this valid for new PR only? I see that some old historical PR are not in the l-p-l folder (example: KNX). If so, people concerned should close PR and make new ones....


(Wouter Born) #23

A good PR builder should really save people time on all sorts of hosting issues. I ran into some hosting issues because my submitted bindings failed to download. The only error that showed was "Error reading bundle content."

Here is some information that may help other people debugging such issues:

  • The IoT Marketplace does not host the bundle JARs or JSON files, it only provides links to them. So put these on a reliable host that can handle some traffic.
  • The Marketplace content is currently loaded from this catalog. So after approval, it should contain the right URLs.
  • Before submitting a binding you can also check if your binding bundle can be properly downloaded/installed via the console by issuing:
    bundle:install http://yourhost.org/yourbinding.jar

In the end my hosting issue turned out to be the Cloudflare Browser Integrity Check that disallowed Apache Karaf from downloading files.


(Kai Kreuzer) #24

PR builds are triggered whenever you push a new commit. If you don't have anything to push, you can also briefly close and directly re-open an existing PR.

Right, this is what I mentioned here. In the past that was always only a temporary problem; I have no clue why it is failing this time so often in a row...


(Craig) #25

I have a question.

Say I create a new version of a binding I am working on and it now available on the url specified within the marketplace url.

For beta testers/end users how would upgrading the binding to that latest build work?

thanks,
craig


(Gregory Moyer) #26

@wborn - did you find a solution to the build problem? My PR (https://github.com/openhab/openhab2-addons/pull/2009) is having the exact same problem with the Feed binding. I can even reproduce the error on a clean clone of the OpenHAB2 Addons repository (none of my code).


(Wouter Born) #27

It may have to do with that the org.openhab.io.transport.feed bundle provides the com.rometools.rome packages on which the org.openhab.binding.feed bundle depends.

I'm not a tycho dependency resolution expert, but with normal Maven dependencies there should be a dependency on this in the POM of org.openhab.binding.feed however it is not.

I can also imagine such dependency resolution is fine with tycho, but due to implementation changes after a tycho upgrade sometimes fails now.

The reproduction scenario in your PR may help @Kai with solving it.


(Kai Kreuzer) #28

FTR: Same issue reported here. I'll have a look at how that can be solved.


(Kai Kreuzer) #29

The feed binding dependency resolution should hopefully be solved now through this PR.


(Kai Kreuzer) #30

Probably simplest to do uninstall/install in the paper ui - I would expect this to download the latest version.


(Kai Kreuzer) #31

Hi,

great to see that there are already so many entries in the marketplace!

I'd like to again point you to my comment above - it would be nice if the Z-Wave (@chris), Isy (@craigh), DMX (@J-N-K) and Zmote (@Temar) binding listings could be adapted accordingly (i.e. do not mention "openHAB", add "Binding" to the title, add a custom logo). Thanks!


(Alex) #32

Done


(Jan N. Klug) #33

Since I am not a graphics designer, I cannot and will not provide a custom logo. We can either leave the DMX binding with the default icon or remove it from the listing. Please advise.

Best Regards,

-jnk


(Craig) #34

ya, I was a little uncomfortable grabbing an image depicting the Isy as well, I didn't bother with copyright permissions.

Logos aren't easy for a developer.


(steve1) #35

If it's a choice between cosmetics and useful contributions, I vote for the contributions! :slight_smile:


(Kai Kreuzer) #36

I think hardly anyone of us is a graphics designer. But I think almost everything is better than having the Eclipse logo shown. And be it "DMX" as bold letters as a png or a picture of some DMX LED lights...


(Kai Kreuzer) #37

Also like to remind @SuperOok and @ChrisSFoot of this comment - thanks!


(Chris Foot) #38

Done!


(David K.) #39

Somehow the DMX binding disappeared - is this intended?

I have made a very quick logo in case this was the reason - Source is me and just do whatever you want with this!

DMX_Logo.pdf (1.8 KB)

Cheers
David


(Super Ook) #40

Done