Ecobee Thermostat (fork off @Singal11)

widget
widgetgallery
Tags: #<Tag:0x00007f1e60239a30> #<Tag:0x00007f1e60239878>
(Red Oranges) #1

Control your Ecobee thermostat with this widget
(a fork off @Signal11 ecobee widget )
Screenshot-2018-4-25%20HABPanel Screenshot-2018-4-25%20HABPanel(4)

Required Files

Widget
Ecobee Thermostat.widget.json (19.9 KB)

Icons
These icons need to be downloaded and extracted to conf/html
Icons.zip

Items
You must edit this file to match your ecobee ID in each item, place it in conf/items
Ecobee Thermostat.widget.items

rules
You must edit this file to match your ecobee ID, place it in conf/rules
Ecobee Thermostat.widget.rules

Required Bindings
OpenHab Ecobee binding

Required Actions
OpenHab Ecobee Acion

Heat only
Screenshot-2018-4-25%20HABPanel(1)

Menu to change heating mode
Screenshot-2018-4-25%20HABPanel(2)

Remote Sensor display
Screenshot-2018-4-25%20HABPanel(3)

Change log

  • Fixed bug that would display sensors out of order or not at all

Features

  • Will display Celsius and Fahrenheit depending on your thermostat setting
  • Uses thermostat settings for max and min cooling for simpler setup
  • Display multiple remote sensors
  • Updated responsive design and other UI enhancements thanks to @Natalie_Nielsen

Known issues

  • Use remote sensor icon
  • hide units doesn’t do it everywhere
  • Want to hide sensor menu button if no sensors available
0 Likes

Custom Widget: Ecobee thermostat
(Matt Aitchison) #2

The icon file link is broken, is it possible to update it?

0 Likes

(Red Oranges) #3

I was relying on the original link by @Signal11 to his google drive.
I’ll try and find a copy and post an update

0 Likes

(Ciaran Kennedy) #4

That would be awesome - have the widget installed and working great … just need the icons. Thanks in advance.

0 Likes

(Red Oranges) #5

If anyone knows how to upload a zip file to this forum let me know, this was is clunky.

0 Likes

(Ciaran Kennedy) #6

Thankyou!

0 Likes

(R_B) #7

For some reason when I change the temp slider, it does not change my actual thermostat temperature. I can change it from Heat to Cool and back again without issue (i.e. it changes the thermostat). Temperature slider does nothing. Any ideas?

0 Likes

(Red Oranges) #8

My first guess would be that the rules file isn’t correctly installed?
Make sure you updated your ecobee id in that file and it’s in the right place.

If it looks ok, i’d say take a look at the event logs and see if the items are being updated.

0 Likes

(R_B) #9

My bad… I didn’t have the Ecobee Action installed. I would update your initial post to state:
Required Bindings: Ecobee Binding
Required Actions: Ecobee Action

It doesn’t seem to read all my remote sensors correctly… no events in the log file and nothing obvious… thoughts?

It shows 2 out of the 4 total as follows:
Living Room
20C (Unoccupied)

(Unoccupied)

Home
20.2C (Unoccupied)

(Unoccupied)

0 Likes

(Red Oranges) #10

Fixed and updated. Try again

0 Likes

(R_B) #11

Just updated… same problem… actually, now I only see one name (Living Room) and the rest are no names, no temperatures, and all state (unoccupied).

Also, now I have the A in front of my degrees Celsius reading.

0 Likes

(Red Oranges) #12

Sorry about that, I recently switched to github to host the file but never changed the link on this page for the actual widget file.
try again now.

0 Likes

(R_B) #13

All good.

Celsius fixed, but now there are no names for any of the Sensors… I’ve got temperatures and occupancy for all 4. Just no names.

Appreciate the quick turn around on these!

0 Likes

(Red Oranges) #14

Ahh, ok I see the issue, will try an update but can’t today

stay tuned.

0 Likes

(Red Oranges) #15

I pushed an update, please try again

0 Likes

(R_B) #16

All working. Awesome work and thank you!

0 Likes

(David Schatz) #18

I have followed the instructions but all I see is a gray box for the widget

0 Likes

(David Schatz) #19

im sorry I am dumb and fixed this, however I would like to get rid of the remote sensors being displayed since i don’t have any. is this easy?

0 Likes

(Red Oranges) #20

There is an option to display them on a second screen with the the “hamburger” icon at the bottom.
I don’t have an option to hide that icon if you don’t have sensors.

0 Likes