Etcher error message

Total newbie fed up with four months of frustration with Home Assistant, hoping to have an easier time with something different. Following the instructions on the openhab website, I am trying to use balena etcher to put openhab on an SD card for installation on a Raspberry Pi. When I attempt to load the file into etcher, it says it’s missing partition table, whatever that means. Any clue what I’m doing wrong? So far it seems like going from home assistant to openhab is like going from the frying pan into the fire.

According to you may have to disable the trim option in etcher.

Which Image did you use?
I flashed the latest openhabian due to some testing with OH3 like 5 times onto SD/SSD without any issues.
I took version 1.6.1 from

That’s what I’m attempting to use but etcher doesn’t like the file for some reason. Etcher had no issues with a Home Assistant image file.

That is irrelevant to my issue with etcher. I’m using a newer version, and I don’t have a problem with the continue button not working. Thanks anyway. Try reading a bit more carefully next time.

What OS are you running etcher from?
Don you run it with admin rights?
Do you extract or modify the downloaded image somehow before flashing?

OS is Ubuntu 20.04.1 LTS. No extraction or modification. Not sure what you mean by admin rights. Like I said before, I have no trouble with other image files. Etcher didn’t give me any errors with the image file for the latest version of Home Assistant, so I’m assuming the problem is with the openhab image file.

Then there should be other reports, too, right …? But the opposite seems to be the case as @Sascha_Billian reported he used the same image.

I don’t care whether or not there are other reports. I know only what I have experienced. I’ve successfully used other image files with etcher. The openhab image file is the only one that causes error messages. I don’t appreciate your confrontational tone. If you can’t be civil, kindly remove yourself from this thread.

Something about pots and kettles…

And the rest of your nonsense from here: May be a stupid question

There are currently zero other reports of this being an issue, and I can guarantee that with OH3 being released on Monday there have been many SD card etchings of openhabian in the last couple of days.

The problem is with your system, not the openhabian file. But then

so good luck I guess.

If you think you’ve found a bug, please file an issue on GitHub as you’re more likely to reach the developers.

1 Like


I can’t see any confrontational tone in the posts above other than yours while the others here tried helping.
With the information provided from you everybody just gan guess what could be the problem.
You didn’t mention in the beginning:

  • What OS you are running etcher on (hence my question with admin rights since i thought you are running on windows)
  • which openhabian image you are yousing
  • no conrete error message from etcher (maybe a screenshot would help understand this issue since nobody else has had it)

So please excuse our “confrontational” tone. We’re all trying to help you but the only feedback we got is

  • read more carefully…
  • i don’t care…
  • i don’t appreciate

@Wolfgang_S was going through the etcher issues on GitHub to see if there’s anything that would help. So he basically did research for your problem.
So please think about your tone here in the community.

back to topic:
Is the message on etcher just a warning as described here: Missing Partition Table Issue - balenaEtcher - balenaForums
What happens if you click on continue? Does etcher do the flashing? Above you’ve reported that you don’t have a problem with the continue button.

1 Like

I haven’t attempted to continue past the error message. I’m not interested in taking any risks.

What shall happen in the worst case? Just give it a try.

RasPI boots different than other devices (see The boot folder - Raspberry Pi Documentation)

So instead of looking for a MBR or GPT, Raspi looks onto the first partition of the attched SD for the relevant files and starts booting. So ignore the warning and continue

I tried clicking continue below the error message and the message went away but nothing was written to the SD card.

Can you let us know what you used?
Image, SD-card make and model, etcher software version, OS software version?
I tried to reproduce issue with the image downloaded from:
Installing with etcher 1.5.100 on Linux Mint 20 with a generic 8 GB SD, which went just fine.

I’d like to suggest to redownload the image(the same as above) and try again, it will only take you the time to redownload and retry.

If only openhab documentation was as detailed as you want me to be in my forum posts, I wouldn’t need to ask for help.

Let’s first solve your issue and then we can see where documentation lacks.
Could you answer the questions so we can help you out?

Well, again a user tried to reproduce your problem in his/her free time and you can’t do anything else than complain instead of helping finding the problem.

To be honest: it might be better for the community here if you’re not able to get it running. I’m afraid of the questions that come up once you start with integrating your hardware into openHAB, because they mostly will end up like “the documentation is sh*t…”

Since it’s Christmas: I wish you a relaxing time and good luck finding a ready2use home automation solution that fits your needs.

Excuse me for sleeping. I’ll answer questions when I have the time. You need to learn patience.