EU Zigbee dongle

zigbee
Tags: #<Tag:0x00007fd311bdc220>

(Elelabs Maintainer) #101

Sorry for the confusion.
The USB Adapter is cross-platform.
It uses the CP2102 USB -> UART converter, which was described before in this thread and used by Telegesis stick as well.

On Windows it looks like this (Device manager):
EZBUSBA_windows

On Ubuntu it is detected as Serial Port:
EZBUSBA_ubuntu

Yes, on Windows you might need to install drivers additionally. But this is described both in this thread and for example here: How to Install Drivers on Windows

Also, we have a detailed instruction on how to setup OpenHAB to use this adapter.


(Rasmus Balle) #102

Thanks… sorry for the misunderstanding :slight_smile:
Then I’ll order one and test :slight_smile:


(Ma Ody) #103

Same problem here:

I was very happy to get the Aqara Body Motion Sensor and the Door/Window Sensor recognized wiithout the Aqara (Xiaomi) Bridge by using the Telegesis USB Stick.

Everything working well but after a few minutes the Aqara devices went offline.

openhab events.log just notes: "2018-05-18 20:50:59.585 [hingStatusInfoChangedEvent] - ‘zigbee:device:04000B3F:00158d00020599fc’ changed from ONLINE to OFFLINE
"

i found no other way to get them back to online status than delete the things and do a new discovery.


(Peter) #104

Did you get anywhere with this? I also have this problem, which is very weird, I had a few Aqara devices working on 2.2 with the SNAPSHOT build of the Zigbee binding everything was stable for the Zigbee binding.
But (about) when the change in ESH made the 2.3 add-ons not work on 2.2 this exact problem started to happen for me.

I have been trying to nail the logs for this since, but I cannot get anything good, the only thing I find is: It worked perfectly, then I upgraded (now on 2.3 RC1) and now it doesn’t.

@chris you are not using Telegensis are you? That is the coordinator I use, what about you @Eberhart? Could that be an issue with these devices?

(And if someone finds the silence from me concerning: newborn baby+new job=zero time)


(Chris Jackson) #105

I have multiple systems running Telegesis, Ember and XBee. Occasionally I also use the TI CC2531, but Telegesis and Ember are my main systems at the moment.


(michel kamp) #106

Great piece of hardware !. So anyone tested the Elelabs Zigbee USB out with OpenHab ?

  • Does the USB version work on a RPi based openHab ?
  • Does it work with all zigbee profiles ?
  • Does it work with HUE ?
  • Does it work with IKEA lamp motion and switches devices ?
  • I read posts that are indicating (for other zibee USB devices) the commutation stops after x hours and openhab has to be restarted to get it working again. Its this device not having this issue ?
  • what version of openhab did you use ?

I am currently running as main controller Domoticz on an RPi (zwave) and evaluating Openhab (Zwave and would love to add ZigBee). Also using Homey (for test) having ZigBee and zwave build in but it has some very annoying delays .

Thanks,
Michel


(Chris Jackson) #107

Check the readme for the binding for an (incomplete) list of devices supported.

I believe that this is solved - I’ve had no reports of this for a long time.


(Elelabs Maintainer) #108

We have prepared a User Guide on how to work with Elelabs ZigBee USB with OpenHAB.

Does the USB version work on a RPi based openHab ?
Yes. It does.
Does it work with all zigbee profiles ?

The adapter itself can work with ZHA, ZLL, Energy measurement profiles, but to my understanding ZigBee OpenHAB binding supports only ZHA profile right now. Though it can still work with the ZLL devices, just doesn’t support all the features, ZLL offers.

Does it work with HUE ?
Yes. It does. At least tested with the bulbs. More devices are on the test list.
Does it work with IKEA lamp motion and switches devices ?
Lamp yes, motion and switches to be tested.
I read posts that are indicating (for other zibee USB devices) the commutation stops after x hours and openhab has to be restarted to get it working again. Its this device not having this issue ?
Have not seen yet. Would appreciate a link to the problem description to get a deep look.
what version of openhab did you use ?
The required support for Elelabs USB Adapter was added since 2.3.0 ZigBee binding version. So 2.3.0+


(Chris Jackson) #109

Check the issues list - there are a couple of open issues. One I think is resolved through a thread blocking issue in the ASH layer, and I think is closed. The other is possibly still there for large networks. I will take a look at closing some of these as there have been no reports on this for many months.

I guess the answer to this question is that as this is simply a standard Ember NCP, IF the problem is still there, then this device will also suffer the problem.


(Daniel Walters) #110

Both my Xiaomi sensors and Philips Hue dimmer are discovered and then drop out the network within a few hours. I don’t have any other devices to test but, at least in my experience, I would say it’s still an issue.


(Chris Jackson) #111

If you have an issue, then please comment on it, and PLEASE provide logs so we can see if it’s the same issue and try and resolve it.

It’s very common for people to say “I have the same issue”, but without real information (ie logs!) it’s often very difficult to confirm this.

I doubt this is related to the issue that is reported on the issues list at the moment where the whole binding locks up due to too much traffic. Of course it could be, in which case this is a known issue, but if you only have a small number of devices, this is probably not the problem.


(Chris Jackson) #112

I should also add that the Xiaomi devices are well known for dropping off the network - there are also comments about this on other forums (eg SmartThings). These are not ZigBee compliant and I think don’t support routing properly, and I think will only connect to the coordinator directly…


Sensors? I'd like to buy the < $5 ones, not the > $30 ones
(Daniel Walters) #113

I’m having issues with the Philips Hue dimmer too which as I understand is certified as ZigBee compliant.

I’ve raised https://github.com/openhab/org.openhab.binding.zigbee/issues/215 which has a log attached


(Chris Jackson) #114

The hue dimmer is not supported by the binding, so this won’t work.


(Daniel Walters) #115

I’m confused as it looks like support was added here:


(Chris Jackson) #116

You’re right - this was added it seems. I’d forgotten since most remotes are not supported at the moment. I had a look at your log, but it doesn’t really show any problem - the devices all appear to be working from what I can tell and it would be useful if you can provide some information about what the log shows from the user perspective.


(Joe) #117

i’m using telegesis etrx357 usb lrs.
it works with baud rate of 19200. after changing the coordinator to 57600 i get errors.

on 19200 there are delays on dimmer synchronisations. (osram bulb)

2018-06-12 13:26:58.602 [me.event.ThingUpdatedEvent] - Thing ‘zigbee:coordinator_telegesis:08a2a421’ has been updated.

2018-06-12 13:26:58.988 [hingStatusInfoChangedEvent] - ‘zigbee:coordinator_telegesis:08a2a421’ changed from ONLINE to OFFLINE: Failed to startup ZigBee transport layer

2018-06-12 13:26:59.072 [hingStatusInfoChangedEvent] - ‘zigbee:coordinator_telegesis:08a2a421’ changed from OFFLINE: Failed to startup ZigBee transport layer to UNKNOWN

2018-06-12 13:27:01.271 [hingStatusInfoChangedEvent] - ‘zigbee:coordinator_telegesis:08a2a421’ changed from UNKNOWN to OFFLINE: Failed to initialize ZigBee transport layer


(Chris Jackson) #118

How did you change the dongle speed? Maybe it didn’t get set correctly as it looks like the dongle is no longer responding.


(Joe) #119

im using paper ui
Configuration --> Things --> Edit --> Telegesis Coordinator

how can i do it on another way?


(Chris Jackson) #120

Sorry - I’m a bit confused. The setting in PaperUI is to configure the binding to the configuration that is set in the dongle. If the dongle is set for 19200 (which is the default), then you need to set the binding to 19200, or it won’t work. If you set the binding to 57600, and have not somehow reconfigured the dongle, the binding will not be able to communicate.

It seems that you have not changed the dongle speed? I’d suggest to read the Telegesis manual to see how to configure this.