EU Zigbee dongle

zigbee
Tags: #<Tag:0x00007fd312292858>

(Joe) #121

hups…sorry… my fault.
changing the baud rate directly on the stick -->. it works.

but short question. how can i manage the dimmer-delay on visualisation?
setting the dimmer will be executeted immediately, but the visualisation “jumps”

update: i have seen that it is a general problem.
btw thanks for the hard work!


(Chris Jackson) #122

I’m not 100% sure I understand what you mean…

Do you mean that you click on the slider to move from 0 to 100%, the slider shows 100%, then maybe 50%, then 100%?

If that’s what you mean, then this is an issue with the way OH works. There should be a setting that stops the UI updating from the command, and only updates from the state. This should (mostly) fix your issue I think, but I can’t find this in the ESH docs at the moment and as it’s not something I personally use I can’t look it up.

Maybe someone else will be able to comment on this.


(Joe) #123

yes that is exactly what i mean!
thank you


(Joe) #124

why does the baud rate resets after reboot of the OS. (from 57600 to standard 19200 in paper ui)
also it resets after scan of zigbee binding.
is this a bug?


(Chris Jackson) #125

It shouldn’t do this. I know others (using Ember dongle for example) can change the baud rate without problem (there are two different Ember versions, and they use different baud rate and different flow control), so I don’t see why the Telegesis dongle should be any different as it’s literally exactly the same code (ie it uses a common class for all dongle types).


(Chris Jackson) #126

I just did a quick test using the Ember dongle, and it definitely saves the baud rate…


(Joe) #127

i set my baud rate to 57600. --> save the edit --> paper ui says ONLINE --> after reboot of raspberry the config resets to 19200.
here some screenshots

image

2018-06-13 08:40:17.798 [me.event.ThingUpdatedEvent] - Thing ‘zigbee:coordinator_telegesis:04000A33’ has been updated.

2018-06-13 08:40:19.926 [hingStatusInfoChangedEvent] - ‘zigbee:coordinator_telegesis:04000A33’ changed from OFFLINE: Failed to initialize ZigBee transport layer to OFFLINE: Failed to startup ZigBee transport layer

2018-06-13 08:40:20.017 [hingStatusInfoChangedEvent] - ‘zigbee:coordinator_telegesis:04000A33’ changed from OFFLINE: Failed to startup ZigBee transport layer to UNKNOWN

so i have to manually change to baud rate to 57600 in the paper ui config everytime i restart the raspberry.


(Chris Jackson) #128

I’m not sure why the reset of the PI would make any difference. When you save the speed, the binding saves this information, and then restarts the handler. This then reads it out of the system storage where all this stuff is stored (probably the json db unless you have something else configured).

So the information is stored or you wouldn’t be able to change the baud rate at all. Why a PI restart should affect that I have no idea, but it’s probably not related to the binding. Do other config also change?

I can test this with a Telegesis stick as well, but since all dongles use the same base class, it must be the same.


(Joe) #129

thats strange.
everything else works fine. also changes to other bindings are stored permanently.

can i config the telegesis as a .thing?
if yes, is there a sample configuration so i can test it (specifications)?


(Comlet Mb) #130

@chris
Since the Telegesis dongle isn’t working with innr Smart Bulbs (https://github.com/openhab/org.openhab.binding.zigbee/issues/60), but you posted a screenshot of a RB 185 C with an Ember stick in openHAB, which Ember stick is it exactly that you use?

I’ve spent hours reading posts and descriptions to find a stick that definitely works with it. I’m looking for a stick available in the EU, but I’m not sure yet. Any confirmed recommendations?


(Chris Jackson) #131

I tend to use the CEL stick, but this stick comes with no software and needs to be programmed which requires the devkit.

https://www.cortet.com/iot-hardware/cortet-usb-sticks/em358-usb-stick


(Michael Larsen) #132

Hi,
I am new to the Home Automation community and looked around online for tips.
OpenHab looks amazing and I have wanted to get a Raspberry Pi anyway.
I live in Denmark so from what I have seen online and in this thread I would probably have to either buy a USB linked by petero on Mouser or the ConBee. Are there any other supported options?
Would it be possible to buy an XBee S2C PRO or an XBee3 PRO and a USB XBee adapter? or would that not be supported yet?

Also a different question, I have seen a Sonoff wifi switch at a friends place, do you know if there is a Zigbee alternative like them? preferably available in Europe :wink:

Thanks a bunch xD


(Chris Jackson) #133

This is not supported.

Yes - you can use this.

The other common option is the Telegesis ETRX3 which is reasonably easily available in Europe.


(Michael Larsen) #134

Ohh the Xstick has gotten support after the post of ChrisSFoot in February nice :+1:

and ohh I guess I was looking at the wrong github, somehow I ended up at zsmartsystems, which has ConBee support. :face_with_raised_eyebrow:

Nice to know the XBee S2C PRO works :slight_smile:
and I will look for some telegesis tutorials before I choose what to buy :grin:


(Elelabs Maintainer) #135

Hey,
Check out our USB adapter as well.
Maybe you find that suitable.

I described it above:


(Kim Andersen) #136

I just received the Elelabs Zigbee shield for Rpi. I havn´t installed it yet, as I plan to install in it my spare Rpi 3B+ together with a USB hub, (things got pretty crowded on USB ports), one of the upcoming days.

Is there anything I need to be aware of regarding the Elelabs Zigbee shield? I guess I just insert shield, start the Rpi, and then install the Zigbee binding?
I have a quite few HUE bulbs, lamps, switches and a motion detector, beside an Osram Ligthfy power plug). Plus some Xiaomi devices as well. I believe they´re all compatable with the shield?
I suspect I just have to scan for these, or should they have to be excluded from their respective gateway first?


(Chris Jackson) #137

Probably they will be ok. Xiaomi devices can be problematic as they are not ZigBee compliant, but hopefully they will work ok. You need to keep pressing the button when including them to keep them awake.

Yes - you will need to reset them first otherwise they wont connect to a new network.


(Kim Andersen) #138

Okay, thank you Chris…


(Kim Andersen) #139

I just installed the Elelabs zigbee shield into my Rpi. The coordinator is working fine.
I then added a Philips Hue switch (Philips RWL021 switch) just to test it. It was added just fine as well, giving me me 3 channels available…

Switch (item type switch)
Battery Percent (item type number)
Battery voltage (item type number)

This is my item file:

//Philips Hue switches

Switch 	HueSwitch1				"Philips Hue switch1 [%s]" 						<switch>			{ channel="zigbee:device:6ec05458:001788011032a21b:001788011032A21B_1_switch_onoff" }
Number 	HueSwitch1_batteryPercent		"Philips Hue switch1 Battery percent [%s]"				<Battery> 	(BatteriLevel) 	{ channel="zigbee:device:6ec05458:001788011032a21b:001788011032A21B_2_battery_level" }
Number 	HueSwitch1_batteryVoltage		"Philips Hue switch1 Battery voltage  [%s]" 				<Energy> 	(BatteriLevel)	{ channel="zigbee:device:6ec05458:001788011032a21b:001788011032A21B_2_battery_voltage" }			

Nothing wrong here I guess.

Except, I do not receive any status from the battery, neither Percent or Voltage.

Question:
Is this Zigbee like Zwave, And I´ll have to wait for a “wakeup” alike before I can see the battery status?
If yes - How long will it take?

I also did a very short sitemap file:

sitemap hueswitches label="Philips Hue Switches"
{
		Text item=HueSwitch1
		Text item=HueSwitch1_batteryPercent
		Text item=HueSwitch1_batteryVoltage
}

I noticed in BasicUI, when I push either the ON or OFF button, BasicUI does not refresh the value, (the page). I have to refresh the page manually.
This is the first time I´ve had this problem… Is this releated to Zigbee in some way? (I doubt, but since I can´t seem to find other reasons, I had to ask).


(Kim Andersen) #140

Ahh, just as I wrote the above, I did get a BatteryPercent status… No Voltage yet though.