Ewelink / Sonoff Binding - New binding without flashing

What version?
Not sure I added in 2.5x
It’s in 3.x as I just added myself and everything back online.

What sensor is it? I’ll double check mine if I have the same

I’m using the .jar file for OpenHAB 4.0.0 available here: Openhab 4.0.0 · Issue #8 · delid4ve/openhab-sonoff-compiled · GitHub

I don’t know if this is compiled over your last version or not. However, I don’t see such AppID and AppSecret on the OpenHAB GUI. Maybe it’s not the same version…

Is it possible to have a .jar file compiled for OpenHAB 4.0.0?

The sensor is an EARU rdcbc-1p

Thank you very much for your help

EDIT: I confirm that this version Openhab 4.0.0 · Issue #8 · delid4ve/openhab-sonoff-compiled · GitHub does not have the AppID and AppSecret options.


Hi all,
from the beginning, I try to set this binding correctly but without success.
Binding is installed and visible in the web interface. I add the account email and password(works on my phone when try it, after that I disconnect it) but in debug message has a problem.
debug message is:

Running Activation task
12:26:33.034 [DEBUG] [internal.handler.SonoffAccountHandler] - Running connection check task
12:26:33.037 [DEBUG] [al.connection.SonoffConnectionManager] - Connection Check Running for cloud mode
12:26:33.041 [DEBUG] [ternal.connection.SonoffApiConnection] - Api Login Request:{“email”:“k****@abv.bg”,“password”:“Me*****00D”,“countryCode”:“+1”}
12:26:33.719 [DEBUG] [ternal.connection.SonoffApiConnection] - Api Login Response:{“error”:407,“msg”:“appid is unauthorized! oeVkj2lYFGnJu5XUtWisfW4utiN4u9Mq”,“data”:null}
12:26:33.723 [DEBUG] [al.connection.SonoffConnectionManager] - Api disconnected
12:26:33.728 [DEBUG] [.connection.SonoffWebSocketConnection] - Stopping websocket client
12:26:35.012 [DEBUG] [internal.handler.SonoffAccountHandler] - Running Activation task

Please help with this problem.
the binding that I use is:
292 │ Active │ 80 │ │ org.openhab.binding.sonoff
openhab version is 3.3.0

Thanks in advance


It’s the same problem I have. You have to setup the AppID and AppSecret. If you have the version for OpenHAB 3 you can do it. The version compiled for OpenHAB 4 does not have this feature.



New version compiled for OH3 and OH4 here: Releases · jgesser/openhab-3.x-sonoff · GitHub

I seem to be getting the errors ‘Cannot send command uiActive, all connections are offline for deviceid 1001e220e7’ and ‘Ok message not received for transaction: 1690632375748, command was uiActive, retrying again. Retry count 3’

Has been working fine for weeks, but seems to have broken over the last few days. It is still getting a temp reading from the TH16 and both lan and cloud show as connected,

Any ideas what to look for first? It’s woking fine via the mobile eWelink mobile app. Still on 3.4.4.


I just notice that the account thing has a comms error

See the posts a few up. Need to update the cloud keys

Hi Francesco,
I don’t have these fields in settings.
Yes I am with OH 3.3.0.
Where to get these ID’s?


1 Like

Hi @delid4ve, thanks again for the great work. One question: still no progress for the DUAL R3 as a roller shutter?


I have such options with the last compiled .jar file on OH 4.0.0. Are you sure you’re using this Releases · jgesser/openhab-3.x-sonoff · GitHub ?


Hi Francesco,
With this binding from a link, all is fine. Need to make a discovery again. After that, I will confirm the end of this saga.

Dear all, after upload " org.openhab.binding.sonoff-4.1.0-SNAPSHOT.jar" to /usr/share/… in OH4:

330 │ Active │ 80 │ 4.0.0 │ openHAB UI :: Bundles :: HABPanel UI
331 │ Active │ 80 │ 1.0.3 │ reactive-streams
334 │ Active │ 80 │ │ openHAB Add-ons :: Bundles :: sonoff Binding

  • the existing Thing (TH10) is working again. FINE - great job!

But in thing discovery there is no “Sonoff” binding shown to select:

What to do to fix?

Thank you
Cheers Stef

Hi all,

Did anyone had any success using the sonoff binding with OH 4.0.0 or 4.0.1 ?

Even the latest compiled by jgesser doesn’t work for me?

Account thing installs successfully and works in any mode (cloud, local or mixed).
But for the sake of it I cannot make my DUALR2 device to work.

OH auto-discovery doesn’t work (no device in Inbox). And when I add it manually from Dev-Sidebar it gives me this:


Anyone has any idea how to manually run discovery on sonoff binding?

Thanks upfront

just installed frech instance of OH 4.0.1
i have the same issue - the binding is active but doesnt in discovery

Dear Francesco, I have uploaded org.openhab.binding.sonoff-4.1.0-SNAPSHOT.jar and all installed devices came back to work. but when i try to do a discovery there is not an option to select “sonoff” - see my POST from Jul, 30th.
Can you please tell me, what to to do get the discovery back?
Thank you very much
Cheers Stef

Hello, I did not use any discovery feature. I have a .thing file so everything came back to normal after I copied the new version, so I can’t help very much.

What I have in my thing file is:

Bridge sonoff:account:uniqueName "Sonoff Account" @ "myLocation" [ email="***.com", password="***",accessmode="mixed"] {}



Hello. I’m trying a fresh installation of openhab 4.1.0 to make sure everything I need works. I have added the latest compiled sonoff binding in the addons folder like I did with the previous versions of openhab and sonoff binding, but does not appear in the binding list. Any ideas? Thanks to whoever is willing to help.

Hi, I have exactly the same problem as described above, my Openhab version is 4.0 and I’ve tried both jars - 4.0.0 and 4.1.0 versions.

I have the same problem (except my command is “consumption”).
It started about three weeks ago, and I haven’t found a solution yet. Did you succeed?

I’m using this binary for the Sonoff binding.
OH: 3.4.0

2023-08-14 11:44:32.175 [ERROR] [unication.SonoffCommunicationManager] - Cannot send command consumption, all connections are offline for deviceid 10015560ed
2023-08-14 11:44:33.176 [WARN ] [unication.SonoffCommunicationManager] - Ok message not received for transaction: 1692006272174, command was consumption, retrying again. Retry count 2


EDIT: Updating to this binary seemed to do the trick. I just renamed the binary to org.openhab.binding.sonoff-3.4.0-SNAPSHOT.jar since the release says it’s compiled for 3.4.0, so… :man_shrugging: