Fibaro Roller Shutter FGRM-222 with Venetian Blinds - Lamellas Position

Is there an update available, which enables the reports sent to OH in case the HW switches are used to change the position/tilt of the venetian blinds?
I am on OH2.3 release build with zwave dev build and I am not receiving any updates on OH

1 Like

is it possible to use “blinds control” and “shutter position” in the same system?
since I do this, the blinds are partially opened when i send a closing command.

or what could that be, if the shutter is opened with a closing command?

z-wave binding: development binding 2.3.0 (date end of june 2018)
openhab version: 2.3.0

what is the best way to set shutter to 70% and open lamella to 50% at the same time? can i do this with one movement, or is it required to program two movements?

my actually solution is not so beautiful:
sendCommand(Lamella_xy, 50)

is there a better way to program this function?

Any chance to put this feature into snapshot? I’ve upgraded now to ON 2.3 and surprised, that it’s still in development.

Once the current issue with the development version is resolved, this will be merged, but it won’t (cant) be added into the current master.


When to expect the next master, which does support both Venetian Blinds as well as enables the reports sent to OH2 in case the HW switches are used to change the position/tilt of the venetian blinds?

I am on development version to enable venetian blinds ever since the binding was released and would like to see both features merged to main branch.

As I said a week ago - as soon as the current issue is resolved, I will look to merge this into master.

without being too pushy - both will be merged to master, right?

What do you mean by “both”? There’s only one development branch, and this will be merged to master.

referring to:

  • Venetian Blinds support
  • enabled reports sent to OH2 in case the HW switches are used to change the position/tilt of the venetian blinds

both topics are mentioned in this thread

I do not personally have these devices, so can’t comment too much, but the support for the FGRM222 specific command class is included in the development branch and this is intended to be merged to master in the coming weeks.

I have the current version of those devices

venetian blind support works well with OH2 dev binding

-> HW switches do not trigger reports to the controller in my setup

@shorty707, @chris

I am using 2.3. development version myself (build 201806262322) and am happy with the venetian blind support - it is working just fine.
I was hoping that the most recent development version (from 3 Aug) is supporting reports to controller if HW switches are used.
Ultimately I would like to away from development builds and rely on official releases only.
Openhab at my place changed from a playground to proper home automation and would like to have a stable system running.

It should, so if it’s not, then some feedback would be appreciated otherwise there’s no way it will change. I would however suggest to exclude and reinclude the device if it’s not working…

I have a freshly included fgrm222.
some channels are updated on physical button push

the most relevant for venetian blinds are not

If the device is not sending this data, but it is sending other data, then either the associations need adjusting, or maybe there’s some other secret command that needs to be sent. If so, then there’s probably not a lot that I can do.

Remember that this is not documented (Fibaro keep this secret so that it’s only supported on their HomeCentre), and the implementation that I used is from people on the web. If someone can work out what needs to be set to configure this, then I’m happy to look at it

some channel questions for users with that device

-> what is the channel switch_binary meant for?
-> sensor_power does report the watts; the channel meter_watts is not reporting anything and could be removed?

and maybe to @chris
is this feature a fibaro special or something that could be implented as a channel or config parameteR?

I have not the answer for all questions, but I know that the only channel that works, for the meter watts, is called: “meter_watts1”. This will work. “meter_watts” and “sensor_power” did not work for me…

you probably have a different revision (and by that database entry)
mine is

last updated by @sihui … maybe you know?

we have the same, roller shutter 2 :wink: