Fibaro window sensor FGK-101 not working properly [SOLVED]

Hi all,

I bought some Fibaro window sensor FGK-101 and I am trying to get them included properly. I am using an Aeotech USB Z-Stick Gen5 as z wave controller.

When I include the sensor by setting the controller in inclusion mode and hitting the TMP button on the sensor three times, the controller recognizes the sensor. The sensor even appears in HABmin, but it seems that the device is not recognized. It has no name and no manufacturer etc. set in the information.

I excluded and reincluded it twice. I even used another sensor (bought multiple). But with no success…

I also updated the addon to 1.8.2 with no success.

I don’t know what to try next. Any ideas?

Cheers
Roman

What does HABmin say exactly. Does it show the type/id numbers, or something like 7FFFFFFF?

The lack of a green light means it’s not completed initialisation. You should wake it up a few more times while it’s close to the controller (ie with the stick plugged in so that openhab can talk to the device).

Thanks a lot for your help. I’ll give it a try.

Shall I also trigger something in openhab? Or just wake up the sensor?

Just waking the sensor should do it (hopefully :wink:). OpenHAB needs to receive a certain frame from the device so that it knows its awake and can communicate with it…

Hmmm, tried it several times now (wake up by pressing the button on the back of the sensor). Nothing happened.

Still trying… :slight_smile:

I forget if you need to use the one on the back, or the one inside - I remember this sensor being a bit of a pain to get included and working.

Is the device reasonably close to the stick (eg within a few meters should be fine). If you don’t get anywhere, check the logs to see if anything is received at all - it might be the inclusion wasn’t 100% successful.

I am about 10 cm from the controller.

The log file isn’t telling anything.

I’ll try the other button in the battery case.

No success. Not with the button on the back, nor with the one inside the battery case…

I even excluded and reincluded it again multiple times. It stays the same result :cry:

10cm might 10 too close - yes - it is possible :wink:. If it’s too close it might overload the stick and stop if from properly processing the data - I would try moving it a little further away (maybe a meter or so).

Otherwise, maybe try resetting the device (which is not easy as it’s a ‘complex’ process of putting the battery in and out and moving the magnet around if I remember correctly).

I’ve found these devices to be a right pain to get running - once running, they work well, but I’ve got a lot more grey hair because of them!

Got the first one up and running. And yes, I have some more grey hairs than usual. I am not sure what fixed it, but I will add 9 more, so I can figure out how to do it the optimal way.

I will report it.

Thank you so much for your help!!!

:thumbsup:

Funny - that’s always how I felt after getting these things going… I kept pressing buttons until it worked - which is something I hate!

If you can work it out, please let us know and I’ll also add it to the database…

Good luck!

I got them all up and running. I did it the following way. That worked quite well in the end :wink:

Prepare the sensor:

  1. Open the sensor with a small screwdriver (be careful)
  2. Remove the paper between the battery an the contact to activate the sensor.
  3. Close the sensor (be sure that it is closed correctly. The sensor must not act like a button if you push the casing. This sometimes happens. It is important to close the device correctly.)

Include the sensor in the network:

  1. Start HABmin.
  2. Navigate to Configuration > Bindings > select the ZWAVE Binding > select the devices tab on the right
  3. You should see at least your ZWAVE-Controller in the list of devices.
  4. Hit “include” to start the 30 sec include mode
  5. Hit the button on the back of the sensor 3 times in a short row.
  6. The device starts to blink in blue. If it stops repeat step 5 until the 30 sec inclusion is over. Keep the sensor not to close and not too far from the controller (between 30 cm and 100 cm)
  7. Hit “reload properties” in HABmin.
  8. The new device should appear in the list (grey with no name)
  9. If not, hit reload in your browser and navigate back to the device list.
  10. The new device should appear in the list (grey with no name)
  11. If not, restart your openHAB server, hit reload in your browser and navigate back to the device list.
  12. The new device should appear in the list (grey with no name)
  13. If not, repeat from step 4 until the device appears (This should happen rarely. I once needed two tries. I added 10 devices all together.)
  14. Hit the button on the back of the sensor 3 times in a short row.
  15. The device starts to blink in blue. Keep the sensor not to close and not too far from the controller (between 30 cm and 100 cm)
  16. Hit “reload properties” in HABmin.
  17. Repeat steps 14 - 16 several times. The device in the list will first show up a name, then turn to yellow and then to green.
  18. Congratulations, you fully added the sensor and it should work correctly now.

Hopefully this will help others :slight_smile:

Thanks again Chris. I would not have been that insistent in repeating and would have never solved the problem without your help. :thumbsup:

1 Like

Thanks for the feedback - I’ll put this into the database so it hopefully won’t be lost…

:thumbsup:

Hi,

thanks to this topic I finally got my FGK-101 to show up with status green in Habmin.
But I still have the problem that sensor data does not show up in my logs. I expect some kind of busevent when I move the contact. There is only once an event when I press the button on the sensor.
I checked the sensor with the Zensys tool and it seems to be working.
Any ideas?

If nothing is showing up in the (debug) logs, then either the device is out of range (I guess it’s not this) or more likely the associations aren’t set correctly. I would suggest to make sure that the appropriate group is configured to report to the controller.

Hello Chris,
I have problem with this sensor, the sensor shows always “Closed”, although I tried to change the distance between two parts the sensor.

do you have any idea for this problem?

Thanks

I would suggest that the associations are not set. The associations tell the device where to send reports when something changes - if you don’t set the association, then there will be no update sent.

This can be set in HABmin.