Google Home - Actions (API) now available!


(Mike) #542

yep, got it when I tried it out yesterday.

That’s why I love this project as one learns something :slight_smile: thank you all


(lysol) #543

I’ll wait for an official fix, but I hate waiting… haha


(Marcus) #544

Great description Gaël, many thanks!

Why not working on workarounds while the official solution takes time to get rolled out.

One won’t become dumber when working on alternatives and this way, we are prepared for further issues.

Digging into the details and learning how things work under the hood is not for everybody but for those willing to, there should be no objection.

It is also nice to see that people are willing to share their findings and knowledge and don’t hide behind buzzwords so others can improve their knowledge - and share it again with others.

Of course, for those who are using workarounds and later have issues with the final solution, they would either need to revert back to the original solution or solve further issues on their own - but that’s imperative and not worth to mention - I thought.


(Mehmet Arziman) #545

Iam not sure how you read things,
but „feel free“ is a clear statement and means …whoever is capable can do it make dirtyhacks to their system.
So the whole idea in this community is about sharing knowledge Marcus. And trust me I ve invested a lot to share my knowledge. Read my docu on github, drink warm milk…go to github of Google Assistant official smarthome action nodejs example. You will see how minimal the docu is there and that a lot lot lot people stuck there cause they followed another deployment approach (Google way) without Google Cloud Functions. No big help, slow reaction to issues cause complicated.

I am not sure from which community you came here to openHAB but you need to learn alot of things. I am also quite unsure what the actual value of your posts is. For me it feels like trolling around :wink:

You repeated what I wrote (no added value), you try to point out things in a negative way (no respect) and I cant see what your contribution was here at all. You can develop a better, issue free version…and we can learn „how to do it right“.

But it is still funny to read what you write :slight_smile:

Can you elaborate a little bit what and who you mean with „hide behind buzzwords“?
I am curious to learn which buzzwords beside oauth, google asssistant and scopes fly around in this topic.

Again, feel free to learn and to hack whatever system you want. Thats your decision. But stay polite and nice in this community. Remember to much anger makes your hairs grey and we dont want that.

All the best. You can always PM me, if you have topics.


(Nick) #546

Thanks for all your hard work!!


(Mehmet Arziman) #547

Thanks to all for waiting!

Google just fixed their stuff and we are live now.
Please check the official announcement:

BR Mehmet


(Flole) #548

Awesome that’s great!

Anyways, I’m still having the same issue with the dimmer, even though I unlinked and resetup the account.


(Josh Hagger) #549

That’s fantastic news!
I have set up all my items through Paper UI, but it doesn’t seem to have the option to add tags, what is the best way to add the tags?


(Ian Bishop) #550

Awesome! Great work Mehmet!

I am getting an error though… After linking works, I hit done back to the Home app and at the bottom I get the message “Something went wrong. Try again.” (That’s on IOS)

From an Android tablet, I get the “Linking your OpenHAB account”, then “Couldn’t update the setting. Check your connection”

Any ideas?


(Andy) #551

Incredible work Mehmet and everyone else who has positively contributed to Mehmet’s work! Thank you for your patience and for putting up with numerous trolls. Coming from a strong corporate IT Infrastructure (and development) background I have known to stay out of the conversation unless I have something useful to say… In this case I couldn’t add anything … so say nothing except to bestow upon you great thanks. I’ve been building my home automation system over the last few months and following this thread with great interest. I hope thing with you personally have started to level out a bit, it sounds like you have had a tough time of it so the thanks and patience is even more appreciated.


(dennis de vreede) #552

getting there - now no more “scope” issues when the Google Home app calls the Myopenhab URL. in there the prompt OAuth2 application authorization is shown - when hitting Allow Google home tells me its adding the account but doesn’t show any devices or account being added. When trying again the OAuth2 prompt is still there…

any ideas??


(Dustin Thurston) #553

OpenHAB is still not available for me when I search Google Home App. It showed up before it was pulled yesterday. Am I missing something?


(Carel Van Hemert) #554

I have just been lurking throughout the development of this action.

I just want to thank you and anyone that assisted for this. I know a lot of work went into it.


(joris) #555

Great work, it sure took some doing on you part, but you (and whomever may have helped you in the shadows) for there in the end


(Johannes) #556

Just after waking up this morning I tried again to connect my Google assistant and “boom” works flawless now! Thank you very much for this great piece of work @MARZIMA ! I really appreciate how much time and effort you put into this! Great stuff, keep on going! You are really motivating me to get started working on features and Bugfixes dir Openhab soon :slight_smile:


(Brett Hiltbrand) #557

This works so smooth! That was incredibly painless to setup and works great. Thank you all for all your hard work! It’s greatly appreciated.


(Ahiel) #558

well now after Google to connect to my openhab it shows me an error : couldn’t update settings. Check your connection.
Any idea why?


(Mihai Badea) #559

Same for me!
I read on the “Limitations and known issues” that Sometimes the Account Linkage needs to be done twice and repeated, but I did it over 10 times…

SOLVED!
I had tags like “TargetTemperature” which are not yet supported…
Removed them and everything worked!


(Michael Schnaitter) #560

Thank you,

I have been following this thread for several months now. My goal is to finally ban Alexa completely and replace it with my Google Home’s. When I saw the announcement this morning, of course, I had to try the lights control. It worked perfectly right away.

However, because of excitement, I forgot my sports bag at home. :smiley:


(Ahiel) #561

I’m using some openhab addons that uses tags (such as ImperiHome) and more…
Is this means I can’t use the binding?

Is there any estimation if or when will be a fix for this bug?

Thanks ahead,