Google Home - Actions (API) now available!


(Nick) #546

Thanks for all your hard work!!


(Mehmet Arziman) #547

Thanks to all for waiting!

Google just fixed their stuff and we are live now.
Please check the official announcement:

BR Mehmet


(Flole) #548

Awesome that’s great!

Anyways, I’m still having the same issue with the dimmer, even though I unlinked and resetup the account.


(Josh Hagger) #549

That’s fantastic news!
I have set up all my items through Paper UI, but it doesn’t seem to have the option to add tags, what is the best way to add the tags?


(Ian Bishop) #550

Awesome! Great work Mehmet!

I am getting an error though… After linking works, I hit done back to the Home app and at the bottom I get the message “Something went wrong. Try again.” (That’s on IOS)

From an Android tablet, I get the “Linking your OpenHAB account”, then “Couldn’t update the setting. Check your connection”

Any ideas?


(Andy) #551

Incredible work Mehmet and everyone else who has positively contributed to Mehmet’s work! Thank you for your patience and for putting up with numerous trolls. Coming from a strong corporate IT Infrastructure (and development) background I have known to stay out of the conversation unless I have something useful to say… In this case I couldn’t add anything … so say nothing except to bestow upon you great thanks. I’ve been building my home automation system over the last few months and following this thread with great interest. I hope thing with you personally have started to level out a bit, it sounds like you have had a tough time of it so the thanks and patience is even more appreciated.


(dennis de vreede) #552

getting there - now no more “scope” issues when the Google Home app calls the Myopenhab URL. in there the prompt OAuth2 application authorization is shown - when hitting Allow Google home tells me its adding the account but doesn’t show any devices or account being added. When trying again the OAuth2 prompt is still there…

any ideas??


(Dustin Thurston) #553

OpenHAB is still not available for me when I search Google Home App. It showed up before it was pulled yesterday. Am I missing something?


(Carel Van Hemert) #554

I have just been lurking throughout the development of this action.

I just want to thank you and anyone that assisted for this. I know a lot of work went into it.


(joris) #555

Great work, it sure took some doing on you part, but you (and whomever may have helped you in the shadows) for there in the end


(Johannes) #556

Just after waking up this morning I tried again to connect my Google assistant and “boom” works flawless now! Thank you very much for this great piece of work @MARZIMA ! I really appreciate how much time and effort you put into this! Great stuff, keep on going! You are really motivating me to get started working on features and Bugfixes dir Openhab soon :slight_smile:


(Brett Hiltbrand) #557

This works so smooth! That was incredibly painless to setup and works great. Thank you all for all your hard work! It’s greatly appreciated.


(Ahiel) #558

well now after Google to connect to my openhab it shows me an error : couldn’t update settings. Check your connection.
Any idea why?


(Mihai Badea) #559

Same for me!
I read on the “Limitations and known issues” that Sometimes the Account Linkage needs to be done twice and repeated, but I did it over 10 times…

SOLVED!
I had tags like “TargetTemperature” which are not yet supported…
Removed them and everything worked!


(Michael Schnaitter) #560

Thank you,

I have been following this thread for several months now. My goal is to finally ban Alexa completely and replace it with my Google Home’s. When I saw the announcement this morning, of course, I had to try the lights control. It worked perfectly right away.

However, because of excitement, I forgot my sports bag at home. :smiley:


(Ahiel) #561

I’m using some openhab addons that uses tags (such as ImperiHome) and more…
Is this means I can’t use the binding?

Is there any estimation if or when will be a fix for this bug?

Thanks ahead,


(Ian Bishop) #562

Hey, thanks tons for this post. My problem seemed to have been related to something item related. I went through to clean up my tags, made everything a [“Lighting”] instead of Switchable and now I’m linked!


(dennis de vreede) #563

sorted my problem - add tags by using HabMin - unlink first in Things - then relink with the required tag - and all works as expected. Great job guys!!


(Sergii) #564

Great! I can’t feel it completely, because I’m at my office now, not at home. But I had tagged all needed lights and switches, then successfully linked Google Home with openHAB account. Then I tried turn ON and turn OFF my stuff. And I see in log - it works!
Thanks to Mehmet Arziman for the great job. Thanks everybody who worked on this big thing.


(cporourke) #565

Replying in this thread as well as HERE to ensure widest dissemination, however, I think most of the discussion would do better in one place or the other. The following is what I posted in the other thread:

Apparently, just adding tags to the .items file wasn’t propagating throughout openhab. I attempted to add tags using both Habmin and the REST API and found that I was getting an ‘http error 404 not found’. So I did the following:

  1. Stop the openhab2 service
sudo systemctl stop openhab2.service
  1. Navigate to the jsondb items files (located at /var/lib/openhab2/jsondb)
  2. Add the tags there and save the file.
  3. Start the openhab2 service
sudo systemctl start openhab2.service
  1. Added the openhab “device” through the Google Home App

This time the account linked and my items showed up under openhab.

My wife is asleep and I currently only have the lights in our bedroom added in openhab so no chance I’ll be testing them tonight, but I am confident that this has fixed my issue. Thanks for all of your help. It seems that most of these issues are related to tag issues in one way or another.