Google Home - Actions (API) now available!


(Tom Ilsbroux) #566

Managed to get my devices in Google Home.

But when I added a second item it didn’t show up. So I unlinked openhab.
Now I try to relink openhab, after I click allow on the openhab webpage I get the error
“Couldn’t update the setting. Check your connection”
I am sure the connection is ok as it worked before. Not sure what to do next.


(Paul Smyth) #567

I’m getting the “Couldn’t update the setting” message too


(Dominik Benner) #568

Works!

Thank you for your work!


(Paul Smyth) #570

Adding tags this way does NOT work. The changes are overwritten as soon as you restart openhab


(Darren Poulson) #571

If you’re getting “Couldn’t update the setting”, then it possibly means you have tags other than Switchable or Lighting in your config. As soon as I removed any other tags, it worked perfectly.


(Paul Smyth) #572

Nope, nothing to do with it, extraneous route. Don’t have any tags in openhab apart from one test item created via text file. I rather stupidly though that Paper UI would actually be properly supported and developed but no, you can’t add tags to anything that’s auto discovered, you can’t add tags through paper ui AT ALL. I might as well dump paper ui altogether. If the Openhab team aren’t going to do any meaningful work with it they should deprecate it and stop wasting everybodies time.


(kluszczyn) #573

Confirming, in my case removing tags “CurrentTemperature” also resolved problem.


(Tom Ilsbroux) #574

Thank you that worked. Removed the tag I added, no idea what was wrong with it, it was same tag as on the other item which worked.
Weird error message though for something like this.


(Tom Ilsbroux) #575

How do I add extra devices ? Are they added automatically or is necessary to unlink and link again openhab on the google app ?


(Renan Muniz) #576

The message “Could not update the setting” was happening to me too. I removed all the tags and saved the .items file, then I just added the “Switchable” and “Lighting” tags and saved the file again. Done that, I reboot the openhab and connect to my openhab again.
Worked to me, hope this can help you


(B K) #577

For all who are adding new devices following the first link-up, just say “Hey Google - sync my devices” and they will be added.


(Ryan) #578

I have a pull request that adds this, hopefully it’ll flow to production soon enough…??


(Spo0nerino) #579

Hello guys

I tried to link my openhab account in the google home app bue i have an issue, i choose openhab and the google home app redirect me to the myopenhab login page, i introduce my credentials and then appears me an oauth2 application authorization that i choose allow and then show me a message that says “linked account”, but next show me again the same authorization page and i choose allow again and the message is “Forbidden” and stays in that page forever. If i go back keeps asking me for authorization and show me always the same forbidden message.

Can you help me? im missing some setting??


(Levin Løssfelt) #580

Hi there,

I’m having similar issues to Spo0nerino.
I’ve linked my account and gotten to the part where it asks for oauth2 authorization. However, when I OK that, I’m taken back to the previous page. I get a brief flash that authorization is now linked, and that I’ve connected my openhab-account. Still, I don’t see any changes in Home Control and I cant control my lights via the assistant.
For information I only have one item, and that is of Lighting sort.


(Levin Løssfelt) #581

Scratch that. By following what cporourke suggested here I got it to work! :smiley:


(Paul Smyth) #582

How does this work when restarting openhab overwrites this json files?


(Ryan) #583

Try going to your Applications section in myopenhab.org and delete the Google Assistant record(s). If that doesn’t work you can try clearing cache for the home app (on Android: settings -> apps, etc.)

Also, to troubleshoot temporarily remove the tags from your items and only have 1 item (Lighting or Switchable) to keep it simple. You can gradually add them back in by editing your items file, then saying “Hey Google Sync Devices”.


(Martin Herbst) #584

The best way to configure tags for items is to use the text format (*.items file) instead of Paper UI.


(Jacob Kuriakose) #585

Thank you for your hard work… It’s working without a problem… Thank you so much…


(cporourke) #586

I’ve restarted it twice now to check and it still holds. That being said, my .items file includes the correct tags so it may be pulling from there now where it wouldn’t before…most of this is over my head and I just troubleshoot until I find a way to make it work.