Google Home - Actions (API) now available!


(Michael Schnaitter) #560

Thank you,

I have been following this thread for several months now. My goal is to finally ban Alexa completely and replace it with my Google Home’s. When I saw the announcement this morning, of course, I had to try the lights control. It worked perfectly right away.

However, because of excitement, I forgot my sports bag at home. :smiley:


(Ahiel) #561

I’m using some openhab addons that uses tags (such as ImperiHome) and more…
Is this means I can’t use the binding?

Is there any estimation if or when will be a fix for this bug?

Thanks ahead,


(Ian Bishop) #562

Hey, thanks tons for this post. My problem seemed to have been related to something item related. I went through to clean up my tags, made everything a [“Lighting”] instead of Switchable and now I’m linked!


(dennis de vreede) #563

sorted my problem - add tags by using HabMin - unlink first in Things - then relink with the required tag - and all works as expected. Great job guys!!


(Sergii) #564

Great! I can’t feel it completely, because I’m at my office now, not at home. But I had tagged all needed lights and switches, then successfully linked Google Home with openHAB account. Then I tried turn ON and turn OFF my stuff. And I see in log - it works!
Thanks to Mehmet Arziman for the great job. Thanks everybody who worked on this big thing.


(cporourke) #565

Replying in this thread as well as HERE to ensure widest dissemination, however, I think most of the discussion would do better in one place or the other. The following is what I posted in the other thread:

Apparently, just adding tags to the .items file wasn’t propagating throughout openhab. I attempted to add tags using both Habmin and the REST API and found that I was getting an ‘http error 404 not found’. So I did the following:

  1. Stop the openhab2 service
sudo systemctl stop openhab2.service
  1. Navigate to the jsondb items files (located at /var/lib/openhab2/jsondb)
  2. Add the tags there and save the file.
  3. Start the openhab2 service
sudo systemctl start openhab2.service
  1. Added the openhab “device” through the Google Home App

This time the account linked and my items showed up under openhab.

My wife is asleep and I currently only have the lights in our bedroom added in openhab so no chance I’ll be testing them tonight, but I am confident that this has fixed my issue. Thanks for all of your help. It seems that most of these issues are related to tag issues in one way or another.


(Tom Ilsbroux) #566

Managed to get my devices in Google Home.

But when I added a second item it didn’t show up. So I unlinked openhab.
Now I try to relink openhab, after I click allow on the openhab webpage I get the error
"Couldn’t update the setting. Check your connection"
I am sure the connection is ok as it worked before. Not sure what to do next.


(Paul Smyth) #567

I’m getting the “Couldn’t update the setting” message too


(Dominik Benner) #568

Works!

Thank you for your work!


(Paul Smyth) #570

Adding tags this way does NOT work. The changes are overwritten as soon as you restart openhab


(Darren Poulson) #571

If you’re getting “Couldn’t update the setting”, then it possibly means you have tags other than Switchable or Lighting in your config. As soon as I removed any other tags, it worked perfectly.


(Paul Smyth) #572

Nope, nothing to do with it, extraneous route. Don’t have any tags in openhab apart from one test item created via text file. I rather stupidly though that Paper UI would actually be properly supported and developed but no, you can’t add tags to anything that’s auto discovered, you can’t add tags through paper ui AT ALL. I might as well dump paper ui altogether. If the Openhab team aren’t going to do any meaningful work with it they should deprecate it and stop wasting everybodies time.


(kluszczyn) #573

Confirming, in my case removing tags “CurrentTemperature” also resolved problem.


(Tom Ilsbroux) #574

Thank you that worked. Removed the tag I added, no idea what was wrong with it, it was same tag as on the other item which worked.
Weird error message though for something like this.


(Tom Ilsbroux) #575

How do I add extra devices ? Are they added automatically or is necessary to unlink and link again openhab on the google app ?


(Renan Muniz) #576

The message “Could not update the setting” was happening to me too. I removed all the tags and saved the .items file, then I just added the “Switchable” and “Lighting” tags and saved the file again. Done that, I reboot the openhab and connect to my openhab again.
Worked to me, hope this can help you


(B K) #577

For all who are adding new devices following the first link-up, just say “Hey Google - sync my devices” and they will be added.


(Ryan) #578

I have a pull request that adds this, hopefully it’ll flow to production soon enough…??


(Spo0nerino) #579

Hello guys

I tried to link my openhab account in the google home app bue i have an issue, i choose openhab and the google home app redirect me to the myopenhab login page, i introduce my credentials and then appears me an oauth2 application authorization that i choose allow and then show me a message that says “linked account”, but next show me again the same authorization page and i choose allow again and the message is “Forbidden” and stays in that page forever. If i go back keeps asking me for authorization and show me always the same forbidden message.

Can you help me? im missing some setting??


(Levin Løssfelt) #580

Hi there,

I’m having similar issues to Spo0nerino.
I’ve linked my account and gotten to the part where it asks for oauth2 authorization. However, when I OK that, I’m taken back to the previous page. I get a brief flash that authorization is now linked, and that I’ve connected my openhab-account. Still, I don’t see any changes in Home Control and I cant control my lights via the assistant.
For information I only have one item, and that is of Lighting sort.