Homematic: StatusDisplay HM-Dis-EP-WM55 supported?

How can I use a Homematic: StatusDisplay HM-Dis-EP-WM55?
At least the Key press?

Currently I did not got it working. The thing did not show up. In the logs there is a warning.

2017-02-09 10:03:57.405 [WARN ] [ternal.communicator.HomematicGateway] - Can’t load device with address ‘NEQ1462966’ from gateway ‘c7b4ed9e’: -3 Unknown paramset (sending getParamsetDescription()

Created an Issue https://github.com/openhab/openhab2-addons/issues/1874

1 Like

Finally we got the StatusDisplay HM-Dis-EP-Wm55 working (thanks to Gerhard Riegler). As soon as the PullRequest has been merged, it could be available in the 2.1.0-SNAPSHOT.

Great to see this supported now. Has anyone experienced the same problem as me? If I react on button press and send an immediate update of the text to display, the display will be UNREACH. I think there is a problem if the device is getting a submit to fast after a button was pressed.

I’m using current homegear nightly.

Hi. Is there any information on how to send text to it?

The HM-Dis-EP-WM55 thing hast got 4 channels named “Display Line 1”, … “Display Line 4”. To send text you must create an item for each line. You can also create additional items to set the icons in each display line.
It is very important to create an additional item for channel “Display Submit” (as a switch).

To send text to the device you can write a rule with “sendCommand” statements that set the texts or icons, or LEDs. In order to send the texts to the device you have to execute a “sendCommand” for the “Display Submit” switch.

Hi Martin,

thanks for your help. I did. But it still does not work. Any Idea whats wrong?

I will answer in the other thread

Thanks so much :slight_smile:

Hi all, I also have trouble getting the HM-Dis-EP-WM55 to work, but while the text is working well, I cannot react on the key presses.
My configs:

Switch Status_Entrance_Bottom                   "Eingangsstatus Taste unten"                                                                    {channel="homematic:HM-Dis-EP-WM55:ccu:NEQ1596256:1#PRESS"} 
Switch Status_Entrance_Bottom_s                 "Eingangsstatus Taste unten kurz"                                                               {channel="homematic:HM-Dis-EP-WM55:ccu:NEQ1596256:1#PRESS_SHORT"} 
Switch Status_Entrance_Bottom_l                 "Eingangsstatus Taste unten lang"                                                               {channel="homematic:HM-Dis-EP-WM55:ccu:NEQ1596256:1#PRESS_LONG"}  

rule "open garage gate by Status_Entrance"
    Item Status_Entrance_Top received command or
    Item Status_Entrance_Top_s received command or
    Item Status_Entrance_Top_l received command
    logInfo("Status_Entrance", "triggering garage gate")
    if (Gate_Garage.state == OPEN)


Sending and receiving text lines work (but there is no reaction to my rule, neither logging nor text lines), so in general the setup is ok. Any suggestions?

When pressing long, I get the error “Unknown value ‘CONT’ for PRESS virtual datapoint, only SHORT,LONG,LONG_RELEASE allowed”, is this related?

Which version of the binding are you using? This error message looks familiar to me and as far as I know a similar problem has already been solved.

I am using 2.2.0 according to the bundle list.

There was a problem with “CONT” which was fixed in January 2018. This was after the release of 2.2. You could try with the latest snapshot release.

Ok, I will give it a try, thank you. This is probably not to be discussed in this thread, but are the addon releases bound to the main OH version number? There should be maintenance releases of addons inbetween two OH releases. At least, I was hoping to get bugfixes easier and continuously by switching to the package distribution of OH. I don’t mean to be rude (my comment is rather general than specific to the homematic addon), but manually installing snapshot versions was pretty much what I was hoping to avoid. I will try it nonetheless.

maybe this was not such a good idea after all. Now updated all to… and nothing is working anymore. Karaf is not starting many bundles, among them core, ui, the bindings, transformations etc… I know what I’ll do for the rest of the evening…

Hmmm, I have tried 2.3 Build 1221 and no problems with a clean installation (on Windows). But I did not test it with production environment on the raspi.
So good luck …

Some feedback from my testing…
Button presses work when reacting on “changed to ON” events, not “received command”.
Text transmission only works for lines 2 and 3. The button descriptions cannot be changed, and also the 3rd line in the middle (presumably line 4) cannot be set. The EP-Thing has only 3 lines, not 5.
Did someone manage to change the button text or the 3 middle line?

It is definitly not possible to change the button texts via the binding, but the three lines in the middle can be set (at least with binding version 2.1). I am not at home, so I can’t post my rule code, but I can check it this weekend and post the rule code here.

That would be awesome. Please post if it works with v2.1 and also which line numbers appear where on the display.