How to upgrade Zwave-Binding to latest Snapshot?

Thanks for your help, but when I am the only one then I have made something wrong when upgrading from release version to Snapshot? I follwed the only officially available instruction as posted here:

The result is that no sitemap is found although I changed NOTHING to my sitemap directories.

So although I tried multiple combinations, followed all recommendations here, asked all the experts and spent many hours there seems to be no way (at least with a windows platform) to have OH2 running stable (also after a system restart) with the latest Zwave Snapshot. And I am not talking about the experimental security Zwave branch, but the 2.1.0 Snapshot.

The problem with this approach (stable core and zwave snapshot): occasionally there are changes in the code for the ESH or openHAB2 core which are a prerequisite for a working zwave snapshot binding. So without updating the runtime you can not benefit from the changes in the snapshot binding.

I don’t think you did something wrong: I’m using the manual setup on Linux which is almost identical to the manual setup on Windows and it works all the time (doing upgrades almost weekly).

I have the same problem with no sitemaps. There are few others having the same problem so this is some soft of bug.

In the end it was a stricter syntax check for the sitemap files which prevented my old sitemap from loading. Try to start with just a new (nearly empty) dummy sitemap to see if this works. If it does try to rebuild the old sitemap until you catch the mistake.

1 Like

ok, thanks. this was my thinking but as it worked before i refrain of doing it…

Just a note for those trying to update their zwave binding from Stable to Snapshot, here is what worked for me.

Openhab2 installed using apt-get running on Ubuntu desktop 1604.

Uninstall the stable binding from the Paper UI -> Add-ons -> Bindings.

Download the latest .jar snapshot from the following location:

Copy the .jar file to the addons directory:
sudo cp /path/to/download/org.openhab.binding.zwave-2.1.0-SNAPSHOT.jar /usr/share/openhab2/addons

Install the serial feature as discussed in post 2
feature:install openhab-transport-serial

Restart OpenHAB2:
sudo systemctl restart openhab2

To check which version of the zwave binding is running, SSH to the Karaf console (from the host running Openhab).
ssh -p 8101 openhab@localhost
(passwd is habopen)

At the openhab prompt type: bundle:list | grep ZWave

openhab> bundle:list | grep ZWave
209 | Active   |  80 |    | ZWave Binding

I hope this helps others, thanks to Chris for maintaining the Zwave binding!!


@mark_cornhill, I followed steps that you provided, but looks like runtime doesn’t pick up JAR dropped into /usr/share/openhab2/addons - ‘bundle:list | grep ZWave’ shows nothing… any ideas?

I’m also trying to install the snapshot. I followed your instructions, there are a few things which I cannot do:

feature:install openhab-transport-serial

gives me unknown command feature:install

ssh -p 8101 openhab@localhost

does nothing but sit there.

without using those two steps, I dropped the Jar for 2.2.0 into the correct folder. Then when I go to look at the binding list, it still shows 2.1.0.

Is there a missing step?

I’m running on raspberry pi.

you need to uninstall the 2.1.0 Z-Wave binding from PaperUI first
The new 2.2.0 snapshot version will not show up in PaperUI addons list.
after you deploy the new jar in the addons folder, you need to enter in the openHAB console and install the serial feature.

The first time that you try to connect to the console you will experience a time out. try again for a second time and you should be able to login.

It appears that even without installing the serial feature (no idea what this is for), I discoverd that if you ignore the fact that the version comes up as 2.1.0 and not 2.2.0 for the z wave binding, the changes in the new binding are still there. So I was now able to add and configure my Aeotec nano switch, which was missing in the db before this update.

let me know if some feature will not work without the serial feature.

You will not be able to connect to your zwave stick …

That’s funny, since I am able.

That means it is still installed :sunglasses:

I’m using OH2. Few months ago, I found a JAR files of the snapshot version 2.1 of Zwave binding and drop it easily in my addons folder. It was working great with all my stuff including security feature for my Schlage door lock.
Last months, I bought a new Zwave switch who was not in the database. I did a database request to update it and now, with the latest snapshot 2.2 it should be fixed. My problem is I’m not able to compile and generate the JAR file from the GitHub repository. I tried manual JAR -cf command (generated JAR files was pretty big and not running after droping it in addons folder). I also tried to compile and generate JAR files from Eclipse but the project is not compiling currently and I don’t know exactly why (few errors, I think there is some missing dependency but I don’t know how to fix it).

Is someone could send me an already compile JAR files of the latest zwave snapshot binding, or could help me compile it by myself?

The only zwave binding version which supports security is the development version of the binding.

Just download it from the main thread of the development zwave binding:

Direct download:

Thanks for this explanation. It explain why my last try yesterday didn’t work. I moved from OH2.1 stable to OH2.2 snapshot and installed zwave binding from paper UI. Security feature was not working so no control of the door lock.

Is this JAR file include the latest database update or this is exactly the same JAR file I was using 3 months ago? My main issue is still the new Zwave wall switch who was not included in the old database. With the zwave 2.2 snapshot version, the switch was recognized from the binding (new database), but like you explained me, security feature was not working.

1 Like

The security binding is updated every week or two with the latest database, so it should contain the same devices as the standard binding.

Now it’s back working perfectly fine. Both secure door lock and my new wall mount device WS15Z5-1. Thanks for your help!

@chris, any chance you could upload a new snapshot with the devices updated since Jan 2?
Also, I’m curious how development is going, if you’re up for letting us peons know! :grinning:

Yes, I will try and do one today (well, more likely tonight as I am doing some more work to tidy the database first).