How to upgrade Zwave-Binding to latest Snapshot?


(Bluman) #21

Just a note for those trying to update their zwave binding from Stable to Snapshot, here is what worked for me.

Openhab2 installed using apt-get running on Ubuntu desktop 1604.

Uninstall the stable binding from the Paper UI -> Add-ons -> Bindings.

Download the latest .jar snapshot from the following location:
https://openhab.ci.cloudbees.com/job/openHAB2-Bundles/lastStableBuild/org.openhab.binding%24org.openhab.binding.zwave/

Copy the .jar file to the addons directory:
sudo cp /path/to/download/org.openhab.binding.zwave-2.1.0-SNAPSHOT.jar /usr/share/openhab2/addons

Install the serial feature as discussed in post 2
feature:install openhab-transport-serial

Restart OpenHAB2:
sudo systemctl restart openhab2

To check which version of the zwave binding is running, SSH to the Karaf console (from the host running Openhab).
ssh -p 8101 openhab@localhost
(passwd is habopen)

At the openhab prompt type: bundle:list | grep ZWave

openhab> bundle:list | grep ZWave
209 | Active   |  80 | 2.1.0.201706022154    | ZWave Binding

I hope this helps others, thanks to Chris for maintaining the Zwave binding!!


Howto add a device to the zwave database
Newbie question - how to add a ZWave device that is not in a database?
Unknown device: Telldus Plug-in Switch Mini, TZWP-102
[Resolved] Unknown device
(Kirill) #22

@mark_cornhill, I followed steps that you provided, but looks like runtime doesn’t pick up JAR dropped into /usr/share/openhab2/addons - ‘bundle:list | grep ZWave’ shows nothing… any ideas?


(Jonathan Fulcher) #23

I’m also trying to install the snapshot. I followed your instructions, there are a few things which I cannot do:

feature:install openhab-transport-serial

gives me unknown command feature:install

ssh -p 8101 openhab@localhost

does nothing but sit there.

without using those two steps, I dropped the Jar for 2.2.0 into the correct folder. Then when I go to look at the binding list, it still shows 2.1.0.

Is there a missing step?

I’m running on raspberry pi.


(Angelos) #24

you need to uninstall the 2.1.0 Z-Wave binding from PaperUI first
The new 2.2.0 snapshot version will not show up in PaperUI addons list.
after you deploy the new jar in the addons folder, you need to enter in the openHAB console and install the serial feature.

The first time that you try to connect to the console you will experience a time out. try again for a second time and you should be able to login.


(Jonathan Fulcher) #25

It appears that even without installing the serial feature (no idea what this is for), I discoverd that if you ignore the fact that the version comes up as 2.1.0 and not 2.2.0 for the z wave binding, the changes in the new binding are still there. So I was now able to add and configure my Aeotec nano switch, which was missing in the db before this update.

let me know if some feature will not work without the serial feature.


(SiHui) #26

You will not be able to connect to your zwave stick …


(Jonathan Fulcher) #27

That’s funny, since I am able.


(SiHui) #28

That means it is still installed :sunglasses:


(Martin Mailloux) #29

I’m using OH2. Few months ago, I found a JAR files of the snapshot version 2.1 of Zwave binding and drop it easily in my addons folder. It was working great with all my stuff including security feature for my Schlage door lock.
Last months, I bought a new Zwave switch who was not in the database. I did a database request to update it and now, with the latest snapshot 2.2 it should be fixed. My problem is I’m not able to compile and generate the JAR file from the GitHub repository. I tried manual JAR -cf command (generated JAR files was pretty big and not running after droping it in addons folder). I also tried to compile and generate JAR files from Eclipse but the project is not compiling currently and I don’t know exactly why (few errors, I think there is some missing dependency but I don’t know how to fix it).

Is someone could send me an already compile JAR files of the latest zwave snapshot binding, or could help me compile it by myself?


(SiHui) #30

The only zwave binding version which supports security is the development version of the binding.

Just download it from the main thread of the development zwave binding:

Direct download: http://www.cd-jackson.com/downloads/openhab2/org.openhab.binding.zwave-2.1.0-SNAPSHOT.jar


(Martin Mailloux) #31

Thanks for this explanation. It explain why my last try yesterday didn’t work. I moved from OH2.1 stable to OH2.2 snapshot and installed zwave binding from paper UI. Security feature was not working so no control of the door lock.

Is this JAR file include the latest database update or this is exactly the same JAR file I was using 3 months ago? My main issue is still the new Zwave wall switch who was not included in the old database. With the zwave 2.2 snapshot version, the switch was recognized from the binding (new database), but like you explained me, security feature was not working.


(Chris Jackson) #32

The security binding is updated every week or two with the latest database, so it should contain the same devices as the standard binding.


(Martin Mailloux) #33

Now it’s back working perfectly fine. Both secure door lock and my new wall mount device WS15Z5-1. Thanks for your help!


(Eric Einstein) #35

@chris, any chance you could upload a new snapshot with the devices updated since Jan 2?
Also, I’m curious how development is going, if you’re up for letting us peons know! :grinning:


(Chris Jackson) #36

Yes, I will try and do one today (well, more likely tonight as I am doing some more work to tidy the database first).


(Andrés Córdova) #37

Hi! I have the same problem. How do you solve it?
Thanks.


(Marcel Keller) #38

Hi, i have installed the z-wave snapshot 2.2.0 of 2018-01-07. Now i would update to the latest snapshot 2.3.0 of 2018-03-07. I have replace the old jar-file in folder add-ons with the new 2.3.0 jar-file.
is this update complete or is there more to do?


(SiHui) #39

Nope. But you may want to double check via karaf and

bundle:list|grep -i zwave

if your new snapshot is the one and only active zwave binding.


(Ton) #40

Late reply, but I too could not remove the Z-wave binding using the GUI, neither Habmin, nor Paper UI in this (rather good!!) recipe from Mark Cornhill at the top of this thread.

I’m using Openhab 2.2.0 from late december on a Rasperry Pi 3 using Openhabian. Maybe the GUI uninstall button broke at some point between juni 2017 and december 2017? I don’t know.

What did work was removing the Zwave binding via the openhab commandline (Karaf).

First, put the new Zwave binding in the addons directory. At the moment of this writing, it worked using this command (download link may vary of course every week), from the /usr/share/openhab2/addons directory:

/usr/share/openhab2/addons$ wget https://openhab.ci.cloudbees.com/job/openHAB2-Bundles/lastStableBuild/org.openhab.binding%24org.openhab.binding.zwave/artifact/org.openhab.binding/org.openhab.binding.zwave/2.3.0-SNAPSHOT/org.openhab.binding.zwave-2.3.0-SNAPSHOT.jar

Second, find the number of the zwave binding using Karaf:

openhab> bundle:list | grep -i zwave
202 │ Active    │  80 │ 2.2.0                  │ ZWave Binding
210 │ Installed │  80 │ 2.3.0.201805091233     │ ZWave Bind

Then, using that number (202), deactivate it. Note that the 2.3.0 .jar file is installed here, because I had a reboot in between. This may not be the case any time, but it is only installed, not active) :

openhab>  bundle:stop
openhab > bundle:uninstall org.openhab.binding.zwave

I verified that all zwave entries are gone using

openhab> bundle:list | grep -i zwave 
202 │ Resolved  │  80 │ 2.2.0                  │ ZWave Binding
210 │ Installed │  80 │ 2.3.0.201805091233     │ ZWave Binding

The 2.2.0 binding becomes “resolved”, don’t know what it means exactly, but it is not active any more.

Then I restarted Openhab from the commandline (perhaps bundle:start would also do the job, I did not try that) :

 sudo systemctl restart openhab2

And verified it:

openhab> bundle:list | grep -i zwave                                                                                                                      
211 │ Active   │  80 │ 2.3.0.201805091233     │ ZWave Binding

And, yes, it has been replaced!! :grinning:

Note that the GUI still reports 2.2.0, but I tend to believe a command line tool more than a GUI :wink:

I’d be happy to make some documentation about this somewhere, when somebody gives me the right pointers to where and how to do that… !


(Angelos) #41

The GUI presents to you the “standard” versions of the (Z-Wave) binding which comes bundled with the OH (2.2) distribution that you can install.
If you use a manually deployed binding, you shouldn’t worry about what PaperUI shows you for the version of the specific binding since you won’t be using that (leave it uninstalled). PaperUI won’t show you the version of a manually deployed binding.