IFTTT commands to OpenHAB not working anymore

Hello there,

I have a Withings sleep sensor which is connected to OpenHAB via IFTTT. This has been working for many years now.

Some weeks ago it stopped working. I cannot see any messages in the OpenHAB log and on IFTTT side there is just an “action failed” information:

The item is exposed as it has been in the past.
In IFTTT I send the command “ON” and “OFF” to a switch item. I also tried sending 1 or 0, but no change.

Controlling items via Amazon Alexa works fine. I also tried reconnecting my account to myopenhab which also worked fine.

Does anyone else have this issue?
Does anyone know how to fix or debug it?

Thanks in advance!

1 Like

I have exactly the same problem! Anyone has any idea of what is going on?

Thanks in advance for your support.

Best regards,

IFTTT support was discontinued in July 2019, because exposed items were putting a massive strain on myopenHAB and causing it to crash regularly. If IFTTT continued to work for you, that’s because items that you had previously exposed haven’t changed since then. I’m honestly surprised that both of you went this long before discovering it.

If nothing changed in your systems recently, then I’m guessing that a recent update to myopenHAB was the culprit.

Unfortunately, there’s nothing you can do to regain the IFTTT connection as it was before. You could try having IFTTT send an HTTP request to myopenHAB to update the item, but I’m not able to help you with that. Alternatively, there may be other ways to remove IFTTT from the mix completely.

Okay, sad to here though.

I was aware that the support for exposing items is discontinued, but I always thought, that existing items (those visible in IFTTT) will stay available.

Maybe my issue came with the update to openHAB 3.4.1.

Indeed, it seems updating to 3.4.1. was the culprit. Is there any definite answer whether IFTTT support fully stopped in 3.4.1.?

Unfortunately, I also know of no other way to get access to the Withings Sleep Analyzer API, so if anyone has a tip on how to connect Withings Sleep with OH without going via IFTTT, I would really appreciate it!

Best regards,

I don’t have experiences with so I am not sure if your use case is covered:

Functions to import and process data from sleep trackers (e.g., Withings Sleep Analyzer)

Per the release notes, there were no changes to the cloud connector in 3.4.1, but there were changes in 3.4.2. As I said before, there have been some recent updates to the myopenHAB servers. I suspect that’s what did it.

Whatever the case, you’re not going to regain IFTTT support by rolling back to an older version of openHAB.

The quickest fix I can think of is to insert a third-party medium that works with both IFTTT and openHAB:

  1. Withings Sleep triggers IFTTT recipe
  2. IFTTT toggles MEDIUM
  3. MEDIUM updates openHAB

For example, a TP-Link Kasa/Tapo outlet would be an inexpensive medium.

I just found this one:

I will try this in the next days.

  • Does not required to expose your Openhab server to internet (only this gateway need to be exposed)

You probably know this already, but I’m going to say it for future readers: be very careful about exposing anything in your home network to the Internet. If you don’t know how to do it safely and securely, then you’re setting yourself up for trouble.

You’ve also reminded me of this discussion, which may be of use.

I have successfully tried this skill in IFTTT:
It provides 3 actions free of charge which is enough for my case.

Withings will trigger an Alexa item.
This will then trigger an Alexa routine.
This will set an item in OpenHAB.

Since I only want this one item set, it is okay for me.


Good stuff. I’m glad to know that Alexa can be a medium with IFTTT. I imagine the lag would be a bit of a challenge in some cases, but I’m assuming you’re not concerned about that in this scenario.

Worked perfectly! Thanks for mentioning it @SeeAge!

Glad to hear that you got it running.

I have meanwhile switched over to another solution because I did not like to have Amazon and this 3rd party skill in between.

Instead I am now using the IFTTT gateway already mentioned above:

I put it into a dockerfile and have it running as a docker container on my Synology NAS. In IFTTT I am using the service “Webhooks” to communicate with the gateway.

With this solution it is also possible to send a command from OpenHAB to IFTTT.
If only there would be more than these 4 free applets in IFTTT.