Inovelli NZW97 and Z-wave Issues

Having some issues getting the inovelli setup. Running into several things so will try to break this down with the steps I am working with.

I am running OH2. Don’t know for sure if its snapshop or not, I am not at the location and dont have my VPN setup yet :slight_smile:

I have a Aeon Labs Z-Stick S2 (Series 2) plugged into the pi. This is the first z-wave device I am trying to setup on it. I have one at the house and have several z-wave devices running so have figured this out before.

The first time I plugged in the inovelli and connected it I found that it was not in the database. At that time it did not show up in the database. Since then, Chris has added it. The link is here.

First question is about trying to update the binding database. From what I read seems I need to uninstall and then reinstall the binding. I tried that through the paper interface. It uninstalled and it reinstalled but did not make changes to the inovelli.

Next I tried to delete the inovelli from the build. i excluded it from the z-stick. Then i tried in both the paper interface and habmin to delete it. in both cases it would not delete it. clicking delete does nothing.

I say all that to say, just trying to get the inovelli working, i tried what i know to do for now, but could use some help with a direction on to get it going.


Almost. You need to uninstall the older version of the binding and install a verison of the binding at least 24 hours older than when the device was added to and approved in the zwave database.

The OH version and binding versions move forward in lock step. Uninstalling and reinstalling a binding through PaperUI will only get you the exact same version of the binding back. You either need to upgrade your entire OH to a version that includes the device, or you need to uninstall the zwave binding and download the jar file for the newer zwave binding and manually install it on your older OH. Note that this doesn’t always work because there are changes made to OH core that require changes in the bindings that make newer bindings no longer backwards compatible with older OH cores.

I’m not really up on all the details for removing devices from the controller. I think the proper way to do it is to put the controller into exclusion mode, exclude the node (usually involves pressing a button on the device), then reincluding. It is possible (likely) that the old node will still be hanging around until the controller decides that it is a dead node at which time you can “Delete dead node” through Habmin to remove it. In the mean time, when you reinclude the device it will show up in the next available node number.

thanks Rick, a few thoughts…

  1. That device was added a month or so back and i tried the update yesterday so it should be in there.

  2. I will have to see what version of OH2 i am on. I installed it in maybe january/february. I have never done an update to oh install so that will be interesting.

  3. i seem to remember from the oh1 days that you would just delete the jar file from the bindings folder then save the one in. is that still in play?

  4. you are correct on removing the device. thats what i tried with no luck. maybe i just needed to wait a bit for it take hold. i guess i could look in the logs too. i am sure it tells me the device is live/removed etc. i’ll do that this weekend.


If you are on OH 2.2 then you reinstalled Zwave binding 2.2 which was released in January. To get the zwave database from a month or so back you must upgrade your whole OH to the 2.3 SNAPSHOT. I don’t think you can run recent 2.3 SNAPSHOT versions of the bindings on OH 2.2 any longer.

If you are running the 2.3 SNAPSHOT from January all you need to do is run an apt-get upgrade (assuming you installed using apt). If you installed OH 2.2 you need to change the apt repo to the SNAPSHOT and then run apt-get upgrade. See for how to add the SNAPSHOT release repo.

No, OH 2.x doesn’t work that way when you use the UIs to install bindings. You can uninstall the zwave binding using PaperUI, then download the 2.3 SNAPSHOT Zwave jar file from Cloudbees and drop that into your addons folder like in the old 1.x days, but like I said above, I think there have been changes between OH 2.2 and OH 2.3 that makes the bindings no longer backward compatible. So you must upgrade the whole OH to 2.3.

I decided to just start over with my home install. Not a problem really as I dont have a heck of alot running and its always good therapy to just walk through all of it again. So I have the latest build now - openHAB 2.2.0-1 (Release Build).

I have several z-wave devices running just fine on the my Aeotec Gen 5 stick. I included the inovelli and it just shows up as another thing:
Z-Wave Node 9 (015D:6100:6100:1.1)
Unknown Device

Still gives me the notice that its not included in the database.

I setup simple switch item and then added to a sitemap to see if it would work and it does not. Of course it needs to recognize the two plugs as well so if it doesnt know what it is, it cant do that.

Not sure where to go from here.


This is not the latest. Your device is definitely in the database, but you need to use a newer version - ie the snapshot version. V2.2 is from around 6 months ago so it doesn’t contain devices added in this time.

Thanks Chris. That has lead to a morning of searching and reading trying to figure this out. I’ll address the database first.

I did some reading on how to delete the 2.2 database and update it to 2.3 but not finding something that I can understand. As a lot have said, it does not work to delete it through the paperui.

I read this article - Says to do this in the jasondb. I found my jasondb and pulled it up as a text file but would have no idea how to delete a binding out of there so i have not messed with that. If there are some better directions that I am missing on how to uninstall and reinstall the updated database please let me know.

Second, I installed the build for openhabian here. Thats what installed the 2.2 build. I did that on Tuesday I think. Should it have not loaded the 2.3 database?


Not the database, you need to upgrade your zwave binding to snapshot 2.3

Nope, it’s already in the database, no need to do that.

No, that stable build does not load any snapshot bindings.
You need to uninstall the 2.2 stable zwave binding, download the 2.3 snapshot binding, place it in your addons folder and restart openHAB.

But it may still not work because of:

Thanks sihui, so i’m back to how to uninstall the binding. it will not let me do that through paperui and have found articles that discuss thats its an issue. I have not found a good way though how to do it without paperui.


I get this error in the log when I try through paperui

2018-05-24 14:46:45.367 [WARN ] [shd.server.session.ServerSessionImpl] - exceptionCaught(ServerSessionImpl[openhab@/])[state=Opened] InterruptedByTimeoutException: null

2018-05-24 14:46:45.504 [ERROR] [io.openhabcloud.internal.CloudClient] - Unsupported request method HEAD

Forgot this part first…

2018-05-24 14:46:45.367 [WARN ] [shd.server.session.ServerSessionImpl] - exceptionCaught(ServerSessionImpl[openhab@/])[state=Opened] InterruptedByTimeoutException: null

One alternative way to do that is through the karaf console:

bundle:uninstall openhab-binding-zwave or
feature:uninstall openhab-binding-zwave

Then check via bundle:list|grep -i zwave if it is gone.

oh my gosh! that worked! awesome!

so now what is the best way to load it? manually into the things folder or should i follow this:

In the Config tool, run:

Option 1: Update Configuration Tool,
Option 2: Upgrade system,

Did you ever read any of the docs? :grinning: Or the above posts?

So download the snapshot zwave jar and put it in your addons folder, then restart openHAB.$org.openhab.binding.zwave/

Thanks sihui! yes, i had read all that. i had also read where doing the upgrade with update things. so i went with moving the jar file into the add-ons folder and voila. finally! i have it updated! and it found the inovelli! priceless.

thanks for all the help! i am going to document this as i have to do the same on another system.


1 Like

I am a newbie to openHAB. I am using the stable 2.3 binding.

I have successfully configured the Z-Stick-Gen5 and the Z-Wave binding to configure the Inoveli NZW37.

However, when I include the inovelli NZW97, it creates an unknown device thing in the Paper UI.

I believe that since this thread is referring to 2.3 snapshots, that the 2.3 stable release should have this device configured in the library.

Any suggestions on how to get this working would be helpful.


Is this a battery powered device? If so you need to wake it up several times to give the binding a chance to discover what it is.

No this is a 2 channel AC plug.

I’ve had it plugged in for several days and I’ve rebooted my server several time and no change.

Please provide the exact wording shown in the UI. Is it communicating at all?

Z-Wave Node 20 (0312:6100:6100:1.1) ONLINE
Unknown Device

If I select it in the paper UI (Configuration/Things), I get -

Z-Wave Node 20 (0312:6100:6100:1.1)

This device has not been fully discovered by the binding. There are a few possible reasons for this -:
The Device is not in the database. If the device attributes show that this device has a valid manufacturer ID, device ID and type, then this is likely the case (e.g. you see a label like "Z-Wave node 1 (0082:6015:020D::2.0) Even if the device appears to be in the database, some manufactures use multiple sets of references for different regions or versions, and your device references may not be in the database. In either case, the database must be updated and you should raise an issue to get this addressed.

The device initialization is not complete. Once the device ins included in the network, the binding must interrogate it to find out what type of device it is. For the mains powered devices, this will occur quickly, however, for battery devices, the device must be woken up a number of times to allow the discovery process to complete. This must be performed with the device close to the controller.