Integrate Danalock via Z-Wave

I would like to integrate my Danalock V3 into Openhab via Z-Wave. Unfortunately, the Z-Wave binding does not find the lock. Has anyone ever integrated a Danalock via Z-Wave? Is there a step by step guide?
My current configuration:
Version: openHAB 3.4.0 M3 on a Synology NAS
Lock: Danalock V3 with Z-Wave
Z-Wave Stick: Aeotec Z-Stick Gen5 (ZW090) - UZB - Sigma Designs, Inc.

Do you have the Danalock with Z-Wave capability? There are several types of these Danalocks, one of them is with Z-Wave.

@robjkamp yes, of course. I have the version with Z-Wave support. Sorry, I should have added that.
Small addition: I have integrated about 70 devices in my openHAB (shutters, windows, doors, thermostats, TVs, HiFi devices, light switches, solar system, smoke detectors, air conditioning, etc.) via various bindings (Livisi, Netatmo, Daikin, AVM, Senec Home, iRobot, Yamaha, etc.).
I also already have a water detector from Fibaro via Z-Wave. So my knowledge in openHAB is already extended, just so you can estimate my skill level a bit :wink:
I’m just having massive problems with the Danalock, and I’m not getting anywhere here.

I have 2 of those locks. They work pretty well with OpenHab zwave binding.

Are you pairing the lock close to the controller?

How are you including the lock? Did you do it through openHAB, or using the button on the Gen5 stick?

The reason I ask is that it’s very common for Gen5 owners to use the button, but secure inclusion must be done through openHAB due to the Network Security Key.

And as @Piotr_Bojko said, you sometimes have to have your lock and controller/server very close to each other for the secure inclusion to work.

@Piotr_Bojko Yes, I had the lock right next to the stick. Distance approx. 10 cm.
@rpwong I have carried out the inclusion via the openHAB interface “Scan” and not via the stick directly.

For clarity, does this mean there is nothing showing up during the scan or something is appearing, but is not identified as the lock (unknown device)?

If the former, maybe setting the z-wave binding to debug might provide a clue. Also check your controller advanced settings for secure inclusion and a 16 byte code. Also might try exclusion first (with Debug) then inclusion

If the latter, your lock ID numbers might be different than the Zwave DB. (The latter is easier to solve). The current entry is here

Edit: One more note; S2 security is not supported, but the device is supposed to fallback to S0. this might show up with debug (if the device is not falling back to S0 for some reason)

I would guess that during parinig close to the controller (stick in openhab, parinig started from openhab) security mode is not enabling. Please note that documentations states:

" Note that the binding will only remain in inclusion mode for 30 seconds, so inclusion of the device must start within this period."

@apella12 Nothing is displayed during the scan.

The security mode is activated for locks. Here are the settings of the Z-Wave stick.

Do you see any messages in debug during scan? Also network wide inclusion is more normal, although with your proximity it should not make a difference

Can you swtich secure inclusion mode to “all devices” for the moment of inclusion (you can rollback this option later).

Have you reset your lock during the process? If I recall, for many devices secure inclusion is a two step process. 1) factory reset the device, 2) start the inclusion process within some short time (15s? 30s?) of the factory reset.

@apella12 Where can you activate the debug mode? Where can I view the debug messages?

@Piotr_Bojko I changed it to “all devices”, unfortunately without success.

@JustinG I have not yet tried to reset the lock. That would be another possibility. But after the reset, I
have to set up the lock again via Bluetooth with the Danalock App, right? Otherwise I have no way of starting the inclusion process for Z-Wave. So the 15-30 seconds after the reset can’t work?!

I don’t know this device at all, so I can’t say. My old August lock has a separate Z-wave reset function, so this one might as well. I would guess that is does have a Z-wave only reset somewhere because you’re right, resetting the whole lock would make it impossible to properly do the secure inclusion in time.

It is best explained at the bottom of the Zwave under the heading, “When things do not go as planned”

The messages will be in the openhab log unless you have setup a separate file for Zwave. There is a viewer that extracts the key messages here (as the files can get long, if inclusion works). Basically I have suggested this for two reasons. One is whether the device is sending out anything to the controller (maybe a power, device radio problem?) and two, if there is a message (should be a NIF), what the binding is doing with it

Just to be sure. How do you enable parinig on the lock? You should use a needle or clipper and with one firm press here:

My question might be obvious, but it wasn’t mentioned, so I’ll ask.
Did you make sure to purchase a Z-Wave Danalock that runs on the same Z-Wave frequency as your Aeotec Z-Stick?
Z-Wave has a few frequencies for different countries, so if your lock and controller are not using the same frequency, your controller won’t find the lock.

1 Like

@mjeshurun That is very interesting information. I haven’t paid attention to that yet. Where can one find out the frequency of the devices?

@Piotr_Bojko Until now, I have always set the lock to inclusion mode via the app. Is that wrong? I have just tried your described variant, but that didn’t work either.