Issues Secure Pairing GoControl/Linear GD00Z-4 Garage Door Opener

Running Openhabian 2.3 snapshot #1192. In the Zwave Controller config, I selected Secure Inclusion for entry devices only. When I attempt to pair, it fails. Do I need to load the test Zwave binding that @chris released this month? Here’s the log:

08:11:52.976 [INFO ] [smarthome.event.BindingEvent ] - org.openhab.binding.zwave.event.BindingEvent@764499
08:12:01.012 [INFO ] [ommandclass.ZWaveSecurityCommandClass] - NODE 13: setupNetworkKey useSchemeZero=false
08:12:01.067 [INFO ] [ig.discovery.internal.PersistentInbox] - Added new thing ‘zwave:device:160a3a1089a:node13’ to inbox.
08:12:01.070 [INFO ] [smarthome.event.InboxAddedEvent ] - Discovery Result with UID ‘zwave:device:160a3a1089a:node13’ has been added.
08:12:01.095 [INFO ] [smarthome.event.BindingEvent ] - org.openhab.binding.zwave.event.BindingEvent@b1aca7
08:12:01.107 [WARN ] [erialmessage.IdentifyNodeMessageClass] - Got IdentifyNodeMessage without request, ignoring. Last message was SendData.
08:12:06.180 [INFO ] [ommandclass.ZWaveSecurityCommandClass] - NODE 13: setupNetworkKey useSchemeZero=true
08:12:06.185 [INFO ] [ommandclass.ZWaveSecurityCommandClass] - NODE 13: Using Scheme0 Network Key for Key Exchange since we are in inclusion mode.
08:12:06.290 [INFO ] [ecurityCommandClassWithInitialization] - NODE 13: Setting Network Key to real key after SECURITY_NETWORK_KEY_SET
08:12:06.295 [INFO ] [ommandclass.ZWaveSecurityCommandClass] - NODE 13: setupNetworkKey useSchemeZero=false
08:12:06.355 [ERROR] [] - NODE 13: SECURITY_ERROR Device message contained nonce that is unknown to us, id=-101.
08:12:06.413 [WARN ] [ommandclass.ZWaveSecurityCommandClass] - NODE 13: payloadQueue was empty, returning!
08:12:12.995 [INFO ] [smarthome.event.InboxRemovedEvent ] - Discovery Result with UID ‘zwave:device:160a3a1089a:node13’ has been removed.
08:12:13.034 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘zwave:device:160a3a1089a:node13’ changed from UNINITIALIZED to INITIALIZING
08:12:13.059 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘zwave:device:160a3a1089a:node13’ changed from INITIALIZING to OFFLINE (BRIDGE_OFFLINE): Controller is offline
08:12:13.172 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘zwave:device:160a3a1089a:node13’ changed from OFFLINE (BRIDGE_OFFLINE): Controller is offline to ONLINE
08:12:26.505 [INFO ] [smarthome.event.BindingEvent ] - org.openhab.binding.zwave.event.BindingEvent@1570293

Yes - secure inclusion is not supported in the master release at this time.

Thanks @chris, appreciate the support and the quick responses.

1 Like

@chris, with the test Zwave binding, the secure inclusion was successful. However I still only see one channel for the garage door opener, barrier state. Should I see more?

Currently there is just one channel defined for the device.

Any near term plans to add security to the master release so that latest snapshot releases can be used?

See this thread, about halfway through for how to set it up.

Yes - I am planning to do this in the near future. I have a few things to do at the moment, but it is something I’d like to get merged sooner rather than later.

1 Like

I am brand new to openhab and I am running it on RPI3 with a Razberry daughter card and openhab2 standard. I have a couple issues. I did a hard reset of the controller before I realized that it would reset it completely and I would loose everything. Now, when I am in HABmin and I look at the attributes of my zwave serial controller “Thing” it has nothing but question marks. Please see pic. How do I fix that?

The second thing is that I have installed the GD00Z-4 Garage Contoller and as stated in the previous post, I too am unable to make the garage controller work. If I need to use the snapshot version, where do I begin and could you direct me to what I should read? Sorry, very new and don’t even know where to look for secure binding or how to use logging yet but it is fun messing with this.

Thanks for any help.


Please ensure that you are using the absolute latest snapshot as the secure binding was merged this morning.

See the docs here.

To enable ZWave debug logging, use the console command log:set debug org.openhab.binding.zwave.