Jetty update, Karaf 4.1.3 upgrade and full LSP support

Ok, tonight I gave it another try, with success.
In the file “org.apache.felix.eventadmin.impl.EventAdmin.cfg” (stored in userdata\openhab2\etc) I added a new parameter:

org.apache.felix.eventadmin.Timeout=0

If you don’t have that parameter (like I did), it defaults to 5000ms (source). If you set it to “0” there is no timeout. In my case, the OH core got “blacklisted” because: “If an event handler takes longer than the configured timeout to process an event, it is blacklisted. Once a handler is in a blacklist, it doesn’t get sent any events anymore.

After setting this parameter, I upgraded back to #1084. On first boot, it took very long for OH to start. After 10 minutes, I initiated a restart. After that, OH started pretty quickly without any errors.

So now I have a working #1084 build. :slight_smile:

Not sure if setting that parameter is “best practice”. So I wanted to check: does one of you guys have a specific value set for this parameter?

3 Likes

Sorry, did forget to mention… I’m on a xen vm. But I’m pretty sure that this detail is not the source of the strange path error.

I did also test with the URI set in vscode instead of using the mapped samba share ("\\ip.of.my.openhab\openhab-conf\") and the message is slightly another, openHAB then complains about the URI containing authentication [string?]
And, yes, certainly the samba share is using authentication :slight_smile:

Could you please enter an issue at https://github.com/eclipse/smarthome/issues?

Another question: when the LSP port is configurable in vscode, where to configure in openHAB2?

Not possible yet. I have created an issue for it.

Thx, nice workaround, that made my #1084 working :rofl:
Have been stumbling with that for hours now :joy:

Btw, I am on Raspbian Jessie on a RPi3 …

For me openhab #1084 also fails to start properly. Besides the message that Paper UI couldn’t be downloaded there are other errors coming before that, so here is my log when starting:

2017-11-20 11:33:48.341 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-package-"standard"': No matching features for openhab-package-"standard"/0.0.0
2017-11-20 11:33:49.056 [WARN ] [url.mvn.internal.AetherBasedResolver] - Error resolving artifact org.openhab.core:org.openhab.ui.paperui:jar:2.2.0-SNAPSHOT: [Could not find artifact org.openhab.core:org.openhab.ui.paperui:jar:2.2.0-SNAPSHOT]
java.io.IOException: Error resolving artifact org.openhab.core:org.openhab.ui.paperui:jar:2.2.0-SNAPSHOT: [Could not find artifact org.openhab.core:org.openhab.ui.paperui:jar:2.2.0-SNAPSHOT]
        at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:720) [4:org.ops4j.pax.url.mvn:2.5.3]
        at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:659) [4:org.ops4j.pax.url.mvn:2.5.3]
        at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:600) [4:org.ops4j.pax.url.mvn:2.5.3]
        at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:567) [4:org.ops4j.pax.url.mvn:2.5.3]
        at org.apache.karaf.features.internal.download.impl.MavenDownloadTask.download(MavenDownloadTask.java:47) [9:org.apache.karaf.features.core:4.1.3]
        at org.apache.karaf.features.internal.download.impl.AbstractRetryableDownloadTask.run(AbstractRetryableDownloadTask.java:60) [9:org.apache.karaf.features.core:4.1.3]
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:?]
        at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:?]
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180) [?:?]
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293) [?:?]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [?:?]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [?:?]
        at java.lang.Thread.run(Thread.java:745) [?:?]
        Suppressed: shaded.org.eclipse.aether.transfer.ArtifactNotFoundException: Could not find artifact org.openhab.core:org.openhab.ui.paperui:jar:2.2.0-SNAPSHOT
                at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:434) [4:org.ops4j.pax.url.mvn:2.5.3]
                at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:246) [4:org.ops4j.pax.url.mvn:2.5.3]
                at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifact(DefaultArtifactResolver.java:223) [4:org.ops4j.pax.url.mvn:2.5.3]
                at shaded.org.eclipse.aether.internal.impl.DefaultRepositorySystem.resolveArtifact(DefaultRepositorySystem.java:294) [4:org.ops4j.pax.url.mvn:2.5.3]
                at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:705) [4:org.ops4j.pax.url.mvn:2.5.3]
                at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:659) [4:org.ops4j.pax.url.mvn:2.5.3]
                at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:600) [4:org.ops4j.pax.url.mvn:2.5.3]
                at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:567) [4:org.ops4j.pax.url.mvn:2.5.3]
                at org.apache.karaf.features.internal.download.impl.MavenDownloadTask.download(MavenDownloadTask.java:47) [9:org.apache.karaf.features.core:4.1.3]
                at org.apache.karaf.features.internal.download.impl.AbstractRetryableDownloadTask.run(AbstractRetryableDownloadTask.java:60) [9:org.apache.karaf.features.core:4.1.3]
                at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:?]
                at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:?]
                at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180) [?:?]
                at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293) [?:?]
                at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [?:?]
                at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [?:?]
                at java.lang.Thread.run(Thread.java:745) [?:?]
Caused by: shaded.org.eclipse.aether.resolution.ArtifactResolutionException: Error resolving artifact org.openhab.core:org.openhab.ui.paperui:jar:2.2.0-SNAPSHOT
        at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:444) ~[?:?]
        at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:246) ~[?:?]
        at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifact(DefaultArtifactResolver.java:223) ~[?:?]
        at shaded.org.eclipse.aether.internal.impl.DefaultRepositorySystem.resolveArtifact(DefaultRepositorySystem.java:294) ~[?:?]
        at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:705) ~[?:?]
        ... 12 more
2017-11-20 11:33:49.116 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-astro", openhab-ui-"basic, openhab-persistence-"influxdb", openhab-ui-habmin", openhab-binding-"zwave, openhab-ui-habpanel, openhab-ui-paper, openhab-misc-"restdocs"': Error:
        Error downloading mvn:org.openhab.core/org.openhab.ui.paperui/2.2.0-SNAPSHOT
2017-11-20 11:33:56.840 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'influxdb.persist'
2017-11-20 11:34:04.320 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'abwesenheit.rules'
2017-11-20 11:34:04.630 [INFO ] [thome.model.lsp.internal.ModelServer] - Language Server started on port 5007
2017-11-20 11:34:05.177 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'test.sitemap'
2017-11-20 11:34:05.567 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'astro.things'
2017-11-20 11:34:07.760 [INFO ] [.dashboard.internal.DashboardService] - Started dashboard at http://192.168.0.22:8080
2017-11-20 11:34:07.774 [INFO ] [.dashboard.internal.DashboardService] - Started dashboard at https://192.168.0.22:8443

I am running openHAB on a RPi3 as well. The versions I got are:

$ cat /var/lib/openhab2/etc/version.properties 
openHAB Distribution Version Information
----------------------------------------
build-no        : Build #1084
online-repo     : https://openhab.jfrog.io/openhab/online-repo-snapshot/2.2

Repository        Version
----------------------------------------
openhab-distro  : 2.2.0-SNAPSHOT
smarthome       : 0.9.0-SNAPSHOT
openhab-core    : 2.2.0-SNAPSHOT
openhab1-addons : 1.11.0-SNAPSHOT
openhab2-addons : 2.2.0-SNAPSHOT
karaf           : 4.1.3

It definitely is NOT a best practice. When any event processing takes longer than 5s, something is wrong and some piece of code blocks the thread, which is a bug. Changing this parameter and thus not setting a time-out merely ignores this bug, but as you say that takes 10 minutes to start, it is still obvious that this is not an intended behavior. Unfortunately, we cannot see from the log, which part of the code blocks. OSGiEventManager only delegates, so it itself is most likely not the culprit. I have created an issue to address this in future.

I added an issue for the Error executing command: java.io.IOException: Stream Closed

This is the part of my log (only info, not debug) where my #1084 system stopped working several times:

2017-11-20 10:42:37.929 [WARN ] [ore.internal.events.OSGiEventManager] - Dispatching event to subscriber 'org.eclipse.smarthome.io.monitor.internal.EventLogger@a0334a' takes more than 5000ms.
2017-11-20 10:42:37.931 [WARN ] [ore.internal.events.OSGiEventManager] - Dispatching event to subscriber 'org.eclipse.smarthome.io.monitor.internal.EventLogger@a0334a' takes more than 5000ms.
2017-11-20 10:42:37.932 [WARN ] [org.apache.karaf.services.eventadmin] - EventAdmin: Blacklisting ServiceReference [{org.osgi.service.event.EventHandler, org.eclipse.smarthome.core.events.EventPublisher}={event.topics=smarthome, component.name=org.eclipse.smarthome.core.internal.events.OSGiEventManager, component.id=62, service.id=158, service.bundleid=110, service.scope=bundle} | Bundle(org.eclipse.smarthome.core_0.9.0.201711182209 [110])] due to timeout!
2017-11-20 10:42:41.162 [WARN ] [org.apache.karaf.services.eventadmin] - EventAdmin: Blacklisting ServiceReference [{org.osgi.service.event.EventHandler, org.eclipse.smarthome.core.events.EventPublisher}={event.topics=smarthome, component.name=org.eclipse.smarthome.core.internal.events.OSGiEventManager, component.id=62, service.id=158, service.bundleid=110, service.scope=bundle} | Bundle(org.eclipse.smarthome.core_0.9.0.201711182209 [110])] due to timeout!
2017-11-20 10:42:41.174 [WARN ] [org.apache.karaf.services.eventadmin] - EventAdmin: Blacklisting ServiceReference [{org.osgi.service.event.EventHandler, org.eclipse.smarthome.core.events.EventPublisher}={event.topics=smarthome, component.name=org.eclipse.smarthome.core.internal.events.OSGiEventManager, component.id=62, service.id=158, service.bundleid=110, service.scope=bundle} | Bundle(org.eclipse.smarthome.core_0.9.0.201711182209 [110])] due to timeout!
2017-11-20 10:42:41.179 [WARN ] [org.apache.karaf.services.eventadmin] - EventAdmin: Blacklisting ServiceReference [{org.osgi.service.event.EventHandler, org.eclipse.smarthome.core.events.EventPublisher}={event.topics=smarthome, component.name=org.eclipse.smarthome.core.internal.events.OSGiEventManager, component.id=62, service.id=158, service.bundleid=110, service.scope=bundle} | Bundle(org.eclipse.smarthome.core_0.9.0.201711182209 [110])] due to timeout!

Yes, that’s what I mean: These logs do not tell us anything. We need to do some proper tracking within the framework in order to be able to produce better logs in future.

Done! https://github.com/eclipse/smarthome/issues/4601

Seeing all those misplaced quotes makes me wonder if something in the config parser is broken? My /var/lib/openhab2/etc/org.openhab.addons.cfg looks like this:

package = "standard"
ui = "basic,paper,habpanel,habmin"
remote = B"true"
persistence = "influxdb"
misc = "restdocs"
binding = "zwave,astro"

Looking at the samples in /etc/openhab2/services/addons.cfg let me try removing the quotes from the file but that just changed the error messages (no more quotes), the actual errors are still the same.

Is there anything I can try to help fixing this?

The quotes are definitely wrong (upgraded to #1088 as well and there are no quotes at all in my addons.cfg)

I think you have to delete cache:

Thanks for reminding me. I already tried that a few times, but it seems I never did it at the same time as removing the quotes. So I always had either a bad config or cached data coming from the bad config. Doing both (clearing cache and removing quotes) now got rid of the error about openhab-package-standard not being installed, but I still have this left:

2017-11-21 19:18:43.016 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'abwesenheit.rules'
2017-11-21 19:18:44.785 [INFO ] [.dashboard.internal.DashboardService] - Started dashboard at http://192.168.0.22:8080
2017-11-21 19:18:44.802 [INFO ] [.dashboard.internal.DashboardService] - Started dashboard at https://192.168.0.22:8443
2017-11-21 19:18:50.333 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'influxdb.persist'
2017-11-21 19:18:51.191 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'test.sitemap'
2017-11-21 19:18:57.012 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'astro.things'
2017-11-21 19:18:57.191 [INFO ] [thome.model.lsp.internal.ModelServer] - Language Server started on port 5007
2017-11-21 19:19:03.081 [WARN ] [url.mvn.internal.AetherBasedResolver] - Error resolving artifact org.openhab.ui:org.openhab.ui.habmin:jar:2.2.0-SNAPSHOT: [Could not find artifact org.openhab.ui:org.openhab.ui.habmin:jar:2.2.0-SNAPSHOT]
java.io.IOException: Error resolving artifact org.openhab.ui:org.openhab.ui.habmin:jar:2.2.0-SNAPSHOT: [Could not find artifact org.openhab.ui:org.openhab.ui.habmin:jar:2.2.0-SNAPSHOT]
        at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:720) [4:org.ops4j.pax.url.mvn:2.5.3]
        at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:659) [4:org.ops4j.pax.url.mvn:2.5.3]
        at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:600) [4:org.ops4j.pax.url.mvn:2.5.3]
        at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:567) [4:org.ops4j.pax.url.mvn:2.5.3]
        at org.apache.karaf.features.internal.download.impl.MavenDownloadTask.download(MavenDownloadTask.java:47) [9:org.apache.karaf.features.core:4.1.3]
        at org.apache.karaf.features.internal.download.impl.AbstractRetryableDownloadTask.run(AbstractRetryableDownloadTask.java:60) [9:org.apache.karaf.features.core:4.1.3]
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:?]
        at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:?]
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180) [?:?]
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293) [?:?]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [?:?]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [?:?]
        at java.lang.Thread.run(Thread.java:745) [?:?]
        Suppressed: shaded.org.eclipse.aether.transfer.ArtifactNotFoundException: Could not find artifact org.openhab.ui:org.openhab.ui.habmin:jar:2.2.0-SNAPSHOT
                at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:434) [4:org.ops4j.pax.url.mvn:2.5.3]
                at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:246) [4:org.ops4j.pax.url.mvn:2.5.3]
                at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifact(DefaultArtifactResolver.java:223) [4:org.ops4j.pax.url.mvn:2.5.3]
                at shaded.org.eclipse.aether.internal.impl.DefaultRepositorySystem.resolveArtifact(DefaultRepositorySystem.java:294) [4:org.ops4j.pax.url.mvn:2.5.3]
                at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:705) [4:org.ops4j.pax.url.mvn:2.5.3]
                at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:659) [4:org.ops4j.pax.url.mvn:2.5.3]
                at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:600) [4:org.ops4j.pax.url.mvn:2.5.3]
                at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:567) [4:org.ops4j.pax.url.mvn:2.5.3]
                at org.apache.karaf.features.internal.download.impl.MavenDownloadTask.download(MavenDownloadTask.java:47) [9:org.apache.karaf.features.core:4.1.3]
                at org.apache.karaf.features.internal.download.impl.AbstractRetryableDownloadTask.run(AbstractRetryableDownloadTask.java:60) [9:org.apache.karaf.features.core:4.1.3]
                at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:?]
                at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:?]
                at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180) [?:?]
                at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293) [?:?]
                at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [?:?]
                at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [?:?]
                at java.lang.Thread.run(Thread.java:745) [?:?]
Caused by: shaded.org.eclipse.aether.resolution.ArtifactResolutionException: Error resolving artifact org.openhab.ui:org.openhab.ui.habmin:jar:2.2.0-SNAPSHOT
        at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:444) ~[?:?]
        at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:246) ~[?:?]
        at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifact(DefaultArtifactResolver.java:223) ~[?:?]
        at shaded.org.eclipse.aether.internal.impl.DefaultRepositorySystem.resolveArtifact(DefaultRepositorySystem.java:294) ~[?:?]
        at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:705) ~[?:?]
        ... 12 more
2017-11-21 19:19:03.136 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-ui-basic, openhab-misc-restdocs, openhab-binding-astro, openhab-ui-habmin, openhab-persistence-influxdb, openhab-ui-habpanel, openhab-ui-paper, openhab-binding-zwave': Error:
        Error downloading mvn:org.openhab.ui/org.openhab.ui.habmin/2.2.0-SNAPSHOT

The config now looks like this:

package = standard
ui = basic,paper,habpanel,habmin
remote = B"true"
persistence = influxdb
misc = restdocs
binding = zwave,astro

Any hint how to proceed? I didn’t write that config myself, openHAB did. So I don’t know how any wrong quotes got in there in the first place.

This doesn’t look right? Typo or is that actually in your file? I have remote = true, not “B” and no quotes.

I don’t know if this is related to your current problem.

Thats really interesting. I have now checked my addon.cfg and recognized that also with an update to #1088 this file is empty. Everything is commented out.
Maybe thats the point where all of those issues coming from?

My installation still hangs with installing UI …

Hooray, that was it! After fixing the bool value I can control my lights and blinds again. :smile:

1 Like

I can now confirm that also fixed all my tons of errors after the upgrade.
I just reinstalled the bindings which i havent all listed within the addons.cfg file.

It is the case that after upgrading this file is not getting migrated but getting completely overwritten. i just activated necessary lines (everything was commented out).

Now everything works again and being on #1088.

Maybe someone can look into it why addons.cfg is not “migrated” properly when doing an upgrade - this saves a lot of time to people :slight_smile:
hooray

I don’t know if this is helping, but I just checked my /var/lib/openhab2/etc/org.openhab.addons.cfg and it looks exactly like @houz one, I’ve also got the B"true". I’m running build 1073 (didn’t dare upgrading last few days because of the known problems) and everything is working like a charm here.

Pasting the entire file below:

package = "standard"
ui = "basic,paper,habmin"
remote = B"true"
binding = "tellstick,expire1,exec,sonos"
persistence = "jdbc-mysql"
action = "mail"
transformation = "regex"
voice = "voicerss"

i’ve read the whole thread and have been following all the leads, but still nothing works. Here the first error message:

2017-11-21 21:45:00.709 [ERROR] [org.openhab.binding.pilight         ] - FrameworkEvent ERROR - org.openhab.binding.pilight
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.pilight [11]
  Unresolved requirement: Import-Package: org.openhab.core.binding

After some more exceptions it results in the following error:

2017-11-21 21:45:03.827 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-exec, openhab-binding-enocean1, openhab-persistence-"mysql, openhab-binding-"avmfritz, openhab-binding-caldav-command1, openhab-ui-habpanel, openhab-transformation-"map, openhab-transformation-regex, openhab-ui-"classic, openhab-binding-lgtv1", openhab-persistence-rrd4j", openhab-ui-basic, openhab-binding-caldav-personal1, openhab-ui-habmin", openhab-transformation-xslt, openhab-transformation-exec, openhab-transformation-jsonpath", openhab-ui-paper, openhab-misc-"restdocs", openhab-binding-onkyo': Error:
	Error downloading mvn:org.openhab.binding/org.openhab.binding.caldav-personal/1.11.0-SNAPSHOT

after all it still hangs with “please stand by while UIs are being installed. This can take several minutes.”

I’ve upgraded from Build #1082 to Build #1088 running ‘runtime/bin/update’, platform is a raspberry pi 3, openhab is installed in /opt/openhab2 as described here.

@benjy, you work a lot with the upgrade scripts and such, do you have any ideas? To summarize, people are upgrading to recent builds and their addons.cfg are becoming corrupted. See Daniel’s posting for an example.