M3 testing results

Hey everyone
Just installed M3 and so far so good. Everything seems to work, rules ect.
Couple things to note:
I know the REST docs moved. I am getting the following error in the log about once a minute

17:19:54.190 [ERROR] [.core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-misc-restdocs'

and Hilbrand’s beta TP-Link binding had to be reinstalled
All other bindings were installed after upgrade

Edit to add:
My zwave binding is a development version from right after 2.4 stable was released and is still running. I guess it would be ok to delete it out of addons and install the current version that comes with 2.5M3 as that is probably a newer version
will update with how that goes

I also saw this hickup. As i’m using a virtual machine, I installed a new one :slight_smile:

The TP-Link Binding in M3 contains all features of the Beta version. So you should be able to use the standard version.

far out Hilbrand! nice

They are now under ui since 2.5M1.

Poke around in this thread. You need to edit a cfg file likely.

1 Like

yup… all the way at the bottom Bruce

error gone
this baby seems ready for a stable release

edit: whoops… not so fast, my embeded MQTT broker says:
OFFLINE - CONFIGURATION_ERROR The system connection with the name embedded-mqtt-broker doesnt exist anymore.
edit to add… seems to be an erroneous file lock, read more below

1 Like

OK… to round up all the issues in this thread so far

Hue emulation:
I don’t use Hue emulation but have read some about it being broken and fix needing to be something upstream beyond developer’s control? @Thedannymullen Danny can you give information as to if this binding is working? I also be remember someone saying the functionality is replaced in a different binding now??? Can anyone comment on this?

@vzorglub Vincent I’m guessing you have a working REST docs by now? I read the issue Hilbrand posted above in post 4 which is still open. I had to install REST docs from new location but had a recurring error in logs until Bruce pointed me to post with cure Is the issue of broken REST fixed. Should I create an issue for the problem Bruce helped me with or mention is in that existing issue?

@Flole did you ever track down your issue with instability and start up?

System Info:
CPU channel is gone and no fix is possible at this time

Embedded Moquette broker:
My problem as reported in this thread with a new issue created here I noticed nobody else in this thread seems to be using the embedded mqtt broker

Anything else I missed? This seems to be a really great version and I noticed lots of little enhancements and hoping a stable release comes soon because so many folks don’t like to not run a stable version and many fixes since 2.4

There are some bindings thatinteract to break the REST docs due to dependency version conflicts. The fix(es) needed did not make it into M3.

Yes Bruce, I checked out the git issue but I’m assuming Vincent hasn’t gone all this time with no REST docs so is there a work around or something?

The only one I would know of would be a second installation of OH just to reference the REST API docs. I think that breakage happened between M1 & M2.

I have… Unfortunately. No fix yet

1 Like

Agree that M3 is pretty solid (as are subsequent snapshots). OTOH, there are several new bindings (including 2 of mine :wink:) that are pretty close to being included in the distro. Would be nice if the next stable release could include some of these. :crossed_fingers:


Yes Mark, you have been rocking it! Been keeping an eye on your door bird development and the community is loving it!!! Bravo! :+1:

The REST docs must be fixed before next stable IMHO.

Hue emulation is worrisome but I thought I had heard it’s functionality has been replaced by another binding. I know little of Hue emulation though except that David has completely lost interest

@Andrew_Rowe the hue emulation does not function in my testing on m3. The lack of function is in regards to alexa discovery and interaction.

I have tried installing a couple different times but the outcome is the same. I have filed an issue on github for it and the developers acknowledged it.

There is no other binding to replace hue emulation. I read the same thing and upon questioning my opinion is they were speaking of using the openHAB skil in alexa.

Git issue: https://github.com/openhab/openhab2-addons/issues/6042

Oh ok… that is not a replacement at all. So please post link to git issue so all of us who want to play along at home can follow along. I now consider this and the REST docs to be blockers for 2.5 stable
IMHO :thinking:

Phillips binding works perfectly.
I can post any logging if it will help

1 Like


As mentioned here, sshd is not working on S1710.

Thanks weakfl for reporting this issue. From reading your thread it sounds like you tried it but then reverted to previous working version without having time to debug? Can you provide any additional details. If you raised an issue on git please provide a link.

RPi 3B rev 1.2
OH2.5M3 (openhabian) (note: Just reinstalled from a manual install that have worked over the years (mainly nightly releases from 2.0 and lastly 2.5M3) but started to get problems (couldn’t add Sonos Beam) so reinstalled everything).
Amazon Echo Control
Samsung TV

Hue Emulation - Unable to get this working with my Logitech harmony Hub.
OpenHab Cloud

Can’t use Rest GIU but it seems to be a known problem with m3.

Except for Hue Emulation and Rest GUI, everything works just fine at the moment.