Miele Cloud-binding

Get a new pair of client id and client secret!

Best regards

Could I repeat the registration or how to achieve that?

Jep, just new registration if I remember correct. I requested a new pair when I head similar problems in setting up the cloud access.

It took some time until the email with „please activate“ arrived!

Best regards

I did the registration again, same problem
It seems that it returned the same pair of client id and secret than before - maybe they derive it from the email address

tata, requesting a pairing with the e-mail address used for the App registration finally succeeded (whatever was the problem). Now thing is ONLINE, I could link channels and remote control works.

I’m using an oven. Is there no way to select the program? I see program status, elapsed/remaining time etc., but no selection for the program.

Some Feedback:

  • Maybe the servlet could also create the thing - all in once rather than hopping between OH UI and Servlet UI
  • There should be some kind of error status when the pairing fails
  • There are various channels enabling/disabling remote control. I think those should go to the thing configuration, there is no need to have them as channels
  • Use channel groups to group channels, which belong together. This can be easily done by adding a “#” to the channel name, e.g. program#remaining time, program#elapsed_time
  • I would name the channels programElapsedTime instead of program_elapsed_time etc.

Finally: looks really professional, good job :slight_smile:


since today I am not able to connect to Miele Cloud anymore. I tried using OH2.5.11, OH2.5.12, OH3.0, OH3.01 - with corresponding MieleCloud (beta) Binding.

All instances are saying (on http://openHAB-ip:8080/mielecloud)
The following bridges are paired, mielecloud:account: home OFFLINE

I tried pairing a couple of times - no suceess.

OH log:

2021-01-28 14:26:11.088 [INFO ] [nternal.webservice.sse.SseConnection] - Scheduled reconnect attempt for Miele webservice to take place in 13 seconds
2021-01-28 14:26:24.088 [INFO ] [nternal.webservice.sse.SseConnection] - Opening SSE connection...
2021-01-28 14:26:54.298 [INFO ] [nternal.webservice.sse.SseConnection] - Scheduled reconnect attempt for Miele webservice to take place in 95 seconds

Because my wife is already complaining… :wink: is there something I can do do bring openHAB & Miele back online?

Yeah, I just noticed the same thing.

1 Like

Hi @April_Wexler @mhilbush,
we have the same issue with our testing instance. It is caused by a Gateway-Timeout (HTTP 504) on the cloud’s SSE Event Stream endpoint that the binding uses for real-time updates. All other endpoints seem to work fine, but as the binding cannot connect it stops working. We assume that this is a temporary problem. I will check it again tomorrow and see what I can do if the error still exists then. Sorry for the inconvenience.

Just to let you know: We also planned to release a new beta version with the changes from the review tomorrow as @mhilbush requested.


same here openhab 2.51 on Qnap.
pairing successfull but offline the whole time…



1 Like

@BjoernLange This gave me a good chuckle this morning… :grinning_face_with_smiling_eyes: Does that really equate to 9.3 trillion days? There must be an edge case in the exponential back-off calculation.

2021-01-30 11:46:36.739 [DEBUG] [g.mielecloud.internal.webservice.sse.SseConnection] - Opening SSE connection...
2021-01-30 11:47:07.102 [DEBUG] [g.mielecloud.internal.webservice.sse.SseConnection] - Scheduled reconnect attempt for Miele webservice to take place in 477 seconds
2021-01-30 11:55:04.102 [DEBUG] [g.mielecloud.internal.webservice.sse.SseConnection] - Opening SSE connection...
2021-01-30 11:55:34.458 [DEBUG] [g.mielecloud.internal.webservice.sse.SseConnection] - Scheduled reconnect attempt for Miele webservice to take place in 2360 seconds
2021-01-30 12:34:54.458 [DEBUG] [g.mielecloud.internal.webservice.sse.SseConnection] - Opening SSE connection...
2021-01-30 12:35:24.825 [DEBUG] [g.mielecloud.internal.webservice.sse.SseConnection] - Scheduled reconnect attempt for Miele webservice to take place in 804243239798179465 seconds
1 Like

@mhilbush me too :slightly_smiling_face:

Obviously, this shouldn’t happen and I’m unsure of how it happened. Not going into too much technical detail, I assume an invalid Retry-After header was sent by a remote server and then processed by the binding. To prevent this in the future the binding now uses the same limits for Retry-After headers as for regular back-off (reconnect interval between five seconds and one hour). I’m sorry to say this, but everyone affected will have to restart the binding (or their openHAB instance). We will include the fix in the planned beta release which we are going to publish once the current cloud issues are resolved.

Regarding the cloud issues: Miele replied this morning that they are working on it.


The cloud problem is fixed. Bindings should reconnect automatically within one hour. If this doesn’t happen please restart the binding.


Everything looks good now. Thanks!!

1 Like

it works again! Thanks :slight_smile:

After Restart (Pause and Start in Main UI) it goes ONLINE immediately.


As requested by @mhilbush we released version beta.5 today. It ships with the changes from the official contribution review.

As the previous version it only works with openHAB 3.0. No steps are required for migration apart from installing the new .jar file, but you may want to migrate your temperature items to make use of the added support for Units of Measurements.

1 Like

Thanks for that info. Just because I am curious: there will be no further betas for OH2.5.x, right?
I am still on 2.5.12 - and plan to move to 3.x soon - but didn’t complete the move yet.

Hi @BjoernLange ,

i noticed a little issue in the binding for a dishwasher G7360:
The elapsed time is not increasing/updating.
Currently the dishwasher is running but elapsedtime stays on 0 sec:

I tried to add a new item, but same result.

for the washing machine the elapsed time it is working fine!


2021-02-11 10:14:52.734 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'WaschmaschineWSI863_Programelapsedtime' changed from 5760 to 5820

2021-02-11 10:14:52.742 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'WaschmaschineWSI863_Programremainingtime' changed from 1260 to 1200

2021-02-11 10:14:52.759 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'GeschirrspulerG7360_Programremainingtime' changed from 2220 to 2160

Best regards

Sorry for the late response, I was quite busy the last few days. As this question was asked multiple times I added an FAQ (specifically this question).

The elapsed time, remaining time and progress fields are updated according to the display on the Miele device. This means that this is not a real-time counter, I assume you already figured that out given your edit. If you encounter further issues please open an issue in our beta repository so that we can track problems in one place.

Edit: I looked at your log again, this indeed seems a little weird. Please track the elapsed and remaining times over one run of your dish washer and if they do not behave consistent with the device display open an issue.

1 Like

Hi @BjoernLange,

thanks for your quick reply.

No I think you misunderstood my edit. Its just to confirm, that elapsed time is updating with the wasching machine, but not with the dishwasher. For the whole 2.5h running time, the elapsed time was still “0 sec”. Maybe it is a model without this information? Because the display is just visible when the program is almost done and the door is opening a little bit to support the drying process.

So when I found out to open an issue, I will dot it :slight_smile:

Elapsed time still “0 sec”: