Mqtt Broker OH 4.1

What am I doing wrong ? . I installed the new OH 4.1 and I can’t configure mqtt broker. Previously, I worked on OH 2 and everything worked.

In OH 2 I created a w file an directory things caled

Bridge mqtt:broker:MosquittoMqttBroker “Mój MQTT Broker” [

What should I do in OH 4?

Have you clicked on the show advanced.
There are more settings there.

This is how I set port 1883, user and password

That is the same as I have except I put in a clientid. I made it openhab4 as the name.

I don’t have a username or password set. Other than that it looks the same as what I have.

I am using mosquitto broker as well.

The error you are seeing is connection refused.
Is password and user correct?

Is mosquitto running and on the correct port?

Is this a new install or an upgrade to 4.1?
I have found a few issues upgrading with parts of things missing and if you remove the thing and out it back it may work?

new install

How and where to check it?

Should work then.

Look at the mosquitto logs.

sudo tail -f /var/log/mosquitto/mosquitto.log

I don’t have such a catalog/VAR/Log/Mosquitto/ x

in /etc/ no mosquitto

Why does this say mosqutto then if you are not using mosquitto broker?
What were you using before?
I don’t know your set up.

Where is your MQTT broker running?
There is no system internal broker any more apparently:

That is correct, there is no longer a internal broker

It wasn’t installed, but now it doesn’t seem to want to run.

The log is clear, your config is blocking connections from other machines and there seems something is already using that port.

It works, in mosqutto version after 2.0 you need to


listener 1883
add allow_anonymous true

Thank you all for helping me solve my problem

1 Like

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.