Myopenhab.org still says offline

Hello. I’ve had the pleasure of doing the openhab installation process many times in the past 24-30 hours and I am still unable to get myopenhab.org to show that it is online. If anyone can help, I would be very grateful.

Currently I am able to view the site on mobile and on PC which are on the same network, so there doesn’t seam to be an issue with the runtime, sitemap, or item files. I’ve went through the exact process in the following examples:

There seams to be one (maybe more) step(s) that I’ve missed. Also, the secret file is not auto-generating. I’ve created a file and put a code which, somehow, was generated before, but the past 2 times of imaging a microSDHC card and following the process has not produced this file. I am using bot the 2 model B and 3 model B.

Again, I hope someone can help as I’m about to pull my hair out.

I would highly recommend to use the official install instructions at

http://docs.openhab.org/addons/io/openhabcloud/readme.html

and take a look into this thread:

and don’t forget the email verification:

Okay, well I just made an account 2 days ago and verified my email on the myopenhab.org site. I’ll look at the installation instructions and see if I missed anything. Also, shouldn’t it still work for version 1.8.3? I believe that is the version it downloaded so I would not think that older version simply stopped working with the site.

Setup openHABCloud on openHAB1 is a different story:

So, I’ve followed the directions posted earlier, but now when I go to find the UUID or secret files, they are not there, and I’m not able to find them. I need these to connect to myopenhab.org do I not?

Yes, you do.

Let’s summarize:
If you are using openHAB2, you need to install the openHABCloud connector 2.x via PaperUI or addons.cfg,
If you are using openHAB1, you need to download the openHABCloud conncector bundle 1.9 and copy it to your addons folder.
In both cases you need a java version later than 101. It does not work with java version 65.
In both cases the UUID and SECRET get created automatically after installing the connector, if not, you may need to restart openHAB or the server.

Good luck.

I apologize. I am new to this and I’m very confused on why I can’t get this to work.

No need to.
I just wanted to tell you all options because you did not tell us which version of openHAB your are using.

So, something else came up. I’m looking to use the gpio pins on the Raspberry and with the OpenHAB V2.x I do not think it’s possible to enable them. I checked and the version of java I had installed was 1.8.0_65-b17 so as you said it doesn’t work with this version. Will I have to go back to V1.x with OpenHAB to use the gpio pins, or is there a way to do this on V2.x?

Yes, should be possible:

and it should have nothing to do with the java version. But it is always a good idea to upgrade to the latest version.

I am starting with OpenHAB V1.8.3 and the version of java is 1.8.0.121. The secret and uuid were created automatically, and I put them into my account on myopenhab.org and have attempted to make a persistence to myopenhab, but unfortunetly at this point I’m not sure why it is still saying “Offline”. I still am able to get to the OpenHAB interface via the local network and it works the gpio pin as it is suppose to and has before, so I’m still confused why the connection to myopenhab.org is not working.

1 Like

Just checking… did you get the email and confirm registration?

Yes, I did those already, and I have updated the UUID and secret to the new ones, but it’s still not making a connection. I’m not sure what I haven’t done or what needs done now, and I’m not really wanting to go through the papreUI. I’d like to just be able to use the SSH and command line approach. I have no idea where any files are or what to do in V2.x… I can’t even get a switch to show up. At least in V1.x I was able to get a pin to turn on and off via the classicUI, but now I can’t do anything and it frustrates and upsets me.

Your items, rules, persistence, sitemap, ect. files are in /etc/openhab2.

It is easiest to go into Paper UI and under configuration>bindings>UI (I believe that is where it is) set the Basic or Classic UI sitemap from _default to whatever yours is named. Then you can access it via http://youropenhabip:8080.

It may be easiest to go into Paper UI, but I liked editing and programming the sitemap and items from the files. This still does not fix the problem where I am not seeing anything on myopenhab.org. Still would also like to know how to access and control the gpio pins in V2.x as I have made a switch to turn it on and off, but nothing to connect to it. The tutorials are getting me some help, but I’m still not finding what the problem is or how to fix it.

Did the GPIO binding not work?

Some more links to that:


http://docs.openhab.org/addons/bindings/gpio1/readme.html

The settings provided by @RHINESEL can also be done via text config:

(same config options are supported by classicui.cfg)

I too am having a similar problem.

Previously I had openHab 1.9 running succesfully on a pc with my.openhab.

Decided to run openhab 2 on a raspberry pi, and did a ‘repository’ ‘stable’ install according to instructions at http://docs.openhab.org/installation/index.html.

I have java version 1.8.0_121-b13.

I can see my openhab in local network.

I used PaperUi and configured openhab Cloud Connector 2.0.

I have double checked the UUID and Secret, and they are correct.

I have deleted myopenhab account and rejoined and replied to email.

But still, myopenhab says offline! (grr)

I read somewhere that openhab Cloud Connector 2.0 can only be used with a Snapshot version of openhab? and I used a stable version. Should I be using a different version of the openhab Cloud Connector?

1 Like

I fixed by following instructions here http://suhothayan.blogspot.ch/2012/05/how-to-install-java-cryptography.html

overwrote files in both JRE and JDK security settings, restarted Java and opehab and now connected.

Could you explain how that process went a little more please? What instructions did you follow exactly, as I am not sure how to install this file via the command prompt in the terminal.

I followed the instructions I provided in the link exactly, connected via
SSH and performed the steps, copying to the stated location, not sure how
to explain this any better I’m afraid.