Neo coolcam z-wave devices

zwave
Tags: #<Tag:0x00007fe05daa00b0>

(Helmut Schütt) #161

@alefz3r0
Today my capacitors arrived, I was able to repair two of my sensors with a 22nF capacitor.
They’re working well now :wink:

Thanks a lot

Helmar


(aleph zero) #162

Good to hear that! Thank you as well!


(Nakh Home) #163

Hi

i have bought those two items

NEO-Coolcam-NAS-DS01Z-Smart-Home-Z-Wave-Plus-Door-Window-Sensor-Compatible-with-Z-wave

NEO Coolcam NAS-PD01Z Smart Home Z-Wave Plus PIR Motion Sensor

My things

i have defined my items :


DateTime ZWaveNode2_DoorWindowSensor_LastUpdate   "Last Update [%1$ta %1$tR]" <clock>
DateTime ZWaveNode2DoorWindowSensor_AlarmAccess_LastUpdate   "Last Update [%1$ta %1$tR]" <clock>
DateTime ZWaveNode2DoorWindowSensor_BatteryLevel_LastUpdate   "Last Update [%1$ta %1$tR]" <clock>
DateTime ZWaveNode8MotionSensorPIRMotionSensor_BinarySensor_LastUpdate   "Last Update [%1$ta %1$tR]" <clock>
DateTime ZWaveNode8MotionSensorPIRMotionSensor_SensorLuminance_LastUpdate   "Last Update [%1$ta %1$tR]" <clock>
DateTime ZWaveNode8MotionSensorPIRMotionSensor_SensorTemperature_LastUpdate   "Last Update [%1$ta %1$tR]" <clock>
DateTime ZWaveNode8MotionSensorPIRMotionSensor_AlarmBurglar_LastUpdate  "Last Update [%1$ta %1$tR]" <clock>
DateTime ZWaveNode8MotionSensorPIRMotionSensor_BatteryLevel_LastUpdate  "Last Update [%1$ta %1$tR]" <clock>

and a rule file


rule "ZWaveNode2_DoorWindowSensor"
when
    Item ZWaveNode2_DoorWindowSensor changed 
then
     ZWaveNode2_DoorWindowSensor_LastUpdate.postUpdate(new DateTimeType()) 
end

rule "ZWaveNode2DoorWindowSensor_AlarmAccess_LastUpdate"
when
    Item ZWaveNode2DoorWindowSensor_AlarmAccess changed 
then
     ZWaveNode2DoorWindowSensor_AlarmAccess_LastUpdate.postUpdate(new DateTimeType()) 
end

rule "ZWaveNode2DoorWindowSensor_BatteryLevel_LastUpdate"
when
    Item ZWaveNode2DoorWindowSensor_BatteryLevel changed 
then
     ZWaveNode2DoorWindowSensor_BatteryLevel_LastUpdate.postUpdate(new DateTimeType()) 
end

rule "ZWaveNode8MotionSensorPIRMotionSensor_BinarySensor_LastUpdate"
when
    Item ZWaveNode8MotionSensorPIRMotionSensor_BinarySensor changed 
then
     ZWaveNode8MotionSensorPIRMotionSensor_BinarySensor_LastUpdate.postUpdate(new DateTimeType()) 
end


rule "ZWaveNode8MotionSensorPIRMotionSensor_SensorLuminance_LastUpdate"
when
    Item ZWaveNode8MotionSensorPIRMotionSensor_SensorLuminance changed 
then
     ZWaveNode8MotionSensorPIRMotionSensor_SensorLuminance_LastUpdate.postUpdate(new DateTimeType()) 
end

rule "ZWaveNode8MotionSensorPIRMotionSensor_SensorTemperature_LastUpdate"
when
    Item ZWaveNode8MotionSensorPIRMotionSensor_SensorTemperature changed 
then
     ZWaveNode8MotionSensorPIRMotionSensor_SensorTemperature_LastUpdate.postUpdate(new DateTimeType()) 
end


rule "ZWaveNode8MotionSensorPIRMotionSensor_AlarmBurglar_LastUpdate"
when
    Item ZWaveNode8MotionSensorPIRMotionSensor_AlarmBurglar changed 
then
     ZWaveNode8MotionSensorPIRMotionSensor_AlarmBurglar_LastUpdate.postUpdate(new DateTimeType()) 
end

rule "ZWaveNode8MotionSensorPIRMotionSensor_BatteryLevel_LastUpdate"
when
    Item ZWaveNode8MotionSensorPIRMotionSensor_BatteryLevel changed 
then
     ZWaveNode8MotionSensorPIRMotionSensor_BatteryLevel_LastUpdate.postUpdate(new DateTimeType()) 
end
your code goes here

not all the channels are updated

even when i am pressing once on the physical button on the door and motion sensor, i can see in the log that

2018-04-01 17:02:34.622 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:162723a63f8:node8' has been updated.

2018-04-01 17:02:40.113 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:162723a63f8:node4' has been updated

what am i missing???


(Chris Jackson) #165

It doesn’t appear to be in the database, so I guess it’s not been used in OH at least.


(SiHui) #168

Yes.

No :sunglasses:


(SiHui) #170

Yes, you still have to use the development/security version of the zwave binding:


(SiHui) #172

Yes (that’s the one I’m using, too :sunglasses: )


(SiHui) #174

Yes, I think it will be in the 2.3 stable.

Yes, just uninstall and reinstall again.
But: after upgrading your openHAB build you need to install the market place bindings again.


(Mar Li) #175

hi,

today I received my neo coolcam 2ch light switch (NAS-SC01Z). just one question to those who also have this switch: inclusion etc did work without any problem. but the touch response of the switch is really slow… so between 0,2sec and 2sec… always different. and switch on both lights nearly at the same time is almost impossible. have to wait 1sec for it.

so do you have the same experience?


(Martin van Wingerden) #176

Short answer, Yes

Sometimes however its better, sometimes its worse. My wife even had the experience that she thought it did not pick up her request clicked again and then the lighted turned on and immediately off.

However in general it performs okay, but not great, my wife did not yet hire someone to replace it or me, so I’m good for now :blush:


(J Wee) #177

Sorry Newbie here. I just connected a Neo Coolcam Door/window sensor to Openhab 2. Paper UI says its online, but “device no the database” under Configuration/things, and that “device initialisation is not complete”

What do I need to do ?


(SiHui) #178

Check the database if it is in there:
http://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list

If not, add it:
http://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-database-guide

If it is in there update to the latest zwave snapshot binding, because it may not be available in the stable version …


(J Wee) #179

Hi, how did you remove the sensor from the Z-wave network?
is this done with openhab 2.2?

thanks


(J Wee) #180

I see the sensor in the list. How do I export it for incorporation into openhab 2.2 binding that I am on now? is it absolutely necessary to use the latest zwave snapshot binding?


(SiHui) #181

It depends: if the device is an old device it may be in the 2.2 stable. If not, you need to upgrade. But the steps are easy: uninstall the 2.2. binding, download the snapshot, put in in your addons folder, restart openHAB and you should be good to go.

Go to HABmin (or PaperUI), select your controller, go to “Tools”, hit “show advanced settings”, hit “Exclude devices”. Now you have 30 seconds to push the exclude button on your device.

https://docs.openhab.org/addons/bindings/zwave/readme.html#inclusion-and-exclusion


(Mar Li) #182

maybe your device is also too far away so the inclusion is not complete. then it could also appear the message “device unknown” or sth. like that.

at least the zwave 2.3 snapshot binding support the sensor, because I’m also running them successfully.


(J Wee) #183

Thanks for confirming the 2.3 snapshot supports this sensor. I think it might be easier just to uninstall 2.2 and install the 2.3 binding.
The Aeotec Z stick was just next to the door/window sensor during inclusion so I dont think it was a distance issue.


(J Wee) #184

I must be doing something wrong. This neo coolcam door/window sensor is still being seen in 2.3 snapshot as not in database, initialisation is not complete.
What am I doing wrong?
Thanks for all your help


(Mar Li) #185

hm. I have nearly the same combination like you.
I’m running OH2.2 with 2.3 snapshot binding from beginning of May on Win10 with Aeotec Gen5 Dongle. The only thing what I did was an inclusion with PaperUI instead of the button from the Aeotec Dongle. Placed the sensor nearby the Aeotec Dongle and voila


(Chris Jackson) #186

Maybe I missed it - what what is the device. Exactly what is printed in the UI? Does it show the product IDs? If not, then the initialisation is not complete and until this is done, it won’t be able to reconcile the database. If it’s a battery device, then it’s likely because you didn’t wake the device up.