New Aqara Hub & Aqara Home


(Dan Hall) #1

Hi All,

i was looking to install the MiHome Binding (https://www.openhab.org/v2.2/addons/bindings/mihome/) to connect up the new Aqara Hub, unfortunately it seems that with the new branding and upgrade of the Hub (i guess it’s v3) the necessary configuration for this binding is no longer possible.Here are my findings so far:

Initial step:

  • Hold button on Aqara Hub for 10 seconds until it flashes yellow

MiHome Android App:

Has the option to add the Aqara Hub or the MiHome hub, unfortunately when Aqara Hub is selected it searches but never finds it. The region can be set to Mainland China but this makes no difference.

Aqara Home Android App:

Has the option to add the Aqara Hub only, the app appears to connect to the Aqara Hub and passes it provided WiFi details (Aqara_Hub-CBDF is seen on the Router). The Aqara Hub reacts in Chinese following the WiFi connection and goes from blinking yellow, to blinking blue and then to dark (i guess it’s a connection confirmation). Unfortunately the Aqara App fails to make any follow up connection to the Hub and continues ‘Connecting’ until after about 80 seconds the following error appears:

‘Error 601, accessory not found in the back-end server.’

i would guess that this actually means ‘Your local server doesn’t support this device’. Unfortunately the Aqara Home app doesn’t have any visible option to change the locale/region!

My questions are:

  • Has anyone had any experience with the new Aqara Home/Aqara Hub and OpenHab? Are there any possible bindings?
  • Does anyone know how to change the region in the Aqara Home app?
  • Does anyone know how to obtain a developer key from Aqara Home once the Hub is successfully connected?

My research so far has led me to believe the Aqara Home App is receiving an update in early 2019 to ‘allow third party application connections’, this is 2nd hand information though, if anyone can provide anything more solid then it would be much appreciated. With enough information I’ll set about creating a new v2 binding for the Aqara Home enviroment.


(Angelos) #2

(Dan Hall) #3

Thanks for the link, that’s where i pulled my info.

I’ve done some further research and have concluded the following:

  1. Version 1.4.4 of the Aqara Home app auto-selects the server, if you’re in Europe, US or anywhere else that means your out of luck because only the China server supports updating the new Aqara Hub!

Luckily i found a solution!

If you want to use the Aqara Home app with your Aqara Hub and products outside China you’ll need to go back to version 1.4.1 by downloading the relevant APK from here (of course only applies to Android users):

https://apkpure.com/de/aqara-home/com.lumiunited.aqarahome/versions

With the older version you can upgrade the Aqara Hub to the newest firmware (currently 1.4.7), following this you can then upgrade the Aqara Home app to the latest version while keeping the connection to the Hub. You’ll also be able to use MiHome to control the Aqara Hub…result!

With the actual base setup now working I’ll see if i can find a way to get into this cheap little Chinese beastie externally with a Binding. I’m hesitant though, the dev’s for Aqara obviously haven’t thought this product through and are regressing rather than improving, I’ll only be drumming up new business for them and that seems a shame if they can’t sort their ‘3rd party connector’ side out properly.


(Angelos) #4

Why don’t you dump their Hub and use the ZigBee binding in openHAB2?

Ps: The info in that link are coming from an admin on the Aqara forums. I wouldn’t call them 2nd hand :slight_smile:
Ps2: Nice workaround!


(Dan Hall) #5

i mean i didn’t see the original post so i didn’t get the information first hand…I might be a little wary of information on the internet :smiley:

Which ZigBee controller might you suggest? Will any old zigbee dongle plugged into an OpenHabian box handle a connection to the switches and temp sensors i have from Aqara (if it’s Zigbee 3 standard)? It seems there’s only a very small ‘tested list’ and so no guarantee that it’ll work.

I’m edging towards this one:

Any ideas how well it plays with Aqara?


(Angelos) #6

:+1: Check here: https://community.aqara.com/forum/faq-1/topic/how-to-connect-the-aqara-hub-to-the-network-78 (search for “Didier3L” and see the replies to his posts)

I really don’t know… I don’t use ZigBee (yet)

Check:

  1. https://www.openhab.org/addons/bindings/zigbee/
  2. EU Zigbee dongle
  3. EU Zigbee dongle

I have seen that many use: https://elelabs.com/products/elelabs_usb_adapter.html
and/or https://www.silabs.com/products/wireless/mesh-networking/telegesis-modules-gateways/etrx3-zigbee-usb-sticks

Also: note: EU Zigbee dongle


(Dan Hall) #7

Thanks for all the info Dim…I’ll get to binging money on ZigBee Boards.