No HABPanel for OH3 because it's behind auth

Hey,

With OH3, HABPanel is no longer accessible without login. This means that when using the Android app, the user is greeted with:

No default panel configuration!
Sign in with the main UI to enable editing in HABPanel and set a default panel configuration.

Is there a workaround for this?

Thanks!

Set a default panel before using it. The same as in OH2. The only difference is administering now requires authentication. Viewing requires no login as far as I am aware.

I can’t find the option for default HABPanel in OH3. Any idea where it was moved to?

I have never used HABPanel but have both ON
H2 and OH3 installed for testing. Where was that setting located for OH2?

Originally under Configuration >Services > HABPanel but now there’s no more HABPanel in Services.

1 Like

I see it is OH2. @ysc can best answer. He designed HABPanel and the new Main UI.

Yes, this has changed. Now you “star” the configuration you want directly in the app, and it will be presented by default.

image

2 Likes

@ysc, I want to ask you for help in my problem, because I don’t know who to turn to. Maybe you can take some time to look at this?
Thanks!

Not the exact fix for the auth issue but will work for now

Sorry I´m having the same problem. I undestand that i can´t see habpanel inside my network because i can’t login because i don’t have any certificate. In use the remote login from openhabcloud I can see habpanel but i can see where i can modify It. I’m seeing a default habpnel.

So how can you change configurations without logging in? I’ve got two configurations for different screen layouts - One portrait layout for mobile phones, one landscape-style for my clock/control panel. This business of requiring logins for everything is damn annoying!

Can you post a screenshot of the login screen?

Well that’s what makes it super frustrating. There is no login screen. The side panel is just blank.

For details, I’ve managed to use a browser on my computer to set a default configuration by logging into the admin interface and then going to habpanel. Then on my raspberry pi, I’ve loaded up habpanel, which has launched the default config, which is all wrong for the raspberry pi’s screen layout. I have a separate config for it, but opening the side panel to switch configs shows me a blank panel, where before I had the option to use local config or load one of the server configs.

Does not work for me. I can’t “star” any configuration because there is no configuration displayed any more after migration to OH3. I’m stuck.

With Edge Browser i can edit, with Firefox not.

@ysc Hi Yannick,

I trying to access HABPanel on OH3.1-M3 from macos and I have tried Firefox, Google Chrome and Safari. Only with Chrome I get access to the HABPanel browser link. With Firefox and Safari I receive this screen:

With Google Chrome I see:

This is at least one of my stored configurations but my wanted configuration would be “Wetterstation-all”.

Is there a way to define a HABPanel configuration for a browser based access via PC (when not using the Android app)?

Thank you for your advice!

Cheers
Justus

You can either click on the “star” besides the panel configuration to make it the default displayed on all devices, or find a way to access the main UI, sign in as an admin and the settings will be available, including switching the current panel configuration.

I have logged in as an admin:

and when I click on HABPanel on the right I get:

But I do not see any thing where I could change the settings?

EDIT: It works with Google Chrome but not with Firefox and Safari!!!

And actually I would like use an existing configuration because after following your guidance I have now the settings gear wheel and can save the empty configuration but I would like to use my exiting one that I have saved from my 2.5.12 installation.

Ok, I logged also into the Android app and saved again the existing (2.5.12) HABPanel configuration under a new name and “stared” it. Some moments later it was also visible on Google Chrome.
In Safari it says that the “Default” theme is not supported with Safari and hence it makes no sense to continue testing.
With Firefox I finally get the gear wheel but it is not clickable (no reaction when clicking on it):