Official Google Assistant Integration for openHAB


Thanks for this great work!

I was wondering is there an option to capture voice data that is not assigned to an item. For example, right now I have been using voice into node red commands, then searching the sentence for key words (e.g., “heating” & “timer” & “20” & “minutes” etc). Basically bridging the gap until GA becomes increasingly supported in openhab. I also use it for scenes, such as “bedroom + off” and via mqtt configuring numerous devices, rather than saying this light off etc.

Really, all I need as a way to call an item some key phrase (its actual name eg “control”) and then the words after this become the string assigned to that item, which I can then parse as a rule. Is there anything like this?

from the google assisstant ifttt triggers page

Thanks, I had already figured it out. Once I realised I could do this to an item of string type is was simple. :slight_smile:

Same here. If I add the thermostat correctly (with “homekit:HeatingCoolingMode” tag), the thermostat is always offline.
I tried with “homekit:TargetHeatingCoolingMode” tag, without tag and without mode, always with the same result: thermostat online but mode offers “heating” and “off”. It seems that the three are the same as removing the mode.
@MARZIMA, any chance you could look into it, please?

I believe something has to be changed around the thermostat, beside what you mention, there are other problems as well…
Using Google Home app my thermostats works just fine. But on my Google Nest Hub, it reports that the current mode isn´t supported. I have no idea if this is a Google issue og a mix of Google and openhab. It´s pretty strange it works fine using the Google Home app, but not the Google Nest Hub.

Also Humidity seems to have vanished somehow.

Ok guys, just saw the thermostat issue.
I will dedicate time on weekend and check to fix it.

Sorry for my absenence…

BR Mehmet


Ahhh cool thank you

Can anyone please help me to understand the point of openhab2 integration to Google assistant? Isn’t it redundant? Please excuse my disconnect in this matter and thank you in advance for your help.
Furthermore I am extremely impressed with openhab! Such an amazing, gifted, creative group of people. Yours truly with much much appreciation Thank you All.

You bet. Many of us have devices that lack direct integration with Google Assistant. For example, Belkin chose not to enable my Wemo Maker in GA, so the only way I can control it is via openHAB’s integration. The same can be said for Z-Wave, Zigbee, and other devices that are only connected to the machine running openHAB.

Thank you @rpwong

Thx :+1:
As my new car does have Android Auto I am now able to control my garage door through the car’s voice control function.
openHAB is getting more and more amazing with every day one is using it.

1 Like

Hi @MARZIMA , any news with the thermostat problem , please ? :slight_smile: thank you

1 Like


I can confirm -changing from the “homekit:HeatingCoolingMode” to “homekit:TargetHeatingCoolingMode”
brings thermostat settings back to google home app. We can read temperature, humidity. However we cannot change heating mode with this NEW tag (using google home app, mode is constantly set to heating).
BTW1: from page quote" Please note: TargetTemperature has been renamed to homekit:TargetTemperature and homekit:HeatingCoolingMode has been renamed to homekit:TargetHeatingCoolingMode"

BTW2: I can change led stripes color using openhab, voice but unable with google home app, (it was possible earlier)

As I understandf, this only applies if you´re using Homekit.
I dont use Homekit. Temperatures are working just the way the description says (with the tag TargetTemperature). All my thermostats are set for “heating”. And they´re working fine in the Google home app.

Whats not working for me is:

  1. Google Nest Hub: When I choose a thermostat, the screen shows “the mode isn´t supported”.
    The mode works fine in the Google Home App. I have no idea if this is a Openhab issue or a Google issue. But it´s an issue which I believe should have some concern.
  2. Humidity seems to have dissapeared. It has never been visual value in Google Home app. But it has been working asking Google about the Humidity, and then the Assistant would return the actual Humidity value by voice. This doesnt work anymore, and have not been working for quite a few months now.

I really wish someone could confirm these issues. And second, someone take a notice of it. I have mentioned it quite a few times now…
I´ll try to rise a issue in github, whenever I get the hand onto how to do that.

As already written in the issue: Removing “homekit:” is working for me too. I think it does not matter if you just remove “homekit:” or change it to “homekit:TargetHeatingCoolingMode” or even use something completely different. You are able to change the temperature again without GA complaining. But using the thermostat mode will not be possible anymore.

I can confirm that the humidity does not work for me either. I tried different configurations (e.g. using a plain Number item or a Number:Dimensionless item) in combination with the “CurrentHumidity” tag. GA always answered: “Current humidity is zero.” - which obviously is wrong.

Thanks for confirmation, Christoph…

humidity work with google home here :

Group Sdb_Thermostat “Thermostat sdb” [“Thermostat”]
String Sdb_ThermostatMode “Mode Thermostat” (Sdb_Thermostat) [“HeatingCoolingMode”]
Number Sdb_ThermostatTarget “Temp Target [%.1f %unit%]” (Sdb_Thermostat)[“TargetTemperature”]
Number Sdb_ThermostatAmbientTemp “Temp actuel. [%.1f %unit%]” (Sdb_Thermostat) [“CurrentTemperature”] {channel=“mihome:sensor_weather_v1:158d00036b57f8:temperature”}
Number Sdb_ThermostatAmbientHumidity “Humidité” (Sdb_Thermostat) [“CurrentHumidity”] {channel=“mihome:sensor_weather_v1:158d00036b57f8:humidity”}

And for some reason I cant explain as I havn´t changed anything, Humidity is working for me again.

A post was split to a new topic: Problems with Google Assistant controlling Rollershutters