Problems with Google Assistant controlling Rollershutters

Was there made a fix for this problem, because i notice the following problem by me.
I have a quibino roller shutter. If i tell the openhab to set the shutter to 90% then it opens them so that they are 90% open, so just 10 % from the rollershutters are visible.
By the same setting if i tell the Google to set the blinds to 90% than are 10% open and 90% are visible.
If i use the invert percentage for the channel in openhab, than if i tell the openhab to set the shutter to 90% then it opens them so that they are 10% open, so just 90 % from the rollershutters are visible.
By the same setting if i tell the Google to set the blinds to 90% than are 90% open and 10% are visible.

@Rintano, I’ve closed the long Google Assistant thread to new posts and your’s is the last post and it doesn’t have a response yet so I moved it to it’s own thread. Tagging @MARZIMA in case you don’t see this, the post was originally a reply to one of yours.

Hallo, Any news or any idea?

@MARZIMA
Hi, any update in Google Assistant integration and NOT WORKING:
[“homekit:TargetHeatingCoolingMode”] vs [“homekit:HeatingCoolingMode”] ?
We can set target temperature, read target temperature, read humidity but we cannot set heatingCooling mode… so we don’t know what is current mode in specific room …

Does GA integration support “open shutter to 10%” and “close shutter to 10%” - the last should be the opposite of the first, not the same.
…or should get rid of the words “open” and “close” and only refer to something like “move shutter to 10%”?

(I’m not a native speaker, hopefully you understand me)

As i know it does not support. the 10% is the same, not important how the words are formuled.

You need to use the word ‘close’ or ‘open’, at least when talking German. ‘move to’ or similar don’t work.

Yes, you need to use the words “Open” and “Close”, but not important which you use, the shutter would move to the same position. The Open the blinds to 10% would do the same as Close the blinds to 10%.

How do you configure a rollershutter if you have both the Goodle assistant active and the Homekit AddOn?

For homekit the tag to be used is “WindowCovering” and for Google it needs to be “Curtain” or “Shutter”. How do I get my rollershutteritems to appear in homekit and Google assistant so I can use both. I.e. what would a configuration line look like.

Does anybody have other items than swithced and lights active in both. For switches and lights it works fine as there are TAGs that work for both (Switchable and LIghting)

Hi,

I don’t have Homekit, but i would Implement 2 “Dummy” items, one for the Google and one for the Homekit. Both would update the real shutter and each other by change in a rule. Or u can the real shutter item use for Homekit and make a dummy just for the Google.

Have you tried just adding both tags? I believe both HomeKit and GA will ignore tags it doesn’t understand.

Even though it may be totally obvious to most of you at least it took me quite some time to find out the right syntax to be able to tag a rollershutter item.

The documentation says it should be “tagged” with { ga=“shutter” } but of course usually you would have the { channel="…" } already in your item, so I defined it as follows

Rollershutter myShutter “Rolli” { ga=“shutter” channel="…" }

which fails because the syntax is wrong.

I wasn’t aware until after some while that the right syntax is that you have to use a COMMA between both.

 Rollershutter myShutter "Rolli" { ga="Shutter",channel="zwave:device:8ce122f5:node12:blinds_control"   }

and yes, if you look thoroughly in https://www.openhab.org/docs/configuration/items.html#_2-x-binding-configuration you will find examples with comma-separations in the curly brackets but even though I am working with OH for quite some time this never stroke me. So forgive me my ignorance but others may don’t know this as well, so I thought I’d share this.

Hi there,
playing around with rollershutters and google assistant, and stumbled on a possible problem.

Openhab assumes that 0 means open (shutter is up) and 100 means closed (shutter down).

Google assistant thinks the same (without inversion), however a command like “open/close the shutter to 20 percent” sends a command of 80 to Openhab.
If I invert the roll, 20 gets sent as 20, but now open means down and close means up.

According to the documentation, one of the two modes should word correctly:

Blinds and similar devices

Blinds should always use the Rollershutter item type. Since Google and openHAB use the oposite percentage value for “opened” or “closed”, the action will tranlate this automatically. If the values are still inverted in your case, you can state the [ inverted=true ] option for all Rollershutter items.

#

What am I missing?

Does this explanation help you?

To recap…

Google world says: xx% is the percentage of how much a blind is opened
-> “close” translates to 0%
-> “open” translates to 100%

openHAB world says: xx% is the percentage of how much a blind is closed
-> “down” translates to 100%
-> “up” translates to 0%

Therefore, by default the percentage is always inverted, so that “close” becomes “down”.
If a user does not want this inversion, the inverted=true option can be set.
But this also causes “close” being inverted to “up” and “open” becoming “down”.

Since Google only tells the open percentage (and not the verb “close” or “down”), we can not differentiate between saying “set blind to 100%” or “open blind”.
Therefore, we are not able to “not invert” the verbs, if the users chooses to invert the numbers.

Hello,

Thanks for the link. It confirms the problem. I’m happy to see it as an open issue.

When I add my rollershutters to GA they show up in the Google home up as blicds with a gear icon at the top but they don’t do anything.

The blinds do respond to voice command OPEN and close but within the Google home app the ico isn’t working at all.

Have I done something wrong ?

1 Like

This is the same for all of us. There seems just to be no support for manual control yet.

1 Like

Hey @michikrug!
Actually, I’m not sure you have a Google hub, but in fact there are blinds/shutters/rollershutters controls on it!! (Attached a picture below)
I’ve tried to understand the controls, or checking what they send back to OH but I’m not quite sure how to go about that.
Any hints? I’ve only just begun adopting a motor for my blinds into OpenHAB (in fact the motor is on the floor and I don’t know up from down yet…) so any pointers or relevant info is highly appreciated!

Hah knowing how to access the console is pretty handy!
So the “play” icon sends the “MOVE” command back to openHAB. The stop, well that one is pretty explanatory. My issue is now with the ones above, which I suppose controls the direction. Clicking those sends nothing back to openHAB…
Where to go from here, I wonder?

Nice to see some controls here. I do not own a Google Nest Hub, so will also not be able to test this.
Sending a direction together with “Move” is not implemented in the integration. Would probably need some conversion to “Up/Down”.

1 Like

The issue I’m facing now is that even openhab “rollers utter” item has three buttons at the item level, which appear to be “up” “down” “stop”, but, when clicking on them, the tasmotta controller receives “100” “0” or another “0” for stop.
Meaning that I cannot automate this properly.
Any hints?