Official Google Assistant Integration for openHAB

Change your phone to english (US) and try again.
It seems very odd if you cant setup the device anymore due to changing language.

I am now writing this comment for probably fourth time, simultaneously debugging, and come to some interesting conclusions (maybe someone reported this before, not sure)

I had a bug with missing items, after my phone app updated. I had one item defined as:

Switch KitchenCatFountain_SwitchBinary “Cat Fountain” [ “Switchable” ] {channel=“zwave:device:0aa4dfe7:node12:switch_binary”}

(I have few more missing possibly)
I did not change anything in my items, but after app update it disappeared from the app, I do not see the device on the phone. I asked google to update items, and it said ok, updating…
However, I can ask google to turn on the missing item, and it would wait 15s and say that it cannot reach openhab. Strange, but here is the conclusion… in my items file it appears that first item that has tags must be without spaces, otherwise warning is thrown in logs.

2018-10-24 23:28:42.714 [WARN ] [mon.registry.AbstractManagedProvider] - Could not update element with key _tags:KitchenCatFountain_SwitchBinary in ManagedMetadataProviderImpl, because it does not exists.

So the very first item with tags has to be [“Switchable”] not [ “Switchable” ]. Others can (possible have to be) with spaces.
If I see this error in the logs after updating the file, some items are missing after I ask google to synchronize.

Btw, how to use new [“Outlet”] tag? Do I need to update something other then the item itself?
When I use Switchable it appears, but if I change to Outlet then it gets removed from the home app.

(also @MARZIMA , I am very much looking forward to the mentioned roller shutter (it can be used for motorized shades right?) :slight_smile: )

I’d say that this is probably a defect

Thank you all so much. I succeeded in connecting my Google Home Dutch language to OpenHAB. The problem was indeed in the items file. I filled the items file with the console and after that the connection succeeded.

The only thing I am figuring out now is what the right voice commands in Dutch are to control my light switches. I haven’t found out so far.

But all thanks to you!

Regards,
Simon

I´m not quite sure about the dutch help for Google Assistant… But try this link:
https://support.google.com/assistant/answer/7540703

Got it working by changing the settings on the router. It turns out that Google Home from the US does not support WIFI channels above 10. When I set a fixed channel below 10 it connected without problems. Still can’t control the lights with Danish though. I guess that it is not an openHAB issue, but thanks for all the help and suggestions anyway.

Thank you. But it’s still not working. The name of the switch which I see in Google Home is ‘lichten aan’ which is the same as ‘lights on’ in English. It works fine when using the switch by hand but I haven’t a clue hoe to use it with voice. I tried every commando I can think of but it doesn’t response.

Until a few days ago voice commands did work for me (in dutch). You could say things like: “zet de lampen in de woonkamer aan” or “zet de hanglamp op 50%”.

Unfortunately all these commands don’t work anymore as well in Dutch as in English. But these are the commands you should be able to use.

  • Jordo

Oh that’s a pity. I use an integration with my Niko home automation system (via OpenHab). I created Items (see picture, ‘lichten aan’ and ‘lichten uit’) but don’t know how to voice control them in Dutch.

I would recommend that the Item label should be just the name of your device, e.g., “Lamp - Bedroom” I found I had to reverse the naming so that I could see what the device was in the Google Home app. Otherwise I could just see the name of the room. This works because the device is assigned to a room so I know that way which device it is.

I then assign that device to the “Bedroom” room with the Google Home app.

I’m speaking here only knowing how this behaves in my English (US) interface.

“OK Google, turn on (or off) the Lamp in the Bedroom.”
or, if I’m in the room speaking to the Google Home in the Bedroom
“OK Google, turn on (or off) the Lamp.”

Mike

Around a week or so ago, my OpenHab <-> Google Home link died… Google Assistant just started saying “OpenHab isn’t available right now” when I tried to use a command. I put off fixing it straight away as I was about to get a Google Home Hub, and figured I’d sort it out then. I can’t recall any change I made to Google Home or OpenHab that might of precipitated this issue.

I got my Google Home Hub yesterday, so went to work trying to fix it.
First thing I tried was simply removing the OpenHab link in Home app and re-adding, before I even took the Home Hub out of the box. It fails with the error “Couldn’t update the setting. Check your connection.” after the myOpenHab authorisation screen goes back to the Home app.

I have tried everything I can think of:

  • rebooted phone & OpenHab, cleared Home app cache on phone, uninstalled and reinstalled Home app, tried the Home app on a different Android device
  • commented out all the relevant exposed tags to my items in OpenHab until only one remained, also took them out of the OpenHab Cloud Connector config
  • confirmed myOpenHab connection working correctly, (it was, but for good measure I deleted my account and recreated anyway). IFTTT is also working normally with myOpenHab
  • removed all other device links in the Home app (Hue, Sensibo)
  • completely removed my “home” in the Home app and made a new one, including hard resetting all the Home devices and setting them up from scratch

No matter what I do, I keep getting the same error when trying to establish the OpenHab <-> Home link inside the Home app. myOpenHab appears to be authorising the Home app correctly

The reported error seems relatively common, I’ve read every related thread I can find. Multiple people have reported it can be related to tag syntax, so I have reviewed all my items in OpenHab very closely and can’t find anything wrong. The fact the OpenHab link died without any changes to OpenHab items makes me think this is not the source of my particular problem. It’s very annoying, I’ve been using my Google Home devices to access OpenHab functions for months.

I really don’t know what I’m missing here, it’s super annoying. Would be grateful for any suggestions. I also can’t find any way to debug the failed connection attempt directly.

Running OpenHab 2.3 on a Pi3

  1. You need to check your items and their tags. This is VERY important. If one tag is failing, the whole connection to Google Assistant will fail.

  2. Connection to Google Assistant require at least one item beeing tagged. If you have removed all tagging, the connection will fail (again).

In your situation, I would recommend scratch every items having Google Assistant tags, except one single item. Then play around with that item only, getting the connection up running.

Note - A known issue, sometimes it requires two tries when trying to establish the connection between openhab and Google Assistant.

Yeh, I’ve seen discussion about that elsewhere. I’ve currently only got one tag left, still nothing working.

Could you post your item?

I have numerous item files, but the only one left with a tag that isn’t commented out is shown below:

// Outside Front Spotlight
Switch SmartWallSwitch_OutsideFront_Switch  "SmartWallSwitch Outside Front Switch"      <light> ["Lighting"] { channel="zwave:device:512:node17:basic_switch_binary1" }
Number SmartWallSwitch_OutsideFront_kWh     "SmartWallSwitch Outside Front kWh"         <energy> { channel="zwave:device:512:node17:meter_kwh1" }
Number SmartWallSwitch_OutsideFront_Watts   "SmartWallSwitch Outside Front Watts"       <energy> { channel="zwave:device:512:node17:meter_watts1" }

//Outside Back Spotlight
Switch SmartWallSwitch_OutsideBack_Switch   "SmartWallSwitch Outside Back Switch"       <light> /*["Lighting"]*/ { channel="zwave:device:512:node18:basic_switch_binary1" }
Number SmartWallSwitch_OutsideBack_kWh      "SmartWallSwitch Outside Back kWh"          <energy> { channel="zwave:device:512:node18:meter_kwh1" }
Number SmartWallSwitch_OutsideBack_Watts    "SmartWallSwitch Outside Back Watts"        <energy> { channel="zwave:device:512:node18:meter_watts1" }

//Garage Lights -> 1 - Main Area, 2 - Back Area
Switch SmartWallSwitch_Garage_Switch        "SmartWallSwitch Garage Switch"             <switch> /*["Lighting"]*/ { channel="zwave:device:512:node49:basic_switch_binary1" }
Number SmartWallSwitch_Garage_kWh           "SmartWallSwitch Garage kWh"                <energy> { channel="zwave:device:512:node49:meter_kwh1" }
Number SmartWallSwitch_Garage_Watts         "SmartWallSwitch Garage Watts"              <energy> { channel="zwave:device:512:node49:meter_watts1" }
Switch SmartWallSwitch_GarageBack_Switch    "SmartWallSwitch Garage Back Switch"        <switch> /*["Lighting"]*/ { channel="zwave:device:512:node49:basic_switch_binary2" }
Number SmartWallSwitch_GarageBack_kWh       "SmartWallSwitch Garage Back kWh"           <energy> { channel="zwave:device:512:node49:meter_kwh2" }
Number SmartWallSwitch_GarageBack_Watts     "SmartWallSwitch Garage Back Watts"         <energy> { channel="zwave:device:512:node49:meter_watts2" }

//Bathroom -> 1 - Extraction Fan, 2 - Heat Lamps
Switch SmartWallSwitch_Bathroom_Fan_Switch  "SmartWallSwitch Bathroom Fan Switch"       <switch> /*["Switchable"]*/  { channel="zwave:device:512:node51:basic_switch_binary1" }
Number SmartWallSwitch_Bathroom_Fan_kWh     "SmartWallSwitch Bathroom Fan kWh"          <energy> { channel="zwave:device:512:node51:meter_kwh1" }
Number SmartWallSwitch_Bathroom_Fan_Watts   "SmartWallSwitch Bathroom Fan Watts"        <energy> { channel="zwave:device:512:node51:meter_watts1" }
Switch SmartWallSwitch_Bathroom_Heat_Switch "SmartWallSwitch Bathroom Heat Switch"      <switch> /*["Switchable"]*/  { channel="zwave:device:512:node51:basic_switch_binary2" }
Number SmartWallSwitch_Bathroom_Heat_kWh    "SmartWallSwitch Bathroom Heat kWh"         <energy> { channel="zwave:device:512:node51:meter_kwh2" }
Number SmartWallSwitch_Bathroom_Heat_Watts  "SmartWallSwitch Bathroom Heat Watts"       <energy> { channel="zwave:device:512:node51:meter_watts2" }

That sole tagged item is also the only one exposed via the Cloud Connector config and myOpenHab shows it working as expected.

Looks good…
One last wild shot.
Try insert space in the tag, like this [ “Lighting” ] indsted of this [“Lighting”] It used to be a problem sometime ago.

Sadly, that didn’t work either. :frowning: Thanks for the help though.

It’s all very strange. Would be helpful if the Google Home app gave more details back when it failed.

@MARZIMA

Where new tags Outet and Scene integrated?
I see that @aart’s pull request were merged, but sync my devices won’t find the items with the new tags…
What should I do?
Should I unlink and re-link again?
I’m running snapshot #1400

Agree. I think @matt1 started a thread a coupple of months ago, suggesting the same. But I´m not quite sure if there were any outcome.
Also I really would like a real (true) documentation of this integration. The only thing I can find is the link to github, but I think it should be plac in the official openhab doc insted. Specially due to the lack of details when things aren´t working, the doc´s is very important and needs to be very specific and precise.

In the mean time… I really wonder about your problem… I have run out of ideas, except to clear cache and tmp, and restart. Then try add the conection again.

It is (currently) not possible to give a custom error response to Google Assistant from OpenHab.
I’ve updated the documentation page, but it needs to be deployed.
In the meantime, I’m writing a tool to validate (and mabe fix) your items in the way the google assistant does this, but my time is also limited…