Official Google Assistant Integration for openHAB

Tags: #<Tag:0x00007f2fb5258078> #<Tag:0x00007f2fb525fee0> #<Tag:0x00007f2fb525fbe8>

Yes, same behaviour for me.

Are you able to control them using the Google Home app or only voice controls?

Only voice. On Google Nest Hub (former Google Home Hub) it displays information “Touch controls are limited right now, but you can still use voice to control this device”

1 Like

Just a question. I exposed one of my Items to myopenhab.org and it showed up there. Afterwards, I tried to connect Openhab through the GH App but it always says “Couldn’t update the settings. Check your connection”. I unlinked every GH-Auth from myopenhab.org but it’s still not working. All my items are labelled and this item is also tagged the right way. Is there anything I forgot or why GH don’t want to connect with OH

I used google camera and connected it with my premium snapchat account ,my streaming and other camera functionalities are working well .
you can also use this link for further details how to get premium snapchat for free

Happy to Help :slight_smile:

Yes I am afraid that I have 1 tag only for each item: everything was ok but suddenly stopped to work the sync command.

Hi @alex_the2, did you go through the steps listed here?

Sorry if you’ve already been through this page without success. I’m just trying to establish what you’ve done so that we can get your issues straightened out.

Even the same problem. Openwebnet and GH does not work the Thermostat.

Hi, I have had openhab working for about a year. Recently.moved it from a raspberry pi to a new pi, and was working also (I created a new openhabcloud account for that new device).

Anyway, it was working and then I added some new devices via mqtt and went to.sync devices but got error messages and it failed. I was still able to control devices ety, just not get it to sync new devices.

Did lots of things, probably not in a very well.structured fashion tbh, but ended out removing the newly created devices and restarting openhab service to see if that would help, and it didn’t.

So, I said I would unlikely my openhab account from Google and link it again.

I unlinked successfully, but now it is refusing to link again, (via the home app), with it giving me the error “couldn’t update the setting, check your cinnection”

Openhab cloud is working, Google home is working, but just the linking is failing , and I cant figure out for the life of me what the problem could be.

Any assistance would be appreciated.

I confirm the same for me with the Blinds tag

Yes but it was working very well till some time ago: I was able to ask the temperature and set the heating temp desired. Now it does not connect to the thermostat.

I had the same problem
i solved it with a cache clearing in OH and a factory reset of GH

My Blinds are working fine now, but only with voice command.
My thermostats are now also down since the last update of the Google Assistant.
I have no idea why…

I am also a problem.

@rpwong
Yeah I made all the steps, until the Authentication as it’s failing there. I already cleared OH-cache and reinstalled OH completly.

How do you clear the cache in openhab ?

I posted a new issue:

My blinds is working but they are inverted.

I recently implemented a garage door (using Garadget) and linked it to Google Home via myopenhab. I noticed when I told Google to open, it sends value 100 and when I told it to close it sends 0. So I wrote a rule to deal with that and invert the value myself.

The remaining problem is when the garage door is closed, and I asked Google, it would say that it’s open and vice versa, but that’s not a big deal.

@All,

Latest state with fix is deployed. Please test it folks and let me know if it is working fine.

Thanks & BR
Mehmet

1 Like